LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-20-2003, 09:22 PM   #1
oot
Member
 
Registered: Dec 2002
Distribution: Slackware 12.0
Posts: 240

Rep: Reputation: 30
ogg123 can't open audio device


My sound card is supported via oss drivers. To use them, mpg321 requires the option "-o oss" to tell it that, then it works fine.

I can't get ogg123 to work at all. I get the error message

Quote:
libao - OSS cannot set rate to 44100
Error: Cannot open device oss.

Segmentation fault
I have tried passing it the option "-d oss" and I get exactly the same error.

Help please?
 
Old 05-20-2003, 09:24 PM   #2
oot
Member
 
Registered: Dec 2002
Distribution: Slackware 12.0
Posts: 240

Original Poster
Rep: Reputation: 30
Hehe... of course, I get it working RIGHT AFTER I ask for help... if anyone else has this problem and finds it in a search or something, try using the option "-d esd".
 
Old 05-21-2003, 05:54 AM   #3
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Or try with no option at all? It should auto detect whether you're running a sound server or not
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot open audio device deus_machinarum SUSE / openSUSE 8 06-20-2005 04:44 PM
audio device fails to open on arch linux, even after alsa config sether Linux - Hardware 1 10-07-2004 12:43 AM
[Audio] Cant open device (permissions) seb3579 Linux - Hardware 3 05-14-2004 11:24 PM
XMMS problem : ** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): sureshrk19 Slackware 4 04-01-2004 09:17 PM
ogg123 - error opening device oss iTux Linux - Software 1 12-15-2003 11:02 PM


All times are GMT -5. The time now is 04:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration