LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-19-2008, 02:43 PM   #1
pjohnson
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
ocfs2 Unable to load module "configfs"


I am running RedHat 5 Update 4. I am trying to setup ocfs2.
I have installed the required rpm's

[root@oaprod1 OCFS2]# rpm -qa | grep ocfs2
ocfs2-tools-1.2.7-1.el4
ocfs2-2.6.9-42.0.10.EL-1.2.9-1.el4
ocfs2console-1.2.7-1.el4


[root@oaprod1 OCFS2]# /etc/init.d/o2cb status
Module "configfs": Not loaded
Filesystem "configfs": Not mounted
Module "ocfs2_nodemanager": Not loaded
Module "ocfs2_dlm": Not loaded
Module "ocfs2_dlmfs": Not loaded
Filesystem "ocfs2_dlmfs": Not mounted

[root@oaprod1 OCFS2]# /etc/init.d/o2cb load
Loading module "configfs": Unable to load module "configfs"
Failed


When I use ocfs2console I get the message

Could not start cluster stack. This must be resolved
before any OCFS2 filesystem can be mounted.


Also in /var/log/messages

Jun 19 15:49:16 oaprod2 modprobe: FATAL: Module configfs not found.
Jun 19 15:55:31 oaprod2 modprobe: FATAL: Module configfs not found.

[root@oaprod1 log]# locate configfs
/lib/modules/2.6.9-42.0.10.EL/kernel/fs/configfs
/lib/modules/2.6.9-42.0.10.EL/kernel/fs/configfs/configfs.ko



What am I missing?

Thanks,
Patti

Last edited by pjohnson; 06-19-2008 at 04:08 PM.
 
Old 06-19-2008, 04:37 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,003
Blog Entries: 54

Rep: Reputation: 2757Reputation: 2757Reputation: 2757Reputation: 2757Reputation: 2757Reputation: 2757Reputation: 2757Reputation: 2757Reputation: 2757Reputation: 2757Reputation: 2757
Quote:
Originally Posted by pjohnson View Post
What am I missing?
Can you modprobe/insmod configfs.ko manually? Else try and check dmesg?

Last edited by unSpawn; 06-19-2008 at 04:39 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to load module "ati" (module does not exist, after upgrad from Redhat 3 to 5. perrym8 Red Hat 2 07-24-2007 10:14 AM
X won't load i810 module for 915GM video card "module requirement mismatch" yougene Slackware 10 03-18-2006 10:02 AM
Flash won't load in Konqueror - "Unable to load Netscape plugin" rollo Linux - Software 2 09-10-2005 12:28 PM
unable to load module "oracleasm" jkmartha Linux - Software 4 07-27-2005 10:39 AM
"Failed to load module "i915"" Kane635 Linux - Software 0 11-22-2004 08:17 PM


All times are GMT -5. The time now is 02:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration