LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-24-2007, 03:56 PM   #1
jadex
LQ Newbie
 
Registered: Jan 2007
Location: San Diego, CA
Distribution: openSUSE 10.2
Posts: 14

Rep: Reputation: 0
NVIDIA install driver problems; Cannot select a higher Refresh rate


I attempted to install the NVIDIA driver for my Linux OpenSuse 10.2 version.

First, I installed the kernel-sources package (already had gcc and make) as instructed on one of the forums. When I ran the NVIDIA installer (sh ...*.run), I accepted the agreement and then a message appeared which said it couldn't find something for the kernel. After I clicked OK, it proceeded to install the driver (whereas before I installed the kernel-sources, the installer exited at this point).

I assumed the driver was installed successfully since Sax2 displayed the correct monitor & card and a game I had tried playing earlier (and gave me a "3D graphics not enabled" message) was now able to run (no message appeared).

However, I still have a problem setting the refresh rate for my monitor (looks a bit blurry at the moment):

When I try to configure the desktop settings (right-click on desktop -> Configure Desktop...), the display settings will not let me select a Refresh rate greater than 50Hz. The screen size is set to the correct 1280x1024.

My Computer Display Info shows correct Vendor & Model, but "unknown" Driver.

Sax2: X11 Configuration screen (YaST Control Center -> Hardware -> Graphics Card and Monitor) displays correct Card & Monitor (NVidia GeForce 7900 GS; SNY Sony SDM-HS93). Resolution is set to 1280x1024(SXGA) and Colors is set to 16.7 Mio. [24 Bit].

Any thoughts on what may be the problem?

Thanks.
 
Old 01-24-2007, 04:03 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
You'll need to specify the refresh in your xorg.conf file. For example:

Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "DFP: 1280x1024_60 +0+0"
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
However, the refresh rate only controls the flickering that you might see, not blurriness. That 's usually caused (on an LCD display) when the resolution does not match the physical resolution.
 
Old 01-24-2007, 04:11 PM   #3
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,275

Rep: Reputation: 126Reputation: 126
Try running nvidia-settings. If you have it, then you know the nvidia installer worked. It allows you to change the refresh rate and other things. You did change the xorg.conf file to use the nvidia driver or allow the .run program to do it for you, right?
 
Old 01-24-2007, 04:54 PM   #4
jadex
LQ Newbie
 
Registered: Jan 2007
Location: San Diego, CA
Distribution: openSUSE 10.2
Posts: 14

Original Poster
Rep: Reputation: 0
It appears the NVidia installer worked since I ran the nvidia-settings and the settings dialog appears. I did let the .run program change the xorg.conf file for me when I did the install...

By the way, where is this file located?
 
Old 01-24-2007, 05:13 PM   #5
jadex
LQ Newbie
 
Registered: Jan 2007
Location: San Diego, CA
Distribution: openSUSE 10.2
Posts: 14

Original Poster
Rep: Reputation: 0
I found the xorg.conf file in two locations:
etc/X11/
var/lib/sax

Both files appear to be the same. However, comparing my file to your sample above, does this look a bit strange? I don't have any display info after my "Identifier" line which is at the end of the block.

Code:
Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Last edited by jadex; 01-24-2007 at 05:16 PM. Reason: Added code tag.
 
Old 01-24-2007, 11:54 PM   #6
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Try adding Option "UseEDIDFreqs" "FALSE" to the device section.

My system got stuck at 75 Hz (on 1024x768) and that did the trick to get higher refreshrates.
 
Old 01-27-2007, 08:27 PM   #7
jadex
LQ Newbie
 
Registered: Jan 2007
Location: San Diego, CA
Distribution: openSUSE 10.2
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks Wim, but unfortunately when I update my config file, it changes my configuration back to 800x600 and the refresh rate is stuck at 50Hz.

I found that I have two locations for the xorg.conf file. The max resolution I can get via the NVIDIA-settings display is 60 Hz.
 
Old 01-27-2007, 08:56 PM   #8
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,275

Rep: Reputation: 126Reputation: 126
Xorg sees your xorg.conf file in /etc/X11/xorg.conf. What do you have for the Monitor section? For your monitor, it should be similar to the following:

Section "Monitor"
Identifier "whatever your identifier is"
Option "DPMS"
HorizSync 28-80
VertRefresh 48-75
EndSection

You may or may not have the DPMS line.
 
Old 01-27-2007, 09:37 PM   #9
jadex
LQ Newbie
 
Registered: Jan 2007
Location: San Diego, CA
Distribution: openSUSE 10.2
Posts: 14

Original Poster
Rep: Reputation: 0
This is my current Monitor, Device, and Screen settings in the xorg.conf file:

Code:
Section "Monitor"
    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Sony SDM-HS93"
    HorizSync       28.0 - 65.0
    VertRefresh     48.0 - 65.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7900 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "1280x1024 +0+0; 640x480 +0+0"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
While it looks similar to your example, the max HorizSync and VertRefresh values are 65.0. Strangely enough, the max I am able to set via the Display settings in Configure - KDestop is 50Hz, while the nvidia-settings dialog has "Auto" and "60Hz" available.
 
Old 01-27-2007, 10:41 PM   #10
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,275

Rep: Reputation: 126Reputation: 126
Well, my example was taken from the sony specs for your monitor. Your GeForce 7900 should be able to drive pretty much anything you throw at it to full resolution.

http://www.iq.sony.com/srvs/DocsConnect/docget.asp?manualid=11023&DL=',600,560,10,10,'Manuals'

I have an old Nvidia ti-500 and a Proview PL916S. The nvidia-settings program offers me 60Hz, 70Hz, and 75Hz at 1024x768 with a depth of 24. Here is my xorg.conf, not one I've mocked up for you. The numbers were taken from the specs for my monitor, so they don't necessarily apply to yours. I guess I can't think of any reason for this not to be working for you if you have it setup the way I posted above.

Hmm, on second thought, how about removing the "1600x1200" from your config file and see if that changes things.

My file: /etc/X11/xorg.conf:
Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ExplorerPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "Device"
	Identifier	"nVidia Corporation NV11 [GeForce2 Ti-500]"
	Driver		"nvidia"
#	BusID		"PCI:3:0:0"
EndSection

Section "Monitor"
	Identifier	"PL916s"
	Option		"DPMS"
	HorizSync	30-80
	VertRefresh	60-75
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation NV11 [GeForce2 Ti-500]"
	Monitor		"PL916s"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA install driver problems; Cannot select a higher Refresh rate. jadex Linux - Software 3 01-24-2007 11:56 PM
Xtreme Newbie: Higher CRT Refresh Rate mrpectate Linux - Newbie 4 01-30-2006 03:29 PM
X.org -higher refresh rate warinthepocket *BSD 3 01-01-2006 12:06 AM
Some question about kde3.5, cant get higher refresh rate cold95 Linux - Software 15 12-29-2005 05:08 AM
Need higher refresh rate 1madstork Debian 6 11-26-2004 02:08 AM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration