LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-27-2004, 08:15 PM   #1
xbrotherx
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
Nvidia help!!!!


I'm kinda upset about this problem . Currently i just went from Suse Linux to Fedora and for some reason when i turn off my x server and try to install my video card driver it keeps telling me that my x server is on.

When i check the log it says:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Feb 27 19:45:02 2004

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Feb 27 19:45:02 2004

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel source path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X0-lock' exists... an X server appears to be running
ERROR: You appear to be running an X server; please exit X before installing.
For further details, please see the section INSTALLING THE NVIDIA DRIVER
in the README available on the Linux driver download page at
www.nvidia.com.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
I knwo i have the x server shut down so im kinda left out ption and im really not to used to fedora scince i just switched from Suse
 
Old 02-27-2004, 08:37 PM   #2
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
What are you doing to turn it off? Try a method where you are booting up without using X, like single user mode or init 3. Here are some instructions:

http://www.linuxquestions.org/questi...hreadid=115039
 
Old 02-29-2004, 05:19 AM   #3
John-e
LQ Newbie
 
Registered: Feb 2004
Distribution: SuSE 8.2 Professional
Posts: 15

Rep: Reputation: 0
ok, I have a similair problem, except it tells me the drivers are already installed, plus I get the splash screen. I have also changed driver "nv" to "nvidia".


nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Feb 27 22:39:24 2004

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel source path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
5336). As part of installing this driver (version: 1.0-5336), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: No)
-> Installation aborted.

And here you see the output of 3Ddiag, if the drivers are installed why do I get a failed here??

3Ddiag version 0.691
Verifying 3D configuration:
Using 3dinfo
************************************************************

Verifying 3D configuration based on XFree86 4 for 3D board
"nVidia Corporation GeForce DDR (10de@0101)":


Verifying driver installation:
nvidia ... failed!
======================= !!! WARNING !!! ========================
Due to license issues only a Dummy Nvidia 2D/3D driver with
Software 3D/OpenGL rendering is provided. Please download
the official 2D/3D Nvidia driver from the nVidia webserver
(http://www.nvidia.com), if you want to use 3D hardware
accelerated 3D/OpenGL.
================================================================

Tests for correct OpenGL libraries/GLX extensions:

Test for correct XFree86 version ... done.

Tests for XFree86 configuration:
Config File /etc/X11/XF86Config ... done.
Driver ... done.
Color Depth ... done.
Extensions ... done.
Options ... done.

----------------------- NOTE -----------------------------------
If 3D hardware OpenGL configuration is not stable enough, you
should switch back to 'Mesa Software Rendering'. You can
verify this configuration with the command "3Ddiag --mesasoft".
----------------------- NOTE -----------------------------------

Checking GLU/glut runtime configuration:
GLU ... done (package mesaglu)
glut ... done (package mesaglut)
AlfaServer:~ # 3Ddiag
3Ddiag version 0.691
Verifying 3D configuration:
Using 3dinfo
************************************************************

Verifying 3D configuration based on XFree86 4 for 3D board
"nVidia Corporation GeForce DDR (10de@0101)":


Verifying driver installation:
nvidia ... failed!
======================= !!! WARNING !!! ========================
Due to license issues only a Dummy Nvidia 2D/3D driver with
Software 3D/OpenGL rendering is provided. Please download
the official 2D/3D Nvidia driver from the nVidia webserver
(http://www.nvidia.com), if you want to use 3D hardware
accelerated 3D/OpenGL.
================================================================

Tests for correct OpenGL libraries/GLX extensions:

Test for correct XFree86 version ... done.

Tests for XFree86 configuration:
Config File /etc/X11/XF86Config ... done.
Driver ... done.
Color Depth ... done.
Extensions ... done.
Options ... done.

----------------------- NOTE -----------------------------------
If 3D hardware OpenGL configuration is not stable enough, you
should switch back to 'Mesa Software Rendering'. You can
verify this configuration with the command "3Ddiag --mesasoft".
----------------------- NOTE -----------------------------------

Checking GLU/glut runtime configuration:
GLU ... done (package mesaglu)
glut ... done (package mesaglut)


glxgears runs at less then 400 frames, quite sad... Here's an extract of the output of xdpyinfo :

name of display: :0.0
version number: 11.0
vendor string: The XFree86 Project, Inc
vendor release number: 40300000
XFree86 version: 4.3.0
maximum request size: 4194300 bytes
motion buffer size: 256
bitmap unit, bit order, padding: 32, LSBFirst, 32
image byte order: LSBFirst
number of supported pixmap formats: 7
supported pixmap formats:
depth 1, bits_per_pixel 1, scanline_pad 32
depth 4, bits_per_pixel 8, scanline_pad 32
depth 8, bits_per_pixel 8, scanline_pad 32
depth 15, bits_per_pixel 16, scanline_pad 32
depth 16, bits_per_pixel 16, scanline_pad 32
depth 24, bits_per_pixel 32, scanline_pad 32
depth 32, bits_per_pixel 32, scanline_pad 32
keycode range: minimum 8, maximum 255
focus: window 0x5800002, revert to PointerRoot
number of extensions: 28
BIG-REQUESTS
DOUBLE-BUFFER
DPMS
Extended-Visual-Information
FontCache
LBX
MIT-SCREEN-SAVER
MIT-SHM
MIT-SUNDRY-NONSTANDARD
NV-CONTROL <------- these are the important ones, yet I seem to be
NV-GLX <------- missing NVIDIA-GLX, this seems like the MESA??
RANDR
RENDER
SECURITY
SHAPE
SYNC
TOG-CUP
X-Resource
XC-APPGROUP
XC-MISC
XFree86-Bigfont
XFree86-DGA
XFree86-Misc
XFree86-VidModeExtension
XInputExtension
XKEYBOARD
XTEST
XVideo
default screen number: 0
number of screens: 1

-------------------------
I'm using XF86Config v.4.7 yet since I have no XF86Config-4 I suppose it uses the default XF86Config. Here it goes:

# /.../
# SaX generated XFree86 config file
# Created on: 2004-02-27.
#
# Version: 4.7
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.7)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "RandR" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "speedo"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "MapName" "Standard Keyboard [ pc102 ]"
Option "Protocol" "Standard"
Option "XkbLayout" "es"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "ButtonNumber" "6"
Option "Device" "/dev/mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
DisplaySize 320 240
HorizSync 27-48
Identifier "Monitor[0]"
ModelName "BELL PLUG & PLAY 2024S"
VendorName "PACKARD"
VertRefresh 42-60
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 79.87 1280 1296 1552 1736 1024 1024 1031 1070
Modeline "1024x768" 63.74 1024 1024 1200 1352 768 768 775 802
Modeline "800x600" 37.44 800 816 928 1072 600 600 607 626
Modeline "640x480" 23.96 640 656 720 864 480 480 487 501
Modeline "1280x1024" 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +HSync +VSync
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce DDR"
# BusID "1:0:0" <---- this I have commented out to try since with 1
Driver "nvidia" <---- grafix card it is not obligatory yet with no effect
Identifier "Device[0]"
Screen 0
# Option "Rotate" "off" <---- This I have tried both ways as well yet nothing
VendorName "nvidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
# Option "Clone" "off" <--- More options I have tried both commented out
# Option "Xinerama" "off" <--- and not. Neither makes any difference..
Screen "Screen[0]"
EndSection

#Section "DRI" <--- this section as well, I have tried it both ways
# Group "video"
# Mode 0660
#EndSection


------------------

My Gforce 256 DDR is AGP, must I define it like PCI or something wierd and strange like that?? Do I have to modify the cards file??

Any suggestions or tips are welcome

Thanx again and see you around guys!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help editing xf86config for nvidia geforce mx440 after installing nvidia driver linguist Linux - Newbie 11 06-13-2006 07:31 AM
Can't build nvidia.ko on MEPIS3.3. Read /usr.../nvidia-kernelsource/README.debian digorykirke Linux - Software 0 03-16-2005 03:10 AM
Nvidia fx5500 mandrake 10.1 problem:Nvidia in /etc/modprobe.preload doesn't work eikeland Linux - Hardware 5 01-17-2005 03:09 PM
Trouble with new nVidia driver installation...no nvidia logo and KDE no start up mdb Linux - Software 8 08-18-2004 10:45 AM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 06:38 AM


All times are GMT -5. The time now is 12:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration