LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2013, 05:14 PM   #1
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Rep: Reputation: Disabled
Nvidia hdmi audio problem


I recently installed the Nvidia drivers on my m11x and after installing bumblebee they finally started working. I can't get audio to work however over hdmi.

When I have it plugged in the video comes up on the tv but no audio. If I go to sound settings it only shows the built in audio anolog stereo. I've seen other forums where they go to the hardware tab and pick the other hardware card but in my sound settings there is no hardware tab.

when I do aplay -l I get

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC665 Analog [ALC665 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

aplay -L shows

default
Playback/recording through the PulseAudio sound server
sysdefault:CARD=Intel
HDA Intel, ALC665 Analog
Default Audio Device
front:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
Front speakers
surround40:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
dmix:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
Direct sample mixing device
dsnoop:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
Direct sample snooping device
hw:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
Direct hardware device without any conversions
plughw:CARD=Intel,DEV=0
HDA Intel, ALC665 Analog
Hardware device with all software conversions
hdmi:CARD=NVidia,DEV=0
HDA NVidia, HDMI 0
HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
HDA NVidia, HDMI 0
HDMI Audio Output
hdmi:CARD=NVidia,DEV=2
HDA NVidia, HDMI 0
HDMI Audio Output
hdmi:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
HDMI Audio Output
dmix:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct sample mixing device
dmix:CARD=NVidia,DEV=7
HDA NVidia, HDMI 0
Direct sample mixing device
dmix:CARD=NVidia,DEV=8
HDA NVidia, HDMI 0
Direct sample mixing device
dmix:CARD=NVidia,DEV=9
HDA NVidia, HDMI 0
Direct sample mixing device
dsnoop:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct sample snooping device
dsnoop:CARD=NVidia,DEV=7
HDA NVidia, HDMI 0
Direct sample snooping device
dsnoop:CARD=NVidia,DEV=8
HDA NVidia, HDMI 0
Direct sample snooping device
dsnoop:CARD=NVidia,DEV=9
HDA NVidia, HDMI 0
Direct sample snooping device
hw:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct hardware device without any conversions
hw:CARD=NVidia,DEV=7
HDA NVidia, HDMI 0
Direct hardware device without any conversions
hw:CARD=NVidia,DEV=8
HDA NVidia, HDMI 0
Direct hardware device without any conversions
hw:CARD=NVidia,DEV=9
HDA NVidia, HDMI 0
Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Hardware device with all software conversions
plughw:CARD=NVidia,DEV=7
HDA NVidia, HDMI 0
Hardware device with all software conversions
plughw:CARD=NVidia,DEV=8
HDA NVidia, HDMI 0
Hardware device with all software conversions
plughw:CARD=NVidia,DEV=9
HDA NVidia, HDMI 0
Hardware device with all software conversions

this forum https://www.linuxquestions.org/quest...t-work-866841/ suggests to blacklist snd_hda_intel and reboot but after doing this aplay -l shows no devices and all audio stops working. I think this is because when doing lspci -v the Nvidia card and the onboard card are both using the kernel snd_hda_intel

lspci -v output

Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: Dell Device 0443
Flags: bus master, fast devsel, latency 0, IRQ 45
Memory at f1600000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
Subsystem: Dell Device 0443
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at f1000000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

How do I get the Nvidia card to use the Nvidia driver?
 
Old 08-03-2013, 11:24 PM   #2
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
hi

as agreed blacklist won't work as its the same module.

instead try this

Code:
cat /proc/asound/devices

or

cat /proc/asound/pcm
------create a .asoundrc in home folder or a system wide /etc/asound.conf

using the formula

pcm.!default {
type hw
card <number>
device <number>
}

now I don't have your hardware but we know the normal index=0 is the onboard so we have
Quote:
pcm.!default {
type hw
card 1
device <number>
}
now the number of devices you see are likely to match the output numbers of 3,7,8 or 9
try each in turn and

good luck

TIP if you have multiple users do a home asoundrc first until you get it right please

BTW that dot asoundrc in case you are using small fonts, sizes etc

Last edited by aus9; 08-03-2013 at 11:58 PM.
 
Old 08-04-2013, 05:19 PM   #3
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
okay I'm a little confused. my output of cat /proc/asound/devices is

1: : sequencer
2: [ 0- 0]: digital audio playback
3: [ 0- 0]: digital audio capture
4: [ 0- 0]: hardware dependent
5: [ 0] : control
6: [ 1- 9]: digital audio playback
7: [ 1- 8]: digital audio playback
8: [ 1- 7]: digital audio playback
9: [ 1- 3]: digital audio playback
10: [ 1- 3]: hardware dependent
11: [ 1- 2]: hardware dependent
12: [ 1- 1]: hardware dependent
13: [ 1- 0]: hardware dependent
14: [ 1] : control
33: : timer

and output of cat /proc/asound/pcm is

00-00: ALC665 Analog : ALC665 Analog : playback 1 : capture 1
01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 0 : HDMI 0 : playback 1
01-08: HDMI 0 : HDMI 0 : playback 1
01-09: HDMI 0 : HDMI 0 : playback 1

so I create a gedit file in the home folder titled .asoundrc and put this info in it

pcm.!default {
type hw
card 1
device <number>
}

or create a gedit in /ect/ titled asound.conf and put the above information?
and i just try 3,7,8,9 for the device number until one works. do I have to reboot after trying each device number?
 
Old 08-04-2013, 05:29 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
I solved a similar problem not too long ago, with nVidia and HDMI sound. See this thread here:
http://www.linuxquestions.org/questi...nd-4175463313/

It might give you some hints.
 
Old 08-04-2013, 05:45 PM   #5
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
When I do the grep eld_valid /proc/asound/NVidia/eld* I get all 0s. I've tried using vlc to choose the device and none of them work.
 
Old 08-04-2013, 05:50 PM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by weinerwad3000 View Post
When I do the grep eld_valid /proc/asound/NVidia/eld* I get all 0s. I've tried using vlc to choose the device and none of them work.
Ok, so back to that thread:
Quote:
Originally Posted by TB0ne
The device with the '1' is what you're after. A note here: if you just plug a device in, the command may not return anything valid. You can fix it either by plugging in the HDMI device before powering-up, or by removing/re-inserting the module-udev-detect module.
If nothing returns a '1', then you can't proceed further. There are NO devices that are outputting HDMI audio. So as said, plug the HDMI device in before powering up your Linux box.

And are you using the proprietary nVidia drivers from their website, and what kind of nVidia card is it?
 
Old 08-04-2013, 06:06 PM   #7
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
I think I tried plugging it in before boot and it still didn't work but I'll try it again. I got the drivers from the nvidia site. I have the GeForce 335m video card.
 
Old 08-04-2013, 07:53 PM   #8
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
well I predicted your output devices and they are
Quote:
6: [ 1- 9]: digital audio playback
7: [ 1- 8]: digital audio playback
8: [ 1- 7]: digital audio playback
9: [ 1- 3]: digital audio playback

1-9 means index=1 device 9

01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 0 : HDMI 0 : playback 1
01-08: HDMI 0 : HDMI 0 : playback 1
01-09: HDMI 0 : HDMI 0 : playback 1

01-03 means index=1 device 3

but only devices for playback are 3 7 8 9 from both lists
so now try your first .asoundrc using device 9 then logout and try 8 then 7 then 3
or try a full reboot


pcm.!default {
type hw
card 1
device 9
}


good luck

Last edited by aus9; 08-04-2013 at 07:55 PM.
 
Old 08-04-2013, 10:09 PM   #9
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
thank you so much for you're help. I'm being blacklisted from using the tv right now so as soon as I get a chance I'll post back and tell you if this works.
 
Old 08-05-2013, 09:01 PM   #10
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
I tried all the different .conf files for .asoundrc and asound.conf and it still didn't work. It will show up under sound settings if it works correct? I tried using vlc to change the audio settings and it lists 20 different hdmi outputs but they all say hdmi 0 and none of them work.

I tried grep eld_valid /proc/asound/NVidia/eld*

and it gave me

/proc/asound/NVidia/eld#0.0:eld_valid 0
/proc/asound/NVidia/eld#1.0:eld_valid 1
/proc/asound/NVidia/eld#2.0:eld_valid 0
/proc/asound/NVidia/eld#3.0:eld_valid 0

but when I do aplay -D plughw:NVidia,3 /usr/share/sounds/alsa/Front_Center.wav

it says

aplay: main:682: audio open error: No such device

I tried all 4 numbers and it gave me the same error.
 
Old 08-06-2013, 01:55 AM   #11
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
Lets do the last first

post a link to whatever made you choose that command pls for
Quote:
aplay -D plughw:NVidia,3 /usr/share/sounds/alsa/Front_Center.wav
My understanding, if you have not changed the index values, is to use the info from aplay -L (capital l for lima) so of course you and I can't see NVidia,3 in that post 1
----Naturally if you have changed the index value you need to run aplay -L to get a new updated list.

try
Code:
aplay --help
you will notice CARD=string or CARD=string,string2

These act as an alias to (=may) save you time.
Code:
aplay  /usr/share/sounds/alsa/Front_Center.wav (plays the default device and should be the same as)
aplay  -D plughw:Intel /usr/share/sounds/alsa/Front_Center.wav
assuming you wanted to test card1 dev3 first ....try
Code:
aplay  -D plughw:NVidia,DEV=3 /usr/share/sounds/alsa/Front_Center.wav
which is not the same as your attempt

commands are syntax sensitive....or input junk can only lead to junk out.
(2)

Vlc....I love it

Did you change your settings to output is what?

(3) Are you using pulseaudio???
(b) Better name your distro I am guessing Ubuntu which tends to use pulseaudio

that blinking thing is likely have control of your card so you need to choose it in vlc and then select the device type such as card1 dev 3 from the pulldown list
--I am guessing as i don't have 2 audio cards/chipsets

good luck

Last edited by aus9; 08-06-2013 at 01:59 AM. Reason: spell NVidia correctly you bozo
 
Old 08-06-2013, 02:52 PM   #12
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
I got that command from this link http://www.linuxquestions.org/questi...nd-4175463313/

I'm using Mint 15 so yes technically it's Ubuntu. I'm not sure if I'm using pulseadio or alsa mixer. In VLC I have alsa mixer selected and these are my options

I tried putting in aplay -D plughw:NVidia,DEV=3 /usr/share/sounds/alsa/Front_Center.wav and still getting the same error
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2013-08-06 11:49:12.jpg
Views:	18
Size:	151.9 KB
ID:	13145  

Last edited by weinerwad3000; 08-06-2013 at 02:58 PM.
 
Old 08-06-2013, 08:15 PM   #13
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
excellent

so hes telling you that you need to look for 1 but appears not to explain how to get the correct DEV number. So my method is still valid IMHO

2) your screenshot.....very nice....but you have chosen Alsa and I suspect you are using pulseaudio

3)
Quote:
I'm not sure if I'm using pulseadio
from memory if you run just
Code:
alsamixer
and you see only one control....you are on pulseaudio......and are doomed....only joking
but if you are on pulseaudio you must match it in vlc

4) Now I need you to help me, you must remove all .asoundrc....and /etc/asound* files and do a full reboot

5) Now try his way swapping in 3,7,8,9 then do the same numbers with my command and a full reboot each test of one number so its
PART ONE

configure vlc....pulseaudio choose nvidia device (number) (first number 3 then 7 then 8 then 9 and if that fails

PART TWO

Code:
aplay -D plughw:NVidia,DEV=3 /usr/share/sounds/alsa/Front_Center.wav 
aplay -D plughw:NVidia,3 /usr/share/sounds/alsa/Front_Center.wav 
sudo reboot
then try 7 reboot then 8 etc

since you did not seem to test all reply 12....probably because you did understand I said "first" meaning try that one first then try others in turn

I am now more confident you will get there

Naturally you have hdmi cable connected to tv....and have tv settings to accept hdmi (cable input X)....eg hdmi 3
 
Old 08-06-2013, 08:20 PM   #14
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
ahh forgot to mention you have enabled spdif in screenshot

some users have found, they needed to turn off then on their s/pdif to get hdmi to work, but they were mainly alsa users and not pulseaudio
 
Old 08-06-2013, 08:23 PM   #15
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
ahh forgot to mention.....as a local user....you need to be a member of audio and video groups

run
Code:
groups
to verify pls
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] No audio with Nvidia 610 GT over HDMI alexiph Linux - Software 2 05-20-2013 08:52 AM
Alsa config for c310 usb webcam and nvidia GeForce 210 hdmi audio micemicerabies Linux - Software 1 03-31-2013 01:13 AM
nVidia HDMI Audio sherb114 Linux - Hardware 8 04-06-2012 07:42 AM
[SOLVED] unable to set up kernel drivers and modules for HDA Nvidia (audio via hdmi) gjwalsh Linux - Hardware 5 06-18-2011 07:57 PM
nVidia HDMI Audio Doesn't Work scott12087 Linux - Hardware 19 03-09-2011 05:43 PM


All times are GMT -5. The time now is 06:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration