LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2007, 11:39 AM   #1
mmaleck
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Rep: Reputation: 0
nVidia drivers installed but not recognized


Hello -

I am running FC5 release 2.6.16-1.2090_FC5smp, and my graphics card is a Quadro FX 1000 (NV30GL).

I have *some* nvidia drivers installed, and my xorg.conf seems to reference these correctly.

Here is the problem:

When I am logged in as root, the nVidia drives are "found":
glxgears gives me a FPS of about 2000. Not great, but hey.
glxinfo indicates that the nVidia drivers are being used.

BUT, logged in as myself (mmaleck):
glxgears --> FPS ~500, because
glxinfo indicates that the default driver (MESA) is being used instead.

I have looked around, and I couldn't find any direct reference to this problem, and I've tried a few things. My lack of experience has me going in circles, so any tips on what could be causing this and where to start would be greatly appreciated.

Thanks!
 
Old 03-16-2007, 02:27 PM   #2
darthpyro42
LQ Newbie
 
Registered: Mar 2007
Location: Nevada, USA
Distribution: Slackware
Posts: 12

Rep: Reputation: 0
Are you using XFree86 or X.org ? (look in /etc/X11/ and see if there is xorg.conf or XF86.conf) Take a look at the configuration file and see if the driver is listed there. There should be a section "Device" with an "Identifier" that says something about your card, and then the "Driver" part is the important part. Check to see if that's the correct value.

Also, are these the drives that came with your distro, or did you download and install these yourself?
 
Old 03-16-2007, 02:44 PM   #3
mmaleck
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Yes, X.

I'm running X -

/etc/X11/xorg.conf

has "nvidia" -- I have heard of use of the generic "nv" here instead for some distributions, but this totally borks my dual display and gives me ~250 FPS.

File in its entirety:
---------------------------

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
Load "glx"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell 2001FP (Digital)"
DisplaySize 410 310
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "nVidia Corporation NV30GL [Quadro FX 1000]"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "on"
Option "MetaModes" "1600x1200, 1600x1200"
Option "SecondMonitorHorizSync" "31.0 - 80.0"
Option "SecondMonitorVertRefresh" "56.0 - 76.0"
Option "ConnectedMonitor" "DFP,DFP"
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1400x1050" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
 
Old 03-16-2007, 02:48 PM   #4
mmaleck
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Original Poster
Rep: Reputation: 0
oops.

Re: Are these the distro drivers -- sorry, forgot to reply about that. The answer is that I do not know -- mostly because I did not document my upgrade to FC5 (yikes) and I don't remember.
 
Old 03-16-2007, 03:05 PM   #5
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
No, he means (I think), did you use the nVidia drivers that perhaps come with the Fedora install, or did you download the drivers yourself from nVidia and install it on your own.
Taking the chance that you got the nVidia drivers from nVidia, I am a bit confused--you say that the 'nv' driver 'borks' the dual display you use. But I only see settings for one display in the above file.

EDIT- Oops, OK I see now the 2 displays, it's a bit different than my xorg.conf file but I use Xinerama instead of Twinview.

PS - nothing wrong with 2000 FPS especially if it's at 24bit color.
I get about 1380 FPS using dual screens, 24bit color @ 1600x1200 & 1024x768. By reducing the color depth to 16, the FPS goes up by thousands

EDIT - and yes, I agree with one of the posters above implication that it seems you are having more than one .conf file being used, depending on who is logged in.
The right file is typically etc/X11/xorg.conf, as you stated.

Last edited by GrapefruiTgirl; 03-16-2007 at 03:10 PM.
 
Old 03-16-2007, 03:28 PM   #6
darthpyro42
LQ Newbie
 
Registered: Mar 2007
Location: Nevada, USA
Distribution: Slackware
Posts: 12

Rep: Reputation: 0
Quote:
has "nvidia" -- I have heard of use of the generic "nv" here instead for some distributions, but this totally borks my dual display and gives me ~250 FPS.
Right. "nv" is the open-source driver that comes with many distros, and "nvidia" is the proprietary driver that nvidia releases.

Anyway about the main problem here, not being able to use the drivers as a mortal user.
Do you have permissions to the file? Do:
Code:
ls -l /etc/X11/xorg.conf
When I do that the output is:
Code:
-rw-r--r-- 1 root root 5111 2007-03-16 11:26 /etc/X11/xorg.conf
(and I have an NVidia card with working drivers)

Also, you could try booting into a command prompt (init 3) and then using "startx" (as a mortal user), then check out the X log file to see if anything went wrong there. My log file is kept in
/var/log/Xorg.0.log . Copy that into a different file, then try doing "startx" as root, and compare the two log files. Maybe that will reveal some useful info. Also check the line: (==) Using config file: "/etc/X11/xorg.conf" to make sure we're considering the correct config file. In the log file, (II) is information, (WW) are warnings, and (EE) are errors. (I'd begin by grepping the two files for (EE) )
If not enough info is in the logfiles, try this:
Code:
startx -- -verbose 5 -logverbose 5
(I found this info at http://us.download.nvidia.com/XFree8...hapter-04.html , in section 4.2, so you might find more useful info in the README)

Last edited by darthpyro42; 03-16-2007 at 03:30 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed nVidia drivers ok but.... thoffland Linux - Newbie 1 07-07-2005 01:11 PM
wireless card not recognized? drivers installed using ndiswrapper jmroach Linux - Wireless Networking 3 03-04-2005 12:49 PM
NVidia drivers installed, but won't load Caesar Linux - Hardware 1 06-03-2004 11:39 PM
Getting the NVIDIA Drivers Installed Pwnz3r Linux - Software 0 01-31-2004 12:50 PM
geforce2, installed drivers off of nvidia.com, now what? the anti-riced Linux - Hardware 13 06-08-2003 08:45 PM


All times are GMT -5. The time now is 08:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration