LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2004, 03:13 AM   #1
push
Member
 
Registered: Sep 2004
Location: Cincinnati
Distribution: Slackware 10.2
Posts: 32

Rep: Reputation: 15
Nvidia drivers freeze system


I do as nvidia says, and do a yast online update and click the update nvidia drivers thing. All goes well, I reboot, see the splash screen see the login page. Then 2 seconds later it freezes. This happens EVERY time. What's going on? I have a evga e-geforce fx 5700 le. Amd 1700+, abit kg7-r, 512 ddr, 80 gig hd, suse 9.1 PE. God help me if I can't figure this out soon I'm gonna just go back to xp
 
Old 09-07-2004, 04:52 AM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
You're problably running with rivafb. nVidia have reported problems with combining the rivafb and the nvidia drivers, so your best bet is to disable the rivafb driver when you start up.

I'm pretty sure that you can do this just by typing
Code:
vga=ask
at the boot prompt, and then selecting the code for 80x24.
 
Old 09-07-2004, 09:01 AM   #3
push
Member
 
Registered: Sep 2004
Location: Cincinnati
Distribution: Slackware 10.2
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by rjlee
You're problably running with rivafb. nVidia have reported problems with combining the rivafb and the nvidia drivers, so your best bet is to disable the rivafb driver when you start up.

I'm pretty sure that you can do this just by typing
Code:
vga=ask
at the boot prompt, and then selecting the code for 80x24.
Will I have to do this every time or just that once? So I go to failsafe mode then login as root and just type vga=ask and then load KDM?
 
Old 09-07-2004, 02:54 PM   #4
push
Member
 
Registered: Sep 2004
Location: Cincinnati
Distribution: Slackware 10.2
Posts: 32

Original Poster
Rep: Reputation: 15
OK I put it in my menu.lst file, and put in that mode, but when it boots into linux it's still using the same old default drivers, not the nvidia ones. I change the drivers using yast to the 5700 drivers, and it works fine in the test, but then I restart, do the vga=ask and still when it comes to the KDM login screen it freezes up after showing the nvidia splash logo.

Last edited by push; 09-07-2004 at 03:07 PM.
 
Old 09-07-2004, 03:27 PM   #5
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
Try booting up with the command-line option ‘3’. This will put you into text-only mode.
Login as a regular user and start X with the command “startx -- -logverbose 10”
After it crashes, restart the computer and read the file /var/log/XFree86.0.log; this should give you more information about what's actually happening.
 
Old 09-07-2004, 11:43 PM   #6
push
Member
 
Registered: Sep 2004
Location: Cincinnati
Distribution: Slackware 10.2
Posts: 32

Original Poster
Rep: Reputation: 15
How do I do the command line -3? I use the grub boot loader do I go to failsafe mode and try that? No one else has had this problem?
 
Old 09-08-2004, 03:38 AM   #7
rm6990
Member
 
Registered: Aug 2004
Location: Canada
Distribution: SUSE 9.1 Pro and Debian Testing on Server
Posts: 469

Rep: Reputation: 30
After installing the new drivers, did you go into Yast and pick which Nvidia card you have before restarting. I always did this on my SuSE installs just to make sure it would work after reboot.
 
Old 09-08-2004, 08:23 AM   #8
push
Member
 
Registered: Sep 2004
Location: Cincinnati
Distribution: Slackware 10.2
Posts: 32

Original Poster
Rep: Reputation: 15
It has 0x034 or something like that for the card. I try setting it to fx 5700 or 5700ve and it works in the sax 2 server, but freezes on the login screen when I reboot.
 
Old 09-08-2004, 06:36 PM   #9
push
Member
 
Registered: Sep 2004
Location: Cincinnati
Distribution: Slackware 10.2
Posts: 32

Original Poster
Rep: Reputation: 15
anyone know why it works fine in the sax2 server when i test it, but then shits on reboot?
 
Old 09-09-2004, 06:26 PM   #10
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
Quote:
Originally posted by push
How do I do the command line -3? I use the grub boot loader do I go to failsafe mode and try that? No one else has had this problem?
The option is 3, not -3.

Normally, when you boot the computer, you are presented with an option of which kernel/operating system to load, with the option to type things in. If you type in something like “linux 3”, it will load the kernel image and settings for “linux”, appending “3” to the command-line (and hence booting into runlevel 3, multiuser without GUI).

You can also add the option through grub to make it permanent if you like.

In the case of this option, you can also change the “initdefault” setting in the /etc/inittab file to 3 to the same effect.
 
Old 09-28-2004, 10:23 PM   #11
AngryLlama
Member
 
Registered: Sep 2004
Location: /dev/urandom
Distribution: Gentoo
Posts: 171

Rep: Reputation: 30
ARG Me too!

Hello everyone this is my first post here.

I have used Linux off and on for a few years but this is my first time really getting my hands dirty with Gentoo. I currently have my main system installed and everything works great (wireless, sound, usb storage etc..) I was going to install Gnome today and I decided to install the real nVidia drivers (I have a GeForce 4 128mg AGP) After emerging and configuring EXACTLY as the Gentoo docs say, I restarted and ran startx.

The screen went blank and the system froze. I then realized there may be a problem with rivafb. So I actually took console framebuffer support out of the kernel and removed the module from my runlevel. X still freezes. I tried several other things such as changing between Load "glx", Load "dri", and neither in my Xorg.conf file. I am really stumped with this one. I have read many other forums and tried whatever suggestions fit my problem.


Any suggestions? Are there any log or confs that will be of use for diagnosing my problem? Thank you for your time, here are my specs:

Athlon XP 2100
1gig DDR
nVidia geForce4 ti4200 128mb
A-bit kt7 series mobo
Netgear ma311 wifi (prism I)
Terratec DMX 6fire (envy)
120gb eide hd

Paul
 
Old 10-08-2004, 08:08 PM   #12
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
Are you sure that the system has frozen? Can you still switch terminals with Ctrl+Alt+F1 etc.?

If so, then you probably have a problem with your monitor settings. Also see the file /var/log/XOrg.0.log for any error messages.
 
Old 10-18-2004, 08:51 PM   #13
Darklegion
LQ Newbie
 
Registered: Aug 2003
Posts: 13

Rep: Reputation: 0
Are either of you using a kernel above 2.6.6? I got a similar problem where X would sit with extremely high cpu usage.The only way to get out of it is to ssh in from another pc and shut it down....or a hardware reset.I have heard this problem mentioned many other times as well.In my case going back to kernel 2.6.6 fixed the issue..I cannot remember if it was an option in the kernel or a design problem with the newer kernels...if it is the former disabling/enabling a particular option could fix it.Someone else who has put more effort into getting it working could provide a better answer...2.6.6 suits me just fine,and despite some good improvements since a lot of stuff has been broken too.....cd writing as a normal user for instance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia drivers freeze whatpot Linux - Hardware 2 04-09-2005 09:28 AM
nVidia drivers makes the system freeze. help. AngryLlama Linux - Hardware 7 10-01-2004 12:50 AM
system freeze .. maybe nvidia graphics card MuLaZ Linux - Hardware 9 08-30-2004 10:20 AM
asus A7V8X and NVIDIA drivers...blank screen + freeze naraku Linux - Hardware 9 07-14-2003 01:41 PM
slackware 9 with ia32_1.0-4363 Nvidia Drivers = FREEZE okasion Slackware 2 07-13-2003 09:34 PM


All times are GMT -5. The time now is 05:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration