LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-16-2008, 02:18 PM   #1
phonebooth
LQ Newbie
 
Registered: Jul 2006
Location: mariposa ca
Distribution: Fedora
Posts: 12

Rep: Reputation: 0
Nvidia driver problems


I have fedora 9 installed and I am using Nvidia's drivers, it was the only way I could get Compiz working so I could use AWN. Anyways my computer hung up and I restarted it, and now Linux wont boot completely. My computer starts and then the Nividia logo flashes on screen, it tries to load the log on screen, but just flashes back to the Nvidia logo, and is stuck in a loop doing this.

I was thinking about booting into a terminal, and then disabling the driver, to see if it will boot all the way. But I have no idea how to do that.
 
Old 10-16-2008, 02:50 PM   #2
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 919
Blog Entries: 13

Rep: Reputation: 124Reputation: 124
hi, you may try pressing "I" during the boot process, which usually switches to interactive boot, there you can select what services to start. You may also try pressing CTRL+ALT+F1 to switch into a terminal, but knowing that the logo is continuously flashing, it probably won't work.

Once in a terminal, open the /var/log/Xorg.0.log file (using nano or vi) and look for any errors.
 
Old 10-16-2008, 03:00 PM   #3
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Quote:
Originally Posted by phonebooth View Post
I have fedora 9 installed and I am using Nvidia's drivers, it was the only way I could get Compiz working so I could use AWN. Anyways my computer hung up and I restarted it, and now Linux wont boot completely. My computer starts and then the Nividia logo flashes on screen, it tries to load the log on screen, but just flashes back to the Nvidia logo, and is stuck in a loop doing this.

I was thinking about booting into a terminal, and then disabling the driver, to see if it will boot all the way. But I have no idea how to do that.
Well, if you have an option to safe-boot, choose that. If you don't, let it boot normally until the Nvidia logo-loop. When you are there, press "CTR + ALT + F1". That will drop you into a console. Login as root and do this:
Code:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf_bak
You've just created a backup of your xorg.conf file. Edit /etc/X11/xorg.conf with you preferred text editor (ex: vim, pico, mcedit, nano, etc).

When you have /etc/X11/xorg.conf open, search for "drivers", under the "Device" category. It should look similar to this:

Code:
Section "Device"
        Identifier      "nVidia Corporation GeForce Go 7900 GS"
        Driver          "nvidia"
What you want to do here is to change "nvidia" to "nv" and restart (you don't have to restart, but let's keep this simple). To shutdown:

shutdown -r now

You should not get stuck on that logo loop now, but you won't have 3D accelerated graphics. The objective here is to see if the drivers are the ones causing trouble.

You could also take a look at your /var/logs directory to see if you can find clues to what is wrong.

Good luck!
 
Old 10-18-2008, 04:25 AM   #4
phonebooth
LQ Newbie
 
Registered: Jul 2006
Location: mariposa ca
Distribution: Fedora
Posts: 12

Original Poster
Rep: Reputation: 0
That did not work. When in the terminal it would disappear every time the loop would begin again, and I would have to go back in to it. I edited xorg.conf multiple times, and every time I restarted my computer it would continue to loop with the nvidia logo and the driver would be set back to nvidia.
 
Old 10-18-2008, 05:34 AM   #5
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Quote:
Originally Posted by phonebooth View Post
That did not work. When in the terminal it would disappear every time the loop would begin again, and I would have to go back in to it. I edited xorg.conf multiple times, and every time I restarted my computer it would continue to loop with the nvidia logo and the driver would be set back to nvidia.
That is not so good. Could you post the contents of the following files here:

/etc/X11/xorg.conf
/var/log/Xorg.0.log

They should contain some clues that we need.
 
Old 10-18-2008, 05:51 AM   #6
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 919
Blog Entries: 13

Rep: Reputation: 124Reputation: 124
Hi,
Quote:
That is not so good. Could you post the contents of the following files here
Since you can't boot, I suggest you use a liveCD to do this.

Another thing you might want to try is changing the default init level. To do that, press "e" when in grub (having selected your fedora distro), select the kernel line, press "e" again and append "1" to the line. Then just press enter and boot by pressing 'b'. Then you might want to install some kind of command line web browser (lynx).

Serafean
 
Old 10-20-2008, 02:36 PM   #7
phonebooth
LQ Newbie
 
Registered: Jul 2006
Location: mariposa ca
Distribution: Fedora
Posts: 12

Original Poster
Rep: Reputation: 0
I have managed to get a copy of the xorg.conf and the Xorg.0.log.

Here is the xorg.conf
Code:
# Xorg configuration created by livna-config-display

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	Option	    "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection
When ever I change the driver to nv save and restart it is back to nvidia.

Here is a link to the xorg.0.log file. It is really long and I did not want to post the whole thing.

Quick question when I booted with a live CD, xorg.conf would not show up when I was browsing the file system. Was there a reason for this.
 
Old 10-20-2008, 04:23 PM   #8
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 919
Blog Entries: 13

Rep: Reputation: 124Reputation: 124
Quote:
Quick question when I booted with a live CD, xorg.conf would not show up when I was browsing the file system. Was there a reason for this.
It might simply have been non-existant, from what I understand, the xorg.conf is generated at boot by the livna configuration system. try running this :
Code:
  /usr/sbin/nvidia-config-display disable
in a chroot (your / partition becomes any directory you chose in the selected shell)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver problems imaniman Linux - General 4 04-08-2007 01:19 PM
nVidia driver problems... shuego Linux - Hardware 8 12-04-2006 09:36 AM
nvidia instalation problems / Sblive driver problems Colonel-1990 Linux - Software 13 02-14-2005 06:48 PM
NVIDIA Driver problems!! crisco Linux - Newbie 26 04-09-2003 06:52 PM
Nvidia driver problems trentk Linux - Newbie 9 03-20-2002 05:45 PM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration