LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-09-2005, 11:10 AM   #1
Avatar33
Member
 
Registered: May 2003
Location: South Africa
Distribution: Ubuntu
Posts: 75

Rep: Reputation: 15
nvidia driver problems


Hi.

I've recently installed Mandrake 10.1 and I'm slowly sorting out all the problems that I have. My current problem is that I can't get the Nvidia driver to work.
It first installed fine, and then I setup xorg.conf according to the documentation (readme.txt that accompanies the driver).
When I tried to restart X, I got the following errors:
Code:
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
I then read some posts and noticed that many people needed to explicitly set the kernel version when installing:
Code:
sh NVIDIA-Linux-x86-1.0-6629-pkg1.run --kernel-name=2.6.8.1-10mdk
I did this and it installed successfully, but with the following warning:
Code:
Your kernel was configured to include rivafb support as a loadable kernel module.
The rivafb driver conflicts with the NVIDIA driver; the NVIDIA module will still be built and installed but be aware the NVIDIA driver will not be able to function properly if the rivafb module is loaded
I checked the xorg.conf file again and restarted X, but still got the same error.
When I do a lsmod to see which modules are loaded, I do not see rivafb.

Does anyone know how to solve this problem?
Any help would be appreciated.
Thanks
 
Old 01-09-2005, 11:26 AM   #2
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
hi,

did you comment-out the " load dri " and " load GLcore " in xorg.conf ?
if not...try that.

egag
 
Old 01-09-2005, 01:03 PM   #3
Avatar33
Member
 
Registered: May 2003
Location: South Africa
Distribution: Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
Thanks for your reply.
Yes I have. (Actually those items did not even exist in my xorg.conf file so nothing had to be done)

Any other ideas?
 
Old 01-09-2005, 01:16 PM   #4
mugstar
Member
 
Registered: Jun 2004
Location: Scotland
Distribution: Anything that'll install...
Posts: 305

Rep: Reputation: 30
Quote:
Your kernel was configured to include rivafb support as a loadable kernel module.
Loadable: this is why lsmod doesn't report it.

AFAIK, you'll have to recompile your kernel and ensure this module is left out entirely.
I'm at work just now, but I have a newly-built kernel waiting to be installed when I get home.
I'll let you know...
 
Old 01-09-2005, 04:47 PM   #5
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 532

Rep: Reputation: 30
I would check first if device nodes for Nvidia are populating your /dev directory.
If not as root create them by
mknod /dev/nvidia c 195 0
mknod /dev/nvidiactl c 195 255.
Then check your /etc/modprobe-preload has a line with
nvidia
In case edit as necessary.
It is possible you need to load the "agpgart" module as well.
Hope this helps.
Ciao
 
Old 01-11-2005, 05:02 AM   #6
mugstar
Member
 
Registered: Jun 2004
Location: Scotland
Distribution: Anything that'll install...
Posts: 305

Rep: Reputation: 30
There's no need to build a new kernel. What works is as follows:

1. Ensure you have the correct kernel-source package installed. `uname -r` will give you the kernel version. If it's 2.6.x, then `urpmi kernel-source-2.6` does the job.

2. Do `telinit 3` to stop the xorg server.

3. Install the Nvidia driver , ignoring the warning about the conflict with the rivafb driver.

4. Edit /etc/X11/xorg.conf as per the nvidia README.

5. Do `modprobe -r rivafb` to unload the rivafb kernel module.

6. Add the line 'nvidia' to the file /etc/modprobe.preload.

7. Do `telinit 5` or reboot. If you see the nvidia logo, you're dancin'.
 
Old 01-11-2005, 02:20 PM   #7
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,674
Blog Entries: 9

Rep: Reputation: 45
Quote:
Originally posted by mugstar
<snip>

1. Ensure you have the correct kernel-source package installed. `uname -r` will give you the kernel version. If it's 2.6.x, then `urpmi kernel-source-2.6` does the job.

</snip>
That was what I always had to do for the two and a half years that I ran mandrake (well after a kernel upgrade anyway).

It seems that people don't always appreciate that the kernel and the kernel sources are different things.

The nvidia driver should install OK for you kernel version, but of course it cant build the module without the sources to tell it what and where needs building.

Then you just make the changes that it tells you in the readme i.e. the "load glx" bit, and changing or making sure that the driver is specifically identified as "nvidia" rather than "nv" which is just generic nvidia support (which my system hates).

regards

John

p.s. If you like mandrake, you can always buy a "boxed set original", that way the nvidia driver is pre-configured/installed and you only need to do the above when you get a new sources/kernel version.
 
Old 01-12-2005, 02:58 PM   #8
Avatar33
Member
 
Registered: May 2003
Location: South Africa
Distribution: Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
Hi all. Thanks for the replies and sorry for the delay (Internet problems).

After applying urka's solution, everything went smooth.
I started X and got the nvidia splash screen.
Quote:
If you see the nvidia logo, you're dancin'.
Well I almost am, except that when I start any application that uses openGL the application terminates with out any warning. I saw something in the readme that comes with the nvidia driver about this.

I going to read that now, I just thought I'd post because I've been offline for a little while.

If anyone knows why this is happening, your knowledge would be appreciated.
Thank you all once again.
Avatar
 
Old 01-13-2005, 03:01 PM   #9
Avatar33
Member
 
Registered: May 2003
Location: South Africa
Distribution: Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
I solved my problem.
I was starting in runlevel 3 and then using "startx" to get into X.
Once I got bored of doing that, I changed to runlevel 5 and my opengl started working.
That pretty much confuses me, but I don't care.

Thanks for your help.
Avatar
 
Old 02-08-2005, 04:51 PM   #10
xevel
LQ Newbie
 
Registered: Feb 2005
Location: Dijon, France
Distribution: Mandrakelinux 10.1
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by mugstar
If you see the nvidia logo, you're dancin'.
That's really what I have done.
When I tried toinstalled the latest NVIDIA drivers, all things went good until I reboot my computer, then I had to reinstall the drivers to get X to work again. (exactly the same error as Avatar33)
Then I read this topic and now I'm playing UT2004 all day long.
Thank you very much!
(and sorry for my bad english)
 
Old 03-12-2005, 08:14 PM   #11
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
not that anyone is watching this anymore, but i had this problem for a long time, but went to nvidia.com to see if there was an updated driver and there was, 7167, i installed it, configured X, got the nvidia splash screen, whici is all good, but after a reboot (where it usually gave me this problem) it worked! no more having to reinstall the driver every time i reboot!
 
Old 03-12-2005, 08:23 PM   #12
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
It was probably a problem with udev coz I had a similar problem on Fedora Core.
 
Old 03-14-2005, 08:59 AM   #13
eldzis
LQ Newbie
 
Registered: Jan 2005
Location: /latvia/valmiera/
Distribution: Gentoo...
Posts: 14

Rep: Reputation: 0
hi
i am having some problems with nvidia:
install went ok, the X server works ok, but when i load some games like TuxRacer veerything in game slows down, everything is very slow
the same with other games, but i have GeForce4 64MB MX-440 i have played UT2004 without problems on windows
so what is wrong in linux??
and else, when i brows throu startup logs in X server log i noticed this line
Code:
(**) NVIDIA(0): DPMS enabled (II) Loading extension NV-CONTROL (EE) NVIDIA(0): Failed to load GLX
but when i checked my xorg.conf
everything was ok with modules section:
Code:
Section "Module"         Load  "dbe"         Load  "extmod"         Load  "fbdevhw"         Load  "glx"         Load  "record"         Load  "freetype"         Load  "type1" EndSection
so can anyone help me??
 
Old 03-14-2005, 09:29 AM   #14
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,674
Blog Entries: 9

Rep: Reputation: 45
I had a problem similar to that recently eldzis,

I can't say if I've cured it completely. I'd just done the latest bit of "#emerge sync, #emerge -upD world and #emerge -uD world", some of the gnome stuff had emerged (well actually if my memory serves me correctly it was gnome 2.8.1-r???). All my graphics started being "choppy" (I should also mention that I'm a KDE user, but always had gnome installed as well, as when I started, I didn't know which frontend GUI I'd prefer).

Also I can't remember if it also coincided with an update to the latest nvidia driver e-build (6629 ?????), just that the "gnome thing" stuck in my mind.

Any way, I've made it so that my /etc/make.conf has "this lot" as use flags

Quote:
USE="aim alsa arts bindist bonobo cdr crypt cups curl divx4linux doc dvd emacs emacs-w3 ethereal evo exif flash foomaticdb ftp gif gnome gstreamer gtk gtk2 gtkhtml icq imlib jabber java jpeg kde libwww miknod ming motif mozilla mpeg msn ncurses nis nvidia offensive oggvorbis opengl oss pdflib perl php png posix ppds python qt quicktime readline ruby samba scanner session simplexml snmp sockets spell ssl svg svga szip tcltk tcp truetype usb xml xml2 xmms yahoo"
Please notice the highlighted RED nvidia use flag. Then if my memory serves me correctly I then did
Code:
emerge -uD --newuse world
Yes, the recompile takes a while (ha, nothing new there ) and then finished off with
Code:
opengl-update nvidia
which gave me this

Quote:
bash-2.05b# opengl-update nvidia
* Switching to nvidia OpenGL interface...
>>> Regenerating /etc/ld.so.cache...
* Caching service dependencies... [ ok ]
bash-2.05b#
Might help? Failing that then just search for more specific things here (and yes, sorry if that seems like I'm "trying to teach granny, too suck eggs", but that's about all I can think of).

regards

John


p.s. Having done all that, I get

Quote:
bash-2.05b$ glxgears
3957 frames in 5.0 seconds = 791.400 FPS
3816 frames in 5.0 seconds = 763.200 FPS
4195 frames in 5.0 seconds = 839.000 FPS
4198 frames in 5.0 seconds = 839.600 FPS
4200 frames in 5.0 seconds = 840.000 FPS
4198 frames in 5.0 seconds = 839.600 FPS
4190 frames in 5.0 seconds = 838.000 FPS
X connection to :0.0 broken (explicit kill or server shutdown).
bash-2.05b$
Which is probably rubbish, but it's still the fastest that I've had things running at for a while - and yes "Tuxracer" plays ok at those speeds (ha, all I have to do now is find out how to get things running even faster - but that's another story!).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with NVIDIA driver Bandetto05 Linux - Hardware 2 03-08-2005 05:27 AM
nvidia instalation problems / Sblive driver problems Colonel-1990 Linux - Software 13 02-14-2005 05:48 PM
nvidia driver problems novacrasher Linux - Hardware 4 12-10-2004 05:07 PM
Problems with 9.2 and Nvidia driver jriis Mandriva 3 11-24-2003 10:33 PM
nvidia Driver problems cappaccio Linux - Hardware 16 05-05-2003 01:47 PM


All times are GMT -5. The time now is 01:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration