LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-19-2002, 02:17 PM   #1
trentk
Member
 
Registered: Feb 2002
Location: Senoia,Ga
Distribution: Mandrake 8.1
Posts: 39

Rep: Reputation: 15
Nvidia driver problems


Okay well I got them to work this time but my OpenGL programs won't work. For example tuxracer gives this error:
Xlib: extension "GLX" missing on display :0.0
Xlib extension "GLX" missing on display :0.0

****couldn't intialize video:couldn't find matching GLX visual.

I figured this would happen so here's my question. Looking at my XF86Config file I chagned "nvidia" to "nv". Now in the driver readme it says to change it to "nvidia" from "nv" but if I do that then x won't start, just gives me a signal 11 every time. Also in the X11 file it has this

Section "Module"

# This loads the DBE extension module.

Load "dbe"

# This loads the NVIDIA GLX extension module.
# IT IS IMPORTANT TO KEEP NAME AS FULL PATH TO libglx.so ELSE
# IT WILL LOAD XFree86 glx module and the server will crash.

Load "/usr/X11R6/lib/modules/extensions/libglx.so"

Okay so in the readme it says to add Load "glx" so should I take that file path out and just replace it with "glx"?

When I try all the above, I'm back to square 1, it won't load x anymore. I uninstalled the GLX rpm and then installed GLX from the tar (in text mode), changed my config file to nvidia and load glx and all the screen does is flickers. I ran a depmod -a and that didn't work and when I try to startx it just says received signal 11. I can't copy/paste so here's free hand what I have, RIVATNT card and MDK8.1

lsmod
size used by
NVdriver 715648 0

-it doesn't say auto clean or anything else.

ls -la on my /usr/lib/libGL*

/usr/lib/libGLcore.so.1->libGLcore.so.1.0.2802
/usr/lib/libGLcore.so.1.0.2802
/usr/lib/libGLcore.so->libGL.so.1.0.2802
/usr/lib/libGLcore.so.1->libGL.so.1.2802
/usr/lib/libGLcore.so.1.0.2802

and then on my /usr/x11r6/lib/modules/extensions

./
../
libdbe.a
libdri.a
libextmod.a
libglx.so->libglx.so.1.0.2802
libglx.so.1.0.2802
libpex5.a
librecord.a
libxie.a

in that order.

This is about the 4th time I've tried to install the new drivers with no success. I'd like to use Linux solely but until I can figure out how to get things like this working I'm stuck with the dual boot. Thanks
 
Old 03-19-2002, 03:02 PM   #2
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
The readme also states that aside from changing 'nv' to 'nvidia' that you need to make sure that the Load "glx" command IS in there and that you need to comment OUT the Load "dri" & Load "GLcore" commands. It sounds like you may be trying to load the old GLcore files? Look for those and see if that helps. Also, did you use the source files or the rpms to install the drivers? I found the source to work best.
 
Old 03-19-2002, 03:08 PM   #3
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
Sorry for dual-posts but here is my XF86Config if it helps. Also what distro are you using? You may need to edit the XF86Config-4 file if it's there:

# This loads the DBE extension module.

Load "dbe"

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

Load "type1"
Load "freetype"
#
#
Load "glx"
# Load "dri"
# Load "GLcore"
 
Old 03-19-2002, 11:58 PM   #4
trentk
Member
 
Registered: Feb 2002
Location: Senoia,Ga
Distribution: Mandrake 8.1
Posts: 39

Original Poster
Rep: Reputation: 15
I'm using Mandrake 8.1 and the part of my config file that reads:

# This loads the DBE extension module.

Load "dbe"

# This loads the NVIDIA GLX extension module.
# IT IS IMPORTANT TO KEEP NAME AS FULL PATH TO libglx.so ELSE
# IT WILL LOAD XFree86 glx module and the server will crash.

Load "/usr/X11R6/lib/modules/extensions/libglx.so"

That is all that is there and then it goes to another section. Load dri and load GLcore aren't in the config. I used the kernel rpm and the tar for the GLX.
 
Old 03-20-2002, 12:55 AM   #5
homer
Member
 
Registered: Mar 2001
Posts: 41

Rep: Reputation: 15
With the GLX rpm you need to:
rpm -e NVIDEA_Glx.i386.rpm first then rpm -ivh the same file
I have it on Mandrake 8.1 but with the GeForce2.
and Config-4 has:
load "/usr/X11R6/lib/modules/extensions/libglx.so"
On a side note, after all things were changed it didn't work untill I rebooted. I don't know why
 
Old 03-20-2002, 02:42 AM   #6
trentk
Member
 
Registered: Feb 2002
Location: Senoia,Ga
Distribution: Mandrake 8.1
Posts: 39

Original Poster
Rep: Reputation: 15
Yeah I used the rpm first and everything worked except my opengl games like tuxracer and the others. That's when I tried to use the GLX tar instead.

When I look at the /var/log there is a line there that says

WW Loadmodule:given non canonical module name
/usr/X11R6/lib/modules/extensions/libglx.so

Any ideas?
 
Old 03-20-2002, 08:32 AM   #7
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
It's saying that because libglx.so is a shared library not a module, edit the line so it says Load "glx" and try it again. If it still fails then download and run nv_check.sh.
 
Old 03-20-2002, 02:01 PM   #8
trentk
Member
 
Registered: Feb 2002
Location: Senoia,Ga
Distribution: Mandrake 8.1
Posts: 39

Original Poster
Rep: Reputation: 15
I tried using load "glx" instead of the full path and it still gives me the same errors. I'm kinda fed up with the whole deal and wanting to remove Linux so does anybody know how to delete it from DOS? I know fdisk /mbr takes out Lilo but how about for the Linux partition?
 
Old 03-20-2002, 05:15 PM   #9
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
You have to have the exact syntax in your /etc/X11/XF86Config-4
Code:
Load    "glx"
If it dosn't look like that then it wont work.
 
Old 03-20-2002, 05:45 PM   #10
trentk
Member
 
Registered: Feb 2002
Location: Senoia,Ga
Distribution: Mandrake 8.1
Posts: 39

Original Poster
Rep: Reputation: 15
I did that. I took out the full path name that was in there and replaced it with just Load "glx"

I'm just going to start over with a fresh install and maybe buy a new video card. Doesn't make sense to run Linux and never be able to upgrade drivers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver problems Avatar33 Linux - Newbie 13 03-14-2005 10:29 AM
nvidia instalation problems / Sblive driver problems Colonel-1990 Linux - Software 13 02-14-2005 06:48 PM
nvidia driver problems novacrasher Linux - Hardware 4 12-10-2004 06:07 PM
Problems with 9.2 and Nvidia driver jriis Mandriva 3 11-24-2003 11:33 PM
nvidia Driver problems cappaccio Linux - Hardware 16 05-05-2003 02:47 PM


All times are GMT -5. The time now is 04:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration