LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-24-2012, 07:38 PM   #16
dwhb
Member
 
Registered: Jul 2012
Location: Down Under
Distribution: Mint 17 Qiana KDE
Posts: 60

Rep: Reputation: Disabled
NVidia-xconfig


Hi there
I have the same problem after installing 12.2 recently. My driver was installed and I was able to follow your instructions only as far as "tab 8 times to highlight expert mode". What I don't understand is that when I started in Yast System Services, 'firewall' was automatically highlighted. I ignored that and did my best to follow your directions to set runlevel, reboot etc. However, I'm totally stuck when I got to the last 2 points before press f10 & f9. As expected, the config did not work.

My Display Info is showing Vendor: nVidia, Model: G98 [GeForce8400 GS] and 2D driver: fbdev

My monitor is 24" but the max & only size now is 1028x1024 (77.0 Hz refresh). The Configure Nvidia server settings is accessible from kick menu, but its still accompanied by the message "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

Do you think you can write out a "howto run nvidia-xconfig for dummies" please?

Thanks very much in advance.


Quote:
Originally Posted by Knightron View Post
OK mate, I'm assuming you knew what you were doing when you installed the nvidia drivers and you have actually installed it. do the following.
Code:
open yast.
go down and select 'system services'.
in the new window, at the top select 'expert mode'
the window has now changed the content and just below expert mode where you just clicked, you can change your 'default runlevel' change it to number '3'.
reboot.
you will boot into the command line. login, su to root and run the following command.

nvidia-xconfig

if you can't such to root, it means on the install you went with the default and use sudo instead, if this is the case, don't worry about su to root. instead once you've logged in, just initiate the following.

sudo nvidia-xconfig

once that has all been done type yast under root (su) or if you use sudo;
sudo yast
you will be in the n cursers mode of yast. once again 
press down twice to go to 'system' and enter.
go down eight times to 'system services' enter.
press tab 8 times to get to highlight expert mode, enter.
press tab 17 times to highlight the run level, enter.
press down and a little window will display, highlight option '5' enter.
press f10
press f9
run the appropriate command below depending if you use sudo or not.

reboot

sudo reboot
I hope I've helped, sorry bout me strange use of code tags, I'm typing off my phone which I don't normally.
 
Old 10-24-2012, 08:23 PM   #17
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,396
Blog Entries: 7

Rep: Reputation: 166Reputation: 166
Quote:
Originally Posted by dwhb View Post
Do you think you can write out a "howto run nvidia-xconfig for dummies" please?
Hey mate, i don't think i could write a 'how to' any more exact than what you quoted.

Quote:
Originally Posted by Knightron View Post
Ok, well Opensuse does not have the Nvidia drivers in there official repository.
Before you add it i recommend you have everything up to date.
Firstly, if this is a new install; Opensuse installs only parts of meta packages from the dvd. eg if you are running kde, right click desktop, go to desktop settings and you will notice you have only two wallpapers. Once you connect to a network, open Yast, go into software management and once the repos are refreshed, just click accept, and let it install the rest of the meta packages. After it's done i recommend a reboot.
Once you're systems running again, open a terminal and run the following command.
Code:
sudo zypper up
This is to update. In Opensuse after a update, to restart all the programs and services i just do a reboot, i think it's easier, so reboot once the updates are done. If there was updates, after the reboot, i always open up the terminal and do a 'sudo zypper up' again, just to make sure it got them all (It doesn't always for some reason), and repeat until there's no more updates.

Here's how to install the Nvidia driver.
Open Yast.
Go to 'Software Repositories'.
At the bottom, select, 'add'.
Now you've a bunch of different options on how you want to add a repo. Select 'Community Repositories' and then click next.
You will now see the most popular repos made available with the Openbuild service. You want to tick the nVidia Graphics Driver repo and click add.
Once this has been done, while still in Yast, open 'Software management'. In the search bar type 'Nvidia' you will notice some packages are already ticked and about to be installed, that is because Opensuse as detected your graphics card and auto selected the appropriate drivers for you. click accept and once everything is installed do a reboot. Once you're system is running again, try to access the nvidia-settings Configuration Tool again and if you get an error again, do the instructions i gave you in my first post again.

Good luck
First did you see this post of mine (above)? Because the OP had not installed the nvidia drivers like they thought, and you need to install them before attempting them instructions of mine, that you quoted.
If you've done that and still get that error (you probably won't), that's when you use them instructions you quoted.
You're probably stuck on the console? and don't know how to get out. By following the next set of instructions, it will get you out and complete the first set of instructions (that should have been done second) you've already half followed.

Code:
I was able to follow your instructions only as far as "tab 8 times to highlight expert mode"
I'll try to help you. All you need to do is simply understand what you're doing and you can fix this. All you are doing, up to that point is changing the run level back to the way it is by default. Because you're using the ncursers mode of yast, instead of navigating your way with a mouse, you move with the tab button. That is all tab was doing in my instructions, moving from one option to another. If the amount of tabs i said are different for your system, then you can still follow my instructions, but you'll have to simply watch where tab is highlighting and use you nous to work it out and correspond it with the place i describe in my instructions.
So if you're in expert mode? and tabbing 17 times doesn't high light the run level, then all you need to do is this:
You know where the run level settings are because you already changed them once in the gui version of Yast remember? Well yast is still the same in ncursers mode and the runlevel is still in the same place. Watch where the highlight goes each time you press tab, and once it highlight the runlevel area (it took me 17 tabs), resume my instructions.

Good luck mate. If you've any more questions, feel free to ask

Last edited by Knightron; 10-24-2012 at 08:32 PM.
 
1 members found this post helpful.
Old 10-25-2012, 03:17 AM   #18
dwhb
Member
 
Registered: Jul 2012
Location: Down Under
Distribution: Mint 17 Qiana KDE
Posts: 60

Rep: Reputation: Disabled
Thanks very much for a quick reply. I did see some F-keys to navigate to run level etc. I did my best prior to posting and it worked. What threw me after reboot was that my monitor being 24", Nvidia Xserver config automaticall listed it as twin view. The login box etc were totally out of sight, I just blindly typed in my password and managed to log on with a blank screen. Had to use the Alt+F2 to get the system settings back up so I can juggle the display.

I will keep your instructions for the next install (just in case). Thanks again

Cheers!
 
Old 10-25-2012, 04:10 AM   #19
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,396
Blog Entries: 7

Rep: Reputation: 166Reputation: 166
Good job mate, glad you got her up and running
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSuse 11.1: KDE will not start after NVIDIA driver install lfjhn SUSE / openSUSE 2 03-15-2009 04:21 AM
which nvidia driver for openSuse 10.2 and nvidia tnt 64 pro sirius57 SUSE / openSUSE 1 08-30-2007 03:30 PM
Trying to install Nvidia driver on Opensuse 10.2 Defender Linux - Hardware 3 06-11-2007 09:18 AM
Installing NVidia graphics driver on Opensuse 10.2 Spectrix33 Linux - Software 4 05-30-2007 12:08 AM
Trouble with new nVidia driver installation...no nvidia logo and KDE no start up mdb Linux - Software 8 08-18-2004 10:45 AM


All times are GMT -5. The time now is 03:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration