LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-04-2012, 05:41 PM   #1
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 247

Rep: Reputation: Disabled
nvidia driver opensuse 12.2 kde


First I have a nvidia graphics card gtx 460 v2. I installed the nvidia-settings Configuration Tool for nVidia GPUs. When I try to use this program I get an error message; it reads:
"You do not appear to be using the NVIDIA X driver.Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."
My question is how do I do this?
Thank you
Jonnynitro138

Last edited by jonnynitro138; 10-05-2012 at 08:34 AM.
 
Old 10-04-2012, 05:47 PM   #2
suicidaleggroll
Senior Member
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 3,222

Rep: Reputation: 1155Reputation: 1155Reputation: 1155Reputation: 1155Reputation: 1155Reputation: 1155Reputation: 1155Reputation: 1155Reputation: 1155
Have you installed the nvidia driver yet?
 
Old 10-04-2012, 06:01 PM   #3
guyonearth
Member
 
Registered: Jun 2012
Location: USA
Distribution: SolydX
Posts: 399

Rep: Reputation: 82
Are you running it as root? You have to run it as root for it to work right. You also have to have the nvidia driver installed and activated, just installing nvidia-settings won't do that.
 
Old 10-06-2012, 12:48 AM   #4
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 247

Original Poster
Rep: Reputation: Disabled
reply to reply

I don't think that I am running it as root all I did was: "zypper install x11-video-nvidia" (for the driver), and then: 'Configuration Tool for nVidia GPUs' through the apper. This is all that I know what to do if I am missing something a step or 6 all help would be greatly appreciated.
Thank you
Jonnynitro138
 
Old 10-06-2012, 01:15 AM   #5
guyonearth
Member
 
Registered: Jun 2012
Location: USA
Distribution: SolydX
Posts: 399

Rep: Reputation: 82
You have to run the configuration tool as root or the settings will not be written to xorg. If you are prompted for a password, that is why.
 
Old 10-06-2012, 02:06 AM   #6
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 247

Original Poster
Rep: Reputation: Disabled
reply to reply

How do I run the config. tool ass root? I only know how to access the 'nvidia settings' through the Kick Off Application Launcher, I just type "nvidia" in the search bar then select 'nvidia setting', and thats when I get the message, "You do not appear to be using the NVIDIA X driver.Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."
Thank you
Jonnynitro138
Sorry I'm a super newbie at this.
 
Old 10-06-2012, 02:29 AM   #7
msxenix
LQ Newbie
 
Registered: Oct 2012
Location: Bristol, CT
Distribution: Debian Wheezy + LXDE
Posts: 26

Rep: Reputation: 1
in a terminal try typing

sudo nvidia-xconfig

It should ask for your password.
 
Old 10-06-2012, 04:28 AM   #8
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,344
Blog Entries: 7

Rep: Reputation: 159Reputation: 159
OK mate, I'm assuming you knew what you were doing when you installed the nvidia drivers and you have actually installed it. do the following.
Code:
open yast.
go down and select 'system services'.
in the new window, at the top select 'expert mode'
the window has now changed the content and just below expert mode where you just clicked, you can change your 'default runlevel' change it to number '3'.
reboot.
you will boot into the command line. login, su to root and run the following command.

nvidia-xconfig

if you can't such to root, it means on the install you went with the default and use sudo instead, if this is the case, don't worry about su to root. instead once you've logged in, just initiate the following.

sudo nvidia-xconfig

once that has all been done type yast under root (su) or if you use sudo;
sudo yast
you will be in the n cursers mode of yast. once again 
press down twice to go to 'system' and enter.
go down eight times to 'system services' enter.
press tab 8 times to get to highlight expert mode, enter.
press tab 17 times to highlight the run level, enter.
press down and a little window will display, highlight option '5' enter.
press f10
press f9
run the appropriate command below depending if you use sudo or not.

reboot

sudo reboot
I hope I've helped, sorry bout me strange use of code tags, I'm typing off my phone which I don't normally.
 
Old 10-06-2012, 01:19 PM   #9
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 247

Original Poster
Rep: Reputation: Disabled
reply to Knightron

First thank you.
I made a print out of what you advised me to do so I wouldn't get lost, sucks when that happens. I made into root and typed 'nvidia-xconfig' then enter. I recieved the message: "If 'nvidia-xconfig' is not a typo you can use command-not-found to look up the package that contains it, like this: cnf nvidia-xconfig" so I did and I recieved the following message: "nvidia-xconfig: command not found"
(I wasn't sure how to write this display so I put everything in quotations that was on my screen.)
On a good note, my opening suse screen no longer has lines in it so that I can see the materializing globe before the log in screen , thank you.
Jonnynitro138
Oh, the directions were very easy to follow
 
Old 10-06-2012, 09:04 PM   #10
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,344
Blog Entries: 7

Rep: Reputation: 159Reputation: 159
If that command didn't work, then it sounds like you don't have the nvidia drivers installed.
Quote:
Originally Posted by jonnynitro138 View Post
zypper install x11-video-nvidia
Do you have the appropriate repository enabled or did you just initiate that command with the default repositories that come enabled with Opensuse?
 
Old 10-07-2012, 05:36 PM   #11
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 247

Original Poster
Rep: Reputation: Disabled
reply to Knightron

I have the default OPensuse repositories. How can I tell if I have successfully installed a driver or other software?
Thank you
Jonnynitro138
 
Old 10-07-2012, 09:18 PM   #12
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,344
Blog Entries: 7

Rep: Reputation: 159Reputation: 159
Ok, well Opensuse does not have the Nvidia drivers in there official repository.
Before you add it i recomend you have everything up to date.
Firstly, if this is a new install; Opensuse installs only parts of meta packages from the dvd. eg if you are running kde, right click desktop, go to desktop settings and you will notice you have only two wallpapers. Once you connect to a network, open Yast, go into software management and once the repos are refreshed, just click accept, and let it install the rest of the meta packages. After it's done i recommend a reboot.
Once you're systems running again, open a terminal and run the following command.
Code:
sudo zypper up
This is to update. In Opensuse after a update, to restart all the programs and services i just do a reboot, i think it's easier, so reboot once the updates are done. If there was updates, after the reboot, i always open up the terminal and do a 'sudo zypper up' again, just to make sure it got them all (It doesn't always for some reason), and repeat until there's no more updates.

Here's how to install the Nvidia driver.
Open Yast.
Go to 'Software Repositories'.
At the bottom, select, 'add'.
Now you've a bunch of different options on how you want to add a repo. Select 'Community Repositories' and then click next.
You will now see the most popular repos made available with the Openbuild service. You want to tick the nVidia Graphics Driver repo and click add.
Once this has been done, while still in Yast, open 'Software management'. In the search bar type 'Nvidia' you will notice some packages are already ticked and about to be installed, that is because Opensuse as detected your graphics card and auto selected the appropriate drivers for you. click accept and once everything is installed do a reboot. Once you're system is running again, try to access the nvidia-settings Configuration Tool again and if you get an error again, do the instructions i gave you in my first post again.

Good luck
 
1 members found this post helpful.
Old 10-07-2012, 09:34 PM   #13
John VV
Guru
 
Registered: Aug 2005
Posts: 13,535

Rep: Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807
you might want to try reading the OpenSUSE nvidia INSTALL INSTRUCTIONS
they ARE posted on the opensuse wiki

http://en.opensuse.org/SDB:NVIDIA
amd using the nvidia repo and zypper
http://en.opensuse.org/SDB:NVIDIA_drivers

or even the "one click" if you do not want to take the time and LEARN how to do it.
 
Old 10-11-2012, 06:13 AM   #14
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 247

Original Poster
Rep: Reputation: Disabled
reply to replies

Thank you all for the great help. I now have it working
 
Old 10-11-2012, 07:55 AM   #15
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,344
Blog Entries: 7

Rep: Reputation: 159Reputation: 159
Great to hear we were able to help you mate.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSuse 11.1: KDE will not start after NVIDIA driver install lfjhn Suse/Novell 2 03-15-2009 04:21 AM
which nvidia driver for openSuse 10.2 and nvidia tnt 64 pro sirius57 Suse/Novell 1 08-30-2007 03:30 PM
Trying to install Nvidia driver on Opensuse 10.2 Defender Linux - Hardware 3 06-11-2007 09:18 AM
Installing NVidia graphics driver on Opensuse 10.2 Spectrix33 Linux - Software 4 05-30-2007 12:08 AM
Trouble with new nVidia driver installation...no nvidia logo and KDE no start up mdb Linux - Software 8 08-18-2004 10:45 AM


All times are GMT -5. The time now is 04:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration