LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2004, 11:21 PM   #1
jlynch6792
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Rep: Reputation: 0
Nvidia driver


Hoping someone might be able to lend a newb a hand with the below situation:

Trying to install the nvidia driver (1.0-6111) for a cheap geforce4 mx 4000 I have on a clean install of debian sarge (kernel-2.4.26). I'm running the nvidia installer (sh NVIDIA-Linux-x86-1.0-6111-pkg1.run) After following the readme to the letter I end up with the following:

gcc-version-check failed:

Could not compile gcc-version-check.c

If you know what you are doing and want to ignore the gcc version check,
select "No" to continue installation. Otherwise, select "Yes" to abort
installation, set the CC environment variable to the name of the compiler
used to compile your kernel, and restart installation. Abort now?


my gcc version:
gcc -v
gcc version 3.3.4 (Debian 1:3.3.4-3)

I do have the source and source headers installed and have also tried this with kernel 2.6.7 with the same result.

Banging my head against a wall here!
 
Old 08-05-2004, 11:29 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 69
Re: Nvidia driver

Quote:
Originally posted by jlynch6792
Hoping someone might be able to lend a newb a hand with the below situation:

Trying to install the nvidia driver (1.0-6111) for a cheap geforce4 mx 4000 I have on a clean install of debian sarge (kernel-2.4.26). I'm running the nvidia installer (sh NVIDIA-Linux-x86-1.0-6111-pkg1.run) After following the readme to the letter I end up with the following:

gcc-version-check failed:

Could not compile gcc-version-check.c

If you know what you are doing and want to ignore the gcc version check,
select "No" to continue installation. Otherwise, select "Yes" to abort
installation, set the CC environment variable to the name of the compiler
used to compile your kernel, and restart installation. Abort now?


my gcc version:
gcc -v
gcc version 3.3.4 (Debian 1:3.3.4-3)

I do have the source and source headers installed and have also tried this with kernel 2.6.7 with the same result.

Banging my head against a wall here!

Try using export IGNORE_CC_MISMATCH=1 or export CC=/usr/bin/gcc-2.95 in the console where you are compiling.
 
Old 08-05-2004, 11:32 PM   #3
jlynch6792
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Original Poster
Rep: Reputation: 0
no go

Tried both, no go:

ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the appropriate nvidia-installer command line option.
 
Old 08-06-2004, 12:00 AM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 69
Re: no go

Quote:
Originally posted by jlynch6792
Tried both, no go:

ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the appropriate nvidia-installer command line option.
Are the kernel headers you installed linked properly they should point to /usr/src/linux eg. you did ln -sf /usr/src/kernel-headers-2.4.26-?-??? /usr/src/linux assuming you are running the 2.4 kernel and I believe that there is a --WITH_KERNEL_DIR=/usr/src/kernel-headers-2.4.26-?-??? or something like that you can use to point to the correct directory I'm positive on that though never used it you may want to search the docs.
 
Old 08-10-2004, 11:34 AM   #5
BaptismOfFire
Member
 
Registered: Aug 2004
Posts: 107

Rep: Reputation: 15
Dunno if this is any help. I am having my own set of probs with the nVidia driver (I currently am trying to instal 6011). Anyway, the link below describes how to install the driver specifically for debian.

http://tinyplanet.ca/~lsorense/debia...-dri-howto.txt
 
Old 08-11-2004, 11:07 AM   #6
jlynch6792
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks!

Following the process at the link you provided worked wonders. The driver is now installed, now I just have to figure out how to get the TV out functioning.

Thanks again.
 
Old 08-11-2004, 06:10 PM   #7
BaptismOfFire
Member
 
Registered: Aug 2004
Posts: 107

Rep: Reputation: 15
glad I could help, because it is not working for me


still, I will post my problem as soon as I have the logs transcribed.

Once again, glad it worked, because I am a newbie at this as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help editing xf86config for nvidia geforce mx440 after installing nvidia driver linguist Linux - Newbie 11 06-13-2006 07:31 AM
nvidia legacy driver and nvidia-glx questions darkleaf Linux - Software 6 06-27-2005 03:42 PM
Trouble with new nVidia driver installation...no nvidia logo and KDE no start up mdb Linux - Software 8 08-18-2004 10:45 AM
nvidia fx5600 loads vesa driver instead of nvidia driver saburo62 Linux - Hardware 3 05-04-2004 04:59 PM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 06:38 AM


All times are GMT -5. The time now is 06:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration