LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-24-2008, 06:47 PM   #1
Kiwi944
Member
 
Registered: Jan 2008
Location: Auckland
Distribution: Ubuntu
Posts: 31

Rep: Reputation: 15
ntsf HDD mounting with slackware 12?


Hi All

Having created a nice installation of Slackware 12 on my PC I would like to look at moving my media drive across to be accessible from within KDE.

when i look at the "system:/media" from within KDE I do see a second Drive correctly labled Data Disk however it is not mounted.

Could someone please assist with mounting this ntsf drive as I have read through most of the threads and retrieved bits of info from each but not gained a clear picture.

/etc/fstab
/dev/hda5 swap swap defaults 0 0
/dev/hda1 / ext2 defaults 1 1
/dev/hda6 /usr ext2 defaults 1 2
/dev/hda7 /opt ext2 defaults 1 2
/dev/hda8 /home ext2 defaults 1 2
#/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

Thanks in advance from a complete newbie
Al
 
Old 01-24-2008, 07:12 PM   #2
rabbit2345
Member
 
Registered: Apr 2007
Location: 中国上海
Distribution: openSUSE 11.3
Posts: 371

Rep: Reputation: 40
you first need to get the ntfs-3g driver for slackware 12

(http://www2.linuxpackages.net/packag...-i486-1McD.tgz)

then you need to add you windows drive to your /etc/fstab file

add the following line:
Code:
/dev/hdx  /windows ntfs-3g rw,user 1 2

replace 'x' with the actual letter of your windows drive

/windows is the mount point

ntfs-3g is the fs type

rw,user are the options
--rw means mount as read-write
--user means any user can unmount/mount the drive

1 2 are for fsck, the file system checking tool
--if you don't want your drive checked for errors every time you boot, then change it to 0 0

any of these option can be changed to you preference (except the fs type, that is a constant)

Last edited by rabbit2345; 01-26-2008 at 03:37 PM. Reason: left something out
 
Old 01-25-2008, 04:30 AM   #3
Kiwi944
Member
 
Registered: Jan 2008
Location: Auckland
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Delayed Response

Sorry for the delay in responding unfortunatly work called anyway Thanks for the walk through on mounting the Windows Device, I will have a crack at it and let you know how I get on.
 
Old 02-06-2008, 03:49 PM   #4
Kiwi944
Member
 
Registered: Jan 2008
Location: Auckland
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
hmm

I have performed the information above on loading ntsf-3g and altered the /etc/fstab as follows.

/dev/hda5 swap swap defaults 0 0
/dev/hda1 / ext2 defaults 1 1
/dev/hda6 /usr ext2 defaults 1 2
/dev/hda7 /opt ext2 defaults 1 2
/dev/hda8 /home ext2 defaults 1 2
#/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
/dev/hdb /windows ntsf-3g rw,user 1 2

From here what is required to access this drive as I understand that I now need to mount the hdb

I apologise if this seems so simple but have no experience to date with linux.
 
Old 02-06-2008, 06:38 PM   #5
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
Not a problem -- everyone starts somewhere.

Now that you have that in your fstab, make sure the /windows directory exists. If it does, try issuing the command "mount /windows" -- if there's an error message, go ahead and post it here (use code tags, meaning [ code ] and [ /code ] w/o spaces) to help format computer output a bit better. If you don't get an error message, try moving a test file to/from the drive!
 
Old 02-06-2008, 06:47 PM   #6
Kiwi944
Member
 
Registered: Jan 2008
Location: Auckland
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Thanks I will post the error message, as I had tried that and did get an error message which i will post shortly.
 
Old 02-06-2008, 07:14 PM   #7
Kiwi944
Member
 
Registered: Jan 2008
Location: Auckland
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Poetics View Post
Not a problem -- everyone starts somewhere.

Now that you have that in your fstab, make sure the /windows directory exists. If it does, try issuing the command "mount /windows" -- if there's an error message, go ahead and post it here (use code tags, meaning [ code ] and [ /code ] w/o spaces) to help format computer output a bit better. If you don't get an error message, try moving a test file to/from the drive!
Not sure about the /windows directory existing which may explain the error below.

Code:
mount: mount point /windows does not exist
It this error is due to no /windows directory please advise where I should be creating this in the directory.

Again thanks for your help with this.
 
Old 02-06-2008, 08:27 PM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,541
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

You can create a mount point with 'mkdir /windows'.

'man mkdir'. You will need to be root.
 
Old 02-07-2008, 04:58 AM   #9
Kiwi944
Member
 
Registered: Jan 2008
Location: Auckland
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Slowly but Surely

Hi and thank you for your time and suggestions.

I have discovered during the process that the ntfs-3g drivers are not installed as I thought they were.

Below is the response when I try and run the doinst.sh file within the install folder.

Any assistance on this would be very helpful, I should also note that I have run and installed fuse 2.7.2 without issue as I understand this to be required also.

Code:
root@Allinux:~/Desktop/ntfs-3g-1.1120-i486-1McD/install# dir
doinst.sh  slack-desc
root@Allinux:~/Desktop/ntfs-3g-1.1120-i486-1McD/install# ./doinst.sh
-bash: ./doinst.sh: Permission denied
root@Allinux:~/Desktop/ntfs-3g-1.1120-i486-1McD/install#
Thanks in advance again for all your patience.
 
Old 02-07-2008, 06:52 AM   #10
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
You should do:

Code:
# installpkg ntfs-3g-1.1120-i486-1McD.tgz
 
Old 02-07-2008, 08:00 AM   #11
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by Kiwi944 View Post
/dev/hdb /windows ntsf-3g rw,user 1 2
You mount individual partitions on a disk, so the first part of your entry above is wrong. It should be /dev/hdbx, where x is the partition to be mounted (e.g. /dev/hdb1).

Quote:
Originally Posted by Kiwi944 View Post
Code:
root@Allinux:~/Desktop/ntfs-3g-1.1120-i486-1McD/install# dir
doinst.sh  slack-desc
.
This is off-topic, but is the root account the only account you have on your system? If so, this is bad practice and you should create a normal user account for day-to-day use.
 
Old 02-07-2008, 05:51 PM   #12
Kiwi944
Member
 
Registered: Jan 2008
Location: Auckland
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Nylex View Post
You mount individual partitions on a disk, so the first part of your entry above is wrong. It should be /dev/hdbx, where x is the partition to be mounted (e.g. /dev/hdb1).



This is off-topic, but is the root account the only account you have on your system? If so, this is bad practice and you should create a normal user account for day-to-day use.
Thanks for all the assistance, not sure what has gone wrong here but on executing "mount /windows" i get the following error.

Code:
root@Allinux:~/Desktop# mount /windows
Failed to access '/dev/hdb1': No such file or directory
The HDD that I am trying to mount is a NTFS Logical drive from windows which has mostly music and other media with no real partition as the drive was formated as one drive named data_disk.

In relation to your last suggestion, indeed I do have another account which I generally use but for this I thought it easier to be root.
 
Old 02-07-2008, 07:15 PM   #13
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,541
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

Quote:
Originally Posted by Kiwi944 View Post
Thanks for all the assistance, not sure what has gone wrong here but on executing "mount /windows" i get the following error.

Code:
root@Allinux:~/Desktop# mount /windows
Failed to access '/dev/hdb1': No such file or directory
Did you correct your '/etc/fstab' file to reflect the proper drive partition? Post the final '/etc/fstab'.

Quote:
Originally Posted by Kiwi944 View Post
The HDD that I am trying to mount is a NTFS Logical drive from windows which has mostly music and other media with no real partition as the drive was formated as one drive named data_disk.
The disk has one partition with all of the space allocated to it.

Quote:
Originally Posted by Kiwi944 View Post
In relation to your last suggestion, indeed I do have another account which I generally use but for this I thought it easier to be root.
That's good. You can use the 'su' command from that user to access root.

Quote:
excerpt 'man su'
SU(1) SU(1)

NAME
su - change user ID or become super-user

SYNOPSIS
su [-] [username [args]]

DESCRIPTION
su is used to become another user during a login session. Invoked with-
out a username, su defaults to becoming the super user. The optional
argument - may be used to provide an environment similiar to what the
user would expect had the user logged in directly.

Additional arguments may be provided after the username, in which case
they are supplied to the user´s login shell. In particular, an argument
of -c will cause the next argument to be treated as a command by most
command interpreters. The command will be executed by the shell speci-
fied in /etc/passwd for the target user.

The user will be prompted for a password, if appropriate. Invalid pass-
words will produce an error message. All attempts, both valid and
invalid, are logged to detect abuses of the system.
 
  


Reply

Tags
fstab, mount, ntfs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting HDD geckoguykc Linux - Newbie 1 05-01-2006 10:54 PM
HDD mounting chandu Linux - Newbie 5 08-13-2005 09:12 AM
Mounting HDD HELP!!! westverg Ubuntu 3 07-05-2005 07:12 PM
Mounting NTSF in SuSE? zenith_zth Linux - General 1 01-15-2005 04:02 PM
Mounting HDD vs. Mounting Filesystem snailophone Linux - Hardware 4 08-12-2003 12:00 PM


All times are GMT -5. The time now is 08:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration