LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-13-2008, 06:32 AM   #1
Jedimastersa
LQ Newbie
 
Registered: Feb 2008
Distribution: Debian, SUSE
Posts: 1

Rep: Reputation: 0
ntpdate - no servers can be used, exiting


Hi,

This is my 1st post here. I have searched this error online for most of the day and am unable to come up with a fix for my problem. Even within the forum

I have Installed Debian Etch, I have updated all my software using apt

I wanted to the add the Linux machine to my Windows 2003 AD domain, for various reasons.

I followed a howto on configuring the machine to be added to the domain. Everything has worked fine. The machine is on the domain. Excpet I cannot log onto the machine using on of my domain users accounts. I suspected the time setting to be the problem because my time is wrong.

The timezone settings are correct. I have manually set the time using the "date --set" command

I have edited my "/etc/default/rcS" file and turned UTC off as well.

I have manually synced the time with my DC using the "ntpdate servername" command.

I have checked the time in my BIOS, I have checked my BIOS Battery. They are all ok.

Yet after rebooting the machine the time changes to almost 2 hours ahead of what it should be.

When I run ntpdate -q I get the error "ntpdate[2671]: no servers can be used, exiting"

In my ntp.conf file I have my DC set as the ntp server, I have checked on a XP machine and it is working fine as an NTP server, plus if it was not working correctly I would have logon issues with the XP machines as well.

I must be missing something somewhere can anyone help?
 
Old 02-13-2008, 07:00 AM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
ntpdate does not use ntp.conf -- that file is used by ntpd.
 
Old 08-10-2008, 07:15 PM   #3
vectro
LQ Newbie
 
Registered: Sep 2006
Location: U.S.A.
Posts: 8

Rep: Reputation: 0
Include the time server in the command:

ntpdate 0.us.pool.ntp.org

If it says the ntp socket is already in use then turn off ntpd before running ntpdate.
 
Old 08-13-2009, 04:26 PM   #4
glasshut
LQ Newbie
 
Registered: Aug 2009
Posts: 1

Rep: Reputation: 0
tail /var/log/messages

If you run
tail /var/log/messages
You may see something that you can easily fix that will be messing with the time on your server. For instance I had one server that didn't have any other reason to go to the internet (phone server)... so then I was able to see 'Network is unreachable' and then realize I needed to configure a gateway. After this simple fix nfsd worked fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NTPDATE -vs- NTPd? carlosinfl Linux - Networking 3 02-25-2007 02:05 PM
ntpdate configuration? introuble Debian 5 03-26-2006 12:04 PM
NTPDATE will *NOT* work jon_k Linux - Software 8 01-02-2005 05:41 AM
ntpdate and port adcripps Linux - General 2 09-06-2002 04:38 AM
ntpdate installation. Oberon_sedai Linux - Newbie 1 12-06-2001 10:27 AM


All times are GMT -5. The time now is 10:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration