LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2015, 08:27 AM   #1
curious-person
LQ Newbie
 
Registered: Jul 2015
Posts: 1

Rep: Reputation: Disabled
ntp usage on a machine out of sync


Just to check my sanity. We had a machine which was 7 mins out, due to ntp peers being blocked by firewall. After the issue was cleared, I brought, the time to within 2 mins, using DATE command. Then I used ntpdate command several times to get the time approximately right. Once it was right, I enabled ntp. I was told by my peers that I was wrong, and it would affect the Oracle database. The best way to do this is the let the machine come to the correct time on it's own. I don't understand that, having installed 100s of machines, am I missing something? What happens during summer/winter time changes, when an hour change occurs in one step? Does it not affect the database?
 
Old 07-20-2015, 08:50 AM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,911
Blog Entries: 14

Rep: Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142
If it is 7 minutes AHEAD then setting it back MIGHT cause issues especially on a RAC cluster if both nodes don't have the same time. However if it is 7 minutes behind setting it forward isn't likely to cause issues.

Oracle stores a variable on its own that relates to time so I'm not sure it would even matter setting it AHEAD at OS. This particular variable is the source of a bug reported by Oracle a couple of years back though I forget the details.

By the way you can use the ntpdate -q <ntpserver> syntax to go ahead an update to current time rather than mucking with the date command.

p.s. Make sure you use hwclock to sync your hardware clock with your system clock so you'll start with correct time on next boot.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NTP sync problem Uday123 Red Hat 3 11-13-2009 07:57 AM
NTP server not sync sebash00 Linux - General 6 04-04-2008 01:40 AM
NTP sync noir911 Linux - Server 1 03-29-2008 06:50 PM
NTP sync problem guillermo Linux - Hardware 1 11-19-2007 03:00 PM
NTP Sync? carlosinfl Linux - Networking 12 04-13-2006 10:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration