LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-11-2013, 09:23 AM   #1
project.linux.proj
Member
 
Registered: Dec 2012
Posts: 75

Rep: Reputation: Disabled
NTP time is increasing


Hi,

On all my Linux machines . My time is increasing by 27 secs. I am using public NTP server. As per logs my time is increasing by 27 sec. I am showing below logs + ntp.conf

Apr 11 03:27:58 test_comp ntpd[19193]: kernel time sync status 0040
Apr 11 03:27:59 test_comp ntpd[19193]: kernel time sync disabled 0001
Apr 11 05:28:40 test_comp ntpd[21967]: kernel time sync status 0040
Apr 11 05:29:09 test_comp ntpd[21967]: time reset +27.666479 s
Apr 11 05:29:09 test_comp ntpd[21967]: kernel time sync disabled 0001
Apr 11 05:32:22 test_comp ntpd[24121]: kernel time sync status 0040
Apr 11 05:32:24 test_comp ntpd_initres[24123]: host name not found: time.microsoft.com
Apr 11 05:32:24 test_comp ntpd_initres[24123]: couldn't resolve `time.microsoft.com', giving up on it
Apr 11 05:33:56 test_comp ntpd[24958]: kernel time sync status 0040
Apr 11 05:33:57 test_comp ntpd[24958]: kernel time sync enabled 0001


cat /etc/ntp.conf

# Permit all access over the loopback interface. This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict 127.0.0.1
restrict -6 ::1

# Hosts on local network are less restricted.
#restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap

# Use public servers from the pool.ntp.org project.
# Please consider joining the pool (http://www.pool.ntp.org/join.html).
server time.windows.com
#server pool.ntp.org
#server 0.rhel.pool.ntp.org
#server 1.rhel.pool.ntp.org
#server 2.rhel.pool.ntp.org

#broadcast 192.168.1.255 key 42 # broadcast server
#broadcastclient # broadcast client
#broadcast 224.0.1.1 key 42 # multicast server
#multicastclient 224.0.1.1 # multicast client
#manycastserver 239.255.254.254 # manycast server
#manycastclient 239.255.254.254 key 42 # manycast client

# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available.
#server 127.127.1.0 # local clock
#fudge 127.127.1.0 stratum 10

# Drift file. Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
driftfile /var/lib/ntp/drift

# Key file containing the keys and key identifiers used when operating
# with symmetric key cryptography.
keys /etc/ntp/keys

# Specify the key identifiers which are trusted.
#trustedkey 4 8 42

# Specify the key identifier to use with the ntpdc utility.
#requestkey 8

# Specify the key identifier to use with the ntpq utility.
#controlkey 8


tos maxdist 100000000000000000


# ntpq -p
remote refid st t when poll reach delay offset jitter
==============================================================================
*wwwco1test16.mi 129.6.15.28 2 u 223 512 377 75.249 -5.604 5.633

Thanks,

Last edited by project.linux.proj; 04-11-2013 at 09:24 AM.
 
Old 04-11-2013, 10:45 AM   #2
project.linux.proj
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
My question is why 27 Seconds were exceeding and it happened on all machines. Is it because of time server issue ? How can i proove.

Apr 11 05:29:09 test_comp ntpd[21967]: time reset +27.666479 s
 
Old 04-11-2013, 01:57 PM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,931

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Are these physical or virtual machines.

Why are you using the windows time server versus the Redhat pool or at least a pool that is close to your location.
 
Old 04-12-2013, 06:27 AM   #4
project.linux.proj
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
It is physical box. I was using the local time server that moment. it was the same problem I was facing while using local NTP server. Then i chose this windows NTP server on that machine temporarily . but again it added 27 seconds. why these 27 secs were adding on all my Linux machines only. Below were the results of two other machines machines. all machines were adding 27 sec. Is it problem with NTP server at any time. Because i asked to windows team they said all windows machines have correct time. Can you plz give me the reason of lagging on linux machines only?


remote refid st t when poll reach delay offset jitter
==============================================================================
*NTP server. 1 u 12 64 367 0.401 -14.025 7.730

remote refid st t when poll reach delay offset jitter
==============================================================================
*NTP server. 1 u 686 1024 377 0.414 8.264 0.530

Last edited by project.linux.proj; 04-12-2013 at 06:37 AM.
 
Old 04-16-2013, 11:44 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,931

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
What happens when you go back to using the RHEL pool?
Explain what you are using for the local NTP server?
 
Old 04-16-2013, 12:03 PM   #6
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,248
Blog Entries: 8

Rep: Reputation: 235Reputation: 235Reputation: 235
Hey I'm curious. Does this 27-second reset happen only once a day? And only on a specific time server correct?

I wonder if somehow there's another thing that makes your system update back to the time which is 27 seconds late from the time servers.
 
Old 05-01-2013, 04:03 AM   #7
project.linux.proj
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
it happened only once at that time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ntp server keeps on changing time-local ntp server Gil@LQ Linux - Newbie 3 01-23-2013 10:33 AM
NTP time sync with windows 2000 AD time csghosh Linux - Enterprise 7 02-24-2012 04:46 PM
NTP Server giving central time instead of eastern time wjleon Linux - Networking 3 11-01-2007 05:04 PM
debian: Get time from ntp (network time protocol) servers checkmate3001 LinuxQuestions.org Member Success Stories 0 09-30-2007 07:36 PM


All times are GMT -5. The time now is 02:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration