LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-16-2015, 08:28 AM   #16
Fusionfox
LQ Newbie
 
Registered: Sep 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by michaelk View Post
I do not understand why the bad server is still is being used if you deleted it from your ntp.conf file. What are you using to edit the file?
I'm using vim to edit the file.

Is there a way to check that the ntp.conf file is actually the one being used by the ntp server?
 
Old 09-16-2015, 08:47 AM   #17
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,265

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
Probably not since /etc/ntp.conf is the default. You can look to see what options are explicitly used via the ps command:
ps ax | grep ntp

You can manually start ntp via the following command.
/usr/sbin/ntpd -g -c /etc/ntp.conf

To stop ntp once manually started
killall ntpd
 
1 members found this post helpful.
Old 09-16-2015, 09:43 AM   #18
Fusionfox
LQ Newbie
 
Registered: Sep 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
Probably not since /etc/ntp.conf is the default. You can look to see what options are explicitly used via the ps command:
ps ax | grep ntp

You can manually start ntp via the following command.
/usr/sbin/ntpd -g -c /etc/ntp.conf

To stop ntp once manually started
killall ntpd
If i stop the ntp service and then start it manually using your command then run ntpq -p I finally get something new, however, it does not look like the servers I listed in the ntp.conf file:
Code:
root@h218:/home/Kaunet/KauNet2.0-Linux/patt_gen# ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 time-a.timefreq .INIT.          16 u    -   64    0    0.000    0.000   0.000
 x.ns.gin.ntt.ne .INIT.          16 u    -   64    0    0.000    0.000   0.000
 leeloo.scurvyne .INIT.          16 u    -   64    0    0.000    0.000   0.000
 noac.co         .INIT.          16 u    -   64    0    0.000    0.000   0.000
 LOCAL(0)        .LOCL.          10 l   30   64    3    0.000    0.000   0.001
If i use the ps ax | grep ntp command i get:
Code:
root@h218:/home/Kaunet/KauNet2.0-Linux/patt_gen# ps ax | grep ntp
19493 ?        Ss     0:00 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -c /var/lib/ntp/ntp.conf.dhcp -u 109:119
19497 pts/0    S+     0:00 grep --color=auto ntp
So it seems like the dhcp service interferes with the ntp service somehow. So after starting the service manually I am also able to synchronize other machines on LAN to my NTP server. Since I need the NTP server to have accurate time synchronization between the machines in the LAN and not to have accurate time I guess it is now working well enough for my purposes. However, I would still like to have it running properly.

But thanks a lot for helping me get this far
 
Old 09-16-2015, 10:04 AM   #19
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,265

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
A pool is a collection of servers that use a round robin DNS system so in a nutshell you will not get the same servers. According to the NTP pool website there are 602 active severs in the US pool.

Looks like an old bug. Just delete the file. Have you considered trying CentOS 6.7?
https://bugs.launchpad.net/ubuntu/+s...p/+bug/1472056

Last edited by michaelk; 09-16-2015 at 10:15 AM.
 
1 members found this post helpful.
Old 09-17-2015, 02:22 AM   #20
Fusionfox
LQ Newbie
 
Registered: Sep 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
A pool is a collection of servers that use a round robin DNS system so in a nutshell you will not get the same servers. According to the NTP pool website there are 602 active severs in the US pool.

Looks like an old bug. Just delete the file. Have you considered trying CentOS 6.7?
https://bugs.launchpad.net/ubuntu/+s...p/+bug/1472056
The setup currently used as part of a research project which finalizes in December, so right now there is no time to change OS. However, I will definitely consider it after the project ends.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian jessie NTP server sync to windows ntp server question rogzuser Linux - Server 1 09-08-2015 07:19 AM
ntp server keeps on changing time-local ntp server Gil@LQ Linux - Newbie 3 01-23-2013 10:33 AM
[SOLVED] NTP synchronisation not working on linux server arvind lavania Linux - Server 2 05-10-2012 05:01 AM
ntp server is not working on RHEL5 - any help? samengr Linux - Server 1 04-14-2009 10:16 AM
ntp server on Fedora 8 not working Tom Douglas Linux - Server 2 03-08-2008 07:27 PM


All times are GMT -5. The time now is 07:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration