LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2007, 07:10 PM   #1
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 590

Rep: Reputation: 34
ntp server/client problems


Hi

I am tring to configure NTP on redhat 3 updatae 7. /etc/ntp.conf content is as folows

server 127.127.0.1
restrict 127.127.0.1

(And I tryed using server 127.0.0.1 restrict 127.0.0.1)

All I want for this server ot do is trust its local tine and be the ntp server for my local LAN (No internet connection)

I have tow problems


1. when I do service ntpd start this is the screen out put
ntpd: Synchronizing with time server: [FAILED]
Starting ntpd: [ OK ]

What am I doing wrong here

2. If I do ntpdate -v -d x.x.x.x (my time server IP) from a client this is the out put
17 Dec 10:02:32 ntpdate[26309]: ntpdate 4.1.2@1.892 Tue Feb 24 06:32:26 EST 2004 (1)
transmit(172.16.86.176)
receive(172.16.86.176)
transmit(172.16.86.176)
receive(172.16.86.176)
transmit(172.16.86.176)
receive(172.16.86.176)
transmit(172.16.86.176)
receive(172.16.86.176)
transmit(172.16.86.176)
172.16.86.176: Server dropped: strata too high
server 172.16.86.176, port 123
stratum 16, precision -17, leap 11, trust 000
refid [0.0.0.0], delay 0.02579, dispersion 0.00000
transmitted 4, in filter 4
reference time: 00000000.00000000 Thu, Feb 7 2036 16:28:16.000
originate timestamp: cb103bbc.04e30446 Mon, Dec 17 2007 10:05:16.019
transmit timestamp: cb103b18.646bbdbe Mon, Dec 17 2007 10:02:32.392
filter delay: 0.02589 0.02579 0.02579 0.02579
0.00000 0.00000 0.00000 0.00000
filter offset: 163.6267 163.6267 163.6267 163.6267
0.000000 0.000000 0.000000 0.000000
delay 0.02579, dispersion 0.00000
offset 163.626720

17 Dec 10:02:32 ntpdate[26309]: no server suitable for synchronization found


If you look at the line in red the year feald is 2036 why is this how to fix this.

None of the resolutions that I could find in the web works
Regards

Last edited by procfs; 12-17-2007 at 03:07 AM.
 
Old 12-17-2007, 08:36 AM   #2
complich8
Member
 
Registered: Oct 2007
Distribution: rhel, fedora, gentoo, ubuntu, freebsd
Posts: 104

Rep: Reputation: 16
If your system time is too far off from the ntp server's, the client will refuse to update to that timestamp, due to sanity checks.

Check the output of "date" to see what time your system's actually set to. If it's too far off, then I'd say manually set it with "date -s" (check the man page )
 
Old 12-17-2007, 03:41 PM   #3
ettran
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Rep: Reputation: 0
ntp server/client problems

1)If your ip was 172.16.86.176, find out your defaultrouter ip or subnet ip, I would presume it will be 172.16.86.1. Add this subnet ip into your /etc/ntp.conf at the end of the page:
server 172.16.86.1 # local clock
restrict 172.16.86.1 noquery nomodify notrap
2)add 172.16.86.1 into /etc/ntp/step-tickers
3)service ntpd restart
4)ntpq -pn to see if it resolved?
Another way is to run rdate -s with 1 of your Unix server.
If you know any Cisco switch's ip that is closed to your server, you can also use that ip to add to those files above. Good luck.
 
Old 12-17-2007, 04:39 PM   #4
ettran
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Rep: Reputation: 0
ntp server/client problems

Sorry did not read carefully your questions. Since you did not have network connections, just use the date command. date M/D/H/Minutes. Why would you want to configure ntp to sync with another local server when you don't have network?
 
Old 12-17-2007, 08:18 PM   #5
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 590

Original Poster
Rep: Reputation: 34
Hi guys thanks for the replies

complich8

When I do date it showed me the time just one half minutes off with the time server, I think this time difference is ok for it to sync? And I change the time of the client clock to match the NTP server time but with no luck ti gives me the same error when I do ntpdate.

ettran

I do have a LAN which has several Redhat clients and few Redhat servers and these are not connected to the internet that what I meant (Sorry).

Regards and Thank you again
 
Old 12-18-2007, 08:13 AM   #6
Homer Jay
LQ Newbie
 
Registered: Dec 2003
Location: Berlin/Germany
Distribution: Debian
Posts: 22

Rep: Reputation: 15
This
Quote:
Originally Posted by asankacgl View Post
172.16.86.176: Server dropped: strata too high
server 172.16.86.176, port 123
stratum 16, precision -17, leap 11, trust 000
says it all: The server 172.16.86.176 thinks its time is unrelyable.
Just make it "Stratum 3" or so.
Here is the relevant

Quote:
Originally Posted by file://localhost/usr/share/doc/ntp-doc/html/notes.html
Time is distributed through a hierarchy of NTP servers, with each server adopting a stratum which indicates how far away from an external source of UTC it is operating at. Stratum-1 servers, which are at the top of the pile (or bottom, depending on your point of view), have access to some external time source, usually a radio clock synchronized to time signal broadcasts from radio stations which explicitly provide a standard time service. A stratum-2 server is one which is currently obtaining time from a stratum-1 server, a stratum-3 server gets its time from a stratum-2 server, and so on. To avoid long lived synchronization loops the number of strata is limited to 15.
greetings
 
Old 12-19-2007, 02:01 AM   #7
agbmelbaust
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: 0
The best ref I have used for setting up NTP is doubleUdoubleUdoubleU_dot_ntp_dot_org

Following is a config I use for setting up a machine to be a client and a self server of ntp.

======================================================================
# set the default restrictions
restrict default notrust nomodify

# restrict which clients can contact this host
restrict 192.168.47.0 mask 255.255.255.0 nomodify
restrict 10.0.0.0 mask 255.255.255.0 nomodify

# network address to broadcast the time on


# set the reference server in this case its own
server 127.127.1.1

# pretend to be a stratum 8 reference using local clock
fudge 127.127.1.1 stratum 8 refid NIST

# ntp from uni of qld - ntp1.uq.edu.au
server 130.102.128.43
======================================================================


use "ntpq -pn" to check the status of ntp on your server.

let's know how it goes.
 
Old 12-27-2007, 03:37 AM   #8
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 590

Original Poster
Rep: Reputation: 34
Dos not work I am getting the same error
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Set up decent NTP server-client Swakoo Linux - Networking 3 09-05-2007 04:35 PM
ntp client update time from windows ? minhsys Linux - Server 2 02-26-2007 03:31 AM
Setting Up NTP Client/Server kaplan71 SUSE / openSUSE 2 05-31-2006 05:38 PM
NTP Client How to Sync automatically minil Programming 3 03-03-2005 03:52 AM
Need help with NTP server/client setup ncorreia Linux - General 0 11-06-2003 06:21 AM


All times are GMT -5. The time now is 10:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration