LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-03-2013, 10:46 PM   #1
Rohit_4739
Member
 
Registered: Oct 2010
Distribution: Red Hat
Posts: 228

Rep: Reputation: 9
NTP offset value too high with ntpdate


Hi Guys,

I am facing an issue where a cluster node got into serious trouble because of the time gap between the 2 nodes, now looking at the /var/log/messages for the faulty servers i found the below infomrtaion where showed that the time Offset value was way too much high during the time when issue occured. Now i am trying hard to figure out what could have caused it, one guess was some temporary network issue which could have caused network latency that delayed communication with ntp. I did a traceroute for both the servers and both nodes follow the same path to reach the ntp server. So can you guys please give me some more ideas to troubleshoot and reslove this issue.

Code:
Mar 29 05:59:40 prodserv0003 ntpdate[5328]: step time server timeserverip offset 3531.785266 secMar 29 05:59:40 prodserv0003 ntpd[5331]: ntpd 4.2.2p1@1.1570-o Thu Nov 26 11:34:34 UTC 2009 (1)
Mar 29 05:59:40 prodserv0003 ntpd[5332]: precision = 1.000 usec
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface wildcard, 0.0.0.0#123 Disabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface wildcard, ::#123 Disabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface lo, ::1#123 Enabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface eth4, #123 Enabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface bond1, #123 Enabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface bond0, #123 Enabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface lo, 127.0.0.1#123 Enabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface eth4, myip#123 Enabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface bond0, myip#123 Enabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: Listening on interface bond1, myip#123 Enabled
Mar 29 05:59:40 prodserv0003 ntpd[5332]: kernel time sync status 0040
Mar 29 05:59:40 prodserv0003 ntpd[5332]: frequency initialized 31.397 PPM from /var/lib/ntp/drift
Mar 29 06:02:58 prodserv0003 ntpd[5332]: synchronized to LOCAL(0), stratum 10
Mar 29 06:04:04 prodserv0003 ntpd[5332]: synchronized to 10.117.7.30, stratum 4

Any quick help would be highly appreciated.
 
Old 04-04-2013, 09:10 AM   #2
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,528

Rep: Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056Reputation: 1056
Somebody pulled the plug? Network connection dropped?

Looking at your log entries, NTPD did exactly what it's supposed to: it recognized the error, disabled, synchronized to localhost, waited for the network to come back then synchronized.

The problem is at the other end, the time server went down for some reason (was the box being rebooted, was the intranet traffic taking you out, or something like that?). Same thing happens if you turn off your router or pull the network cable -- NTPD sees it, syncs to localhost for a while (that's why the entry is there in your npt.conf file):
Code:
# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available. The
# default stratum is usually 3, but in this case we elect to use stratum
# 0. Since the server line does not have the prefer keyword, this driver
# is never used for synchronization, unless no other other
# synchronization source is available. In case the local host is
# controlled by some external source, such as an external oscillator or
# another protocol, the prefer keyword would cause the local host to
# disregard all other synchronization sources, unless the kernel
# modifications are in use and declare an unsynchronized condition.
#
server	127.127.1.0	# local clock
fudge	127.127.1.0 stratum 10	
#server  pool.ntp.org
server  0.us.pool.ntp.org
server  1.us.pool.ntp.org
server  2.us.pool.ntp.org
Hope this helps some.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ntp safely on server, ntpdate? --debian GreggT Linux - Server 5 06-30-2012 05:14 PM
ntp Offset value too high newcranium Linux - Server 3 05-20-2011 08:53 AM
NTP high offset noir911 Red Hat 1 01-22-2009 08:34 AM
NTP offset marstse Linux - General 1 01-14-2009 12:33 AM
[root] Changing time without using ntp/ntpdate ? frenchn00b Linux - Newbie 1 07-22-2007 03:53 PM


All times are GMT -5. The time now is 08:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration