LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-25-2010, 06:16 AM   #1
harendra bisht
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Rep: Reputation: 0
Question ntp client not working in linux 4


[my virtuale machine(linux4) not sync with ntp server
dmeg show

tc_mmss: can't update from 5 to 57
set_rtc_mmss: can't update from 7 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 2 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 7 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 2 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 7 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 10 to 59
set_rtc_mmss: can't update from 3 to 56
set_rtc_mmss: can't update from 4 to 57
set_rtc_mmss: can't update from 6 to 58
set_rtc_mmss: can't update from 8 to 59
set_rtc_mmss: can't update from 2 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 7 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 2 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 7 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 10 to 59
set_rtc_mmss: can't update from 4 to 57
set_rtc_mmss: can't update from 6 to 58
set_rtc_mmss: can't update from 7 to 59
set_rtc_mmss: can't update from 0 to 55
set_rtc_mmss: can't update from 2 to 56
set_rtc_mmss: can't update from 3 to 57
set_rtc_mmss: can't update from 5 to 58
set_rtc_mmss: can't update from 7 to 59
set_rtc_mmss: can't update from 2 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 2 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 7 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 10 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 10 to 59
set_rtc_mmss: can't update from 3 to 56
set_rtc_mmss: can't update from 4 to 57
set_rtc_mmss: can't update from 6 to 58
set_rtc_mmss: can't update from 8 to 59
set_rtc_mmss: can't update from 2 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 7 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 2 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 7 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 2 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 7 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 9 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 4 to 56
set_rtc_mmss: can't update from 5 to 57
set_rtc_mmss: can't update from 6 to 58
set_rtc_mmss: can't update from 7 to 59
set_rtc_mmss: can't update from 3 to 55
set_rtc_mmss: can't update from 5 to 56
set_rtc_mmss: can't update from 6 to 57
set_rtc_mmss: can't update from 8 to 58
set_rtc_mmss: can't update from 10 to 59


ntpq -p command show this detail
[root@incdcl138 ~]# ntpq -p
remote refid st t when poll reach delay offset jitter
==============================================================================
SERVERS09 .FREE. 1 u 951 1024 377 2.533 333598. 6214297
*LOCAL(0) LOCAL(0) 10 l 37 64 377 0.000 0.000 0.004
[root@incdcl138 ~]#

what should i do for that pls help me out

firewall also disable machine on same network
configuration done in /etc/ntp.conf
ouput of /etc/ntp.conf is
# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.

restrict default nomodify notrap noquery

# Permit all access over the loopback interface. This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict 127.0.0.1


# -- CLIENT NETWORK -------
# Permit systems on this network to synchronize with this
# time service. Do not permit those systems to modify the
# configuration of this service. Also, do not use those
# systems as peers for synchronization.
# restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap


# --- OUR TIMESERVERS -----
server 0.pool.ntp.org
server 1.pool.ntp.org
server 2.pool.ntp.org
server 147.128.136.69



# --- NTP MULTICASTCLIENT ---
#multicastclient # listen on default 224.0.1.1
# restrict 224.0.1.1 mask 255.255.255.255 nomodify notrap
# restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap



# --- GENERAL CONFIGURATION ---
#
# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available. The
# default stratum is usually 3, but in this case we elect to use stratum
# 0. Since the server line does not have the prefer keyword, this driver
# is never used for synchronization, unless no other other
# synchronization source is available. In case the local host is
# controlled by some external source, such as an external oscillator or
# another protocol, the prefer keyword would cause the local host to
# disregard all other synchronization sources, unless the kernel
# modifications are in use and declare an unsynchronized condition.
#
server 127.127.1.0 # local clock

fudge 127.127.1.0 stratum 10

#
# Drift file. Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
#
driftfile /var/lib/ntp/drift
broadcastdelay 0.008

#
# Keys file. If you want to diddle your server at run time, make a
# keys file (mode 600 for sure) and define the key number to be
# used for making requests.
#
# PLEASE DO NOT USE THE DEFAULT VALUES HERE. Pick your own, or remote
# systems might be able to reset your clock at will. Note also that
# ntpd is started with a -A flag, disabling authentication, that
# will have to be removed as well.
#
keys /etc/ntp/keys


also give some detail more


Linux incdcl138 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:27:17 EDT 2006 i686 i686 i386 GNU/Linux


some budy help me out


Thanks in advance

Harendra Bisht

Last edited by Tinkster; 06-26-2010 at 12:11 AM. Reason: removed phone number
 
Old 06-26-2010, 01:58 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,560

Rep: Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556
Quote:
Originally Posted by harendra bisht View Post
[my virtuale machine(linux4) not sync with ntp server

also give some detail more

Linux incdcl138 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:27:17 EDT 2006 i686 i686 i386 GNU/Linux

some budy help me out

Thanks in advance
Harendra Bisht
What "linux 4" are you talking about?? RedHat Linux 4 (which is very, VERY old), RedHat Enterprise Linux 4? What?

If you're talking about RHEL4 in a VM environment, there's a known bug. You have to patch the kernel, and apply a change to the VM environment. Full details and fixes are on the RHEL site, through their knowledgebase. If you're using RHEL, you're already paying for access to it, so give them a call.
 
Old 06-28-2010, 05:37 AM   #3
harendra bisht
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Original Poster
Rep: Reputation: 0
i am using rhel 4.6

Thanks

Harendra Bisht

9871963116
 
Old 06-28-2010, 05:45 AM   #4
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,591

Rep: Reputation: 162Reputation: 162
You should probably open port 123, UDP. You open that with the firewall program. Sometimes it just called 'ntp'.
 
Old 06-28-2010, 08:07 AM   #5
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,560

Rep: Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556Reputation: 2556
Quote:
Originally Posted by harendra bisht View Post
i am using rhel 4.6

Thanks
Harendra Bisht
9871963116
Ok, great. Now how about answering the other questions. Are you running in a VM environment? And have you called RedHat support, since you're paying for it??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NTP client configuration krishrj Linux - Server 2 05-25-2010 07:59 AM
ntp drift file in /etc/ntp instead of /var/lib/ntp - suggestion for a patch in Slack niels.horn Slackware 16 05-07-2009 07:35 PM
synchronize ntp client rizvi_iut Linux - Newbie 6 12-08-2008 09:54 PM
ntp: linux client to active directory server fancylad Linux - Server 1 06-03-2008 03:21 PM
Setting Up NTP Client/Server kaplan71 Suse/Novell 2 05-31-2006 04:38 PM


All times are GMT -5. The time now is 09:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration