LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-12-2003, 10:09 AM   #1
wetrix
LQ Newbie
 
Registered: Jan 2003
Posts: 3

Rep: Reputation: 0
NTFS/Win2k Mount Problems


Hello.

I am currently running SuSE 8.1.

When mounting an NTFS (Windows 2k) partition, it works fine when mounting as root, but a normal user does not have access to the mount point.

I have set up the mount point and /etc/fstab exactly the same as the vfat types (which work fine), but still no joy.

Has anyone had the same problem, or knows what I can do?

Thank you
 
Old 01-12-2003, 10:29 AM   #2
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
Check the permissions.
 
Old 01-12-2003, 11:28 AM   #3
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Edit your /etc/fstab to have a "umask" setting. Also, you will need to enable users to mount/umount the disc, something along the lines of:
/dev/hdX /mnt/wherever ntfs users,auto,noexec,owner,umask=333,ro 0 0

Is complete overkill and some of those are redundant upon each other in the options portion, however they do not clash so it will work.

For more info on the options section and an entry in fstab alltogether, see man mount.

Cool

Last edited by MasterC; 01-12-2003 at 11:30 AM.
 
Old 02-02-2003, 12:26 PM   #4
wetrix
LQ Newbie
 
Registered: Jan 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the advise.

I managed to get it working by putting the following in the /etc/fstab file:

/dev/hda3 /windows/F ntfs noauto,user,uid=700,gid=100,umask=007 0 0

(gid number was the "users" group)

Seems to work fine!
 
Old 02-02-2003, 12:30 PM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Good deal! I'm baffled on this umask deal and am thinking of emailing the NTFS devel team to find out what's up. Anyway, glad you got it working

Cool
 
Old 03-29-2003, 02:42 PM   #6
tutan@rediffmai
LQ Newbie
 
Registered: Mar 2003
Location: India
Distribution: RH
Posts: 1

Rep: Reputation: 0
mount problem

Hi,

well as far as i know, you cannot mount a drive/partition/disk whatever...unless you are the root. This has been done for security reasons. I never use SuSE, however, the architecture is more of less the same, thus what is true for RH is true for SuSE too!!
Cheers!!!
 
Old 03-30-2003, 01:24 PM   #7
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
A user can if the option is listed in fstab for that device/partition. It does have to be listed in fstab though...

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Mount Ntfs Partition David2004 Red Hat 10 09-07-2006 10:48 PM
NTFS mount problems w/ Kernel 2.6.3 k0rupt Fedora 3 04-17-2004 11:53 PM
NTFS file system mount problems Fedora 2.4 jjisnow Linux - Newbie 2 03-23-2004 05:42 PM
/etc/fstab - NTFS mount problems dbc001 Linux - Hardware 12 02-22-2004 06:50 AM
Mount Problem for NTFS (WIN2k) FIle System atul_jadhav Linux - General 5 12-31-2001 08:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration