LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-03-2003, 06:35 AM   #1
Ivo.Loncar
LQ Newbie
 
Registered: Feb 2003
Location: Serbia
Posts: 7

Rep: Reputation: 0
Talking NTFS problem - No: 1.354.275


Hello everyone..

At first, I would like to apologize for all mistakes you could see, because english is not my best side



This is my situation:

I want to mount NTFS partitions (totaly 3, one - FAT32 - on hdd with RedHat8.0, second two - NTFS - on second hdd). Because NTFS was not supported by kerel, I enable it as read only from /usr/src/linux-2.4 with "make xconfig".
However, it does not working although it says that is enabled.

Then I downloaded {something}.rpm for supporting NTFS, and it works. I can mount them, and i added in /etc/fstab next lines:

/dev/hdc5 /mnt/Leo defaults 0 0
/dev/hda3 /mnt/Dajana vfat 0 0

..and it mounts them as RW, which i don't want.

So, instead of "defaults" I put "ro" and it mounts them, but I can't access to Leo from user account, but only as root (which is pretty non-practical).

And my final idea I tried to change the permissions (owner: root, group: root) but disk is read only.

I can't change permissions on drive wherever is "ro" or "rw", so I need your help



I apricieate your help. Thank's.
 
Old 02-03-2003, 07:01 AM   #2
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 47
An ntfs filesystem doesn't handle permissions in the same way as a normal filesystem on linux. The mount manpage will explain how to set permission for NTFS in the 'Mount options for NTFS' section.

Basically you can set the uid=xxx gid=xxx umask=xxx settings in the fstab file to set permissions for the all the files on that filesystem.
 
Old 02-03-2003, 08:27 AM   #3
Ivo.Loncar
LQ Newbie
 
Registered: Feb 2003
Location: Serbia
Posts: 7

Original Poster
Rep: Reputation: 0
Thank you, now I know where to look.
 
Old 04-07-2003, 04:05 PM   #4
rsherard3
LQ Newbie
 
Registered: Apr 2003
Distribution: Mandrake 8.2
Posts: 1

Rep: Reputation: 0
Same Problem

I am having the same problem trying to get to my NTFS mounts from my user account. I can access it fine from root, but not my user account. Can you provide me with some reference? I really have no idea where to start. Thanks!
 
Old 04-07-2003, 06:38 PM   #5
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
In fstab put down something like this:

I like to control access but this is what my line looks like in fstab

/dev/hda2 /mnt/XP ntfs umask=0227,uid=root,gid=xp 0 0

Where /dev/hda2 is my Windows XP partition, I made a dir called /mnt/XP this is where I am mounting to, umask=0227 lets the owner and members of the group read the partition, uid=root is who I set the owner to on the partition, gid=xp is the group who has access and my user name is part of the xp group.

Now if you don't want this type of control try this line which should allow everybody using the computer access to the ntfs partition with read only permission:

/dev/hda2 /mnt/XP ntfs umask=0222 0 0

Good Luck

Last edited by JayCnrs; 04-07-2003 at 06:39 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with ntfs Barq Linux - General 2 07-17-2005 01:34 PM
ntfs problem varun_33 Red Hat 1 03-01-2005 01:05 PM
NTFS problem mcang Linux - Hardware 1 02-24-2005 06:33 PM
ntfs problem muerte42200 Linux - Newbie 13 12-26-2004 07:34 AM
problem with NTFS demmylls Linux - General 2 12-09-2003 08:44 AM


All times are GMT -5. The time now is 01:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration