LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-27-2003, 11:41 PM   #1
slackerJoe
LQ Newbie
 
Registered: Jul 2003
Location: Asheville, NC
Distribution: Slackware
Posts: 14

Rep: Reputation: 0
NTFS partition mounting questions


OK, so this post actually is two questions, but I think they are related:

1. When I am logged in as a normal user and I attempt "mount -t ntfs /dev/hda1 /mnt/winxp" I'm told that I have to be root to do this. Sure enough, I am able to mount it when I change to su. But, is there anyway I can change this so I CAN mount it while simply logged in with my user account.

2. Once the ntfs partition is mounted and I try to view the contents to play a movie or mp3 or whatever, I'm told that I dont have permission to view the contents. As root or when I log in as su it works just fine.

I tried "chmod -R 555 /mnt/winxp" as root but got the error that it was read only and it couldnt be completed, which makes sense because I didn't include NTFS write abilities when I compiled the kernel. So yeah, I'm sure there is a setting somewhere that can fix this, I just have no clue where it is. Help me gurus, help!
 
Old 07-28-2003, 03:22 AM   #2
mowtown75
LQ Newbie
 
Registered: Jul 2003
Posts: 10

Rep: Reputation: 0
Hi,

Firstly I am a newbie too, and I have not complied a new Kernel yet, so I am humbled.

I have started with mounting partions, but only Fat. I did the same, mounted them as root, but I then edited the fstab file, so they would mount on boot up.

This means they are mounted before I log in, so may this will work for you.

add the relevant info to your fstab file

run: gedit etc/fstab

then add the line something like:
/dev/hdb1 /mnt/vfat vfat auto,users 0 0 0

I have not tried to access mine as anything but SU, so I am yet to see if mine are accesible.

All the best

Mo
 
Old 07-28-2003, 03:59 AM   #3
koyi
Member
 
Registered: Jul 2003
Location: Osaka, Japan
Distribution: Arch, Ubuntu
Posts: 421

Rep: Reputation: 31
This is the entry for my NTFS partition.

/dev/hdb5 /mnt/misc ntfs noauto,user,uid=1000 0 0

Check your uid by typing the command "id".
It doesnt mount automatically on startup but you can do so by changing "noauto" to "auto".... I suppose :P Of course it is read-only.

Hope this helps.
 
Old 07-28-2003, 10:53 AM   #4
slackerJoe
LQ Newbie
 
Registered: Jul 2003
Location: Asheville, NC
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks guys, you rock!
 
Old 07-28-2003, 02:58 PM   #5
slackerJoe
LQ Newbie
 
Registered: Jul 2003
Location: Asheville, NC
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
doh....

I spoke too soon, I tried that and still when I'm logged onto my user account it tells me that I must be root to mount and once it is mounted I'm unable to view the contents unless im su. Here is my fstab if it helps:

/dev/hda7 swap swap defaults 0 0
/dev/hda8 / reiserfs defaults 1 1
/dev/hda9 /home reiserfs defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,ro 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
/dev/hda1 /mnt/winxp ntfs auto,joe,uid=1000 0 0
/dev/hda5 /mnt/winxp2 ntfs auto,joe,uid=1000 0 0

note: I did double check to make sure the correct user ID for joe was 1000.

Last edited by slackerJoe; 07-28-2003 at 03:00 PM.
 
Old 07-28-2003, 03:04 PM   #6
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
If you are not to concerned about security, use the following options in your /etc/fstab
Code:
user,rw,exec,umask=000
 
Old 07-28-2003, 03:21 PM   #7
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Slackerjoe


/dev/hda1 /mnt/winxp ntfs auto,ro,umask=022 0 0

or

/dev/hda1 /mnt/winxp ntfs auto,ro,umask=002 0 0

The umask value is the key - try both of these

Last edited by Skyline; 07-28-2003 at 03:23 PM.
 
Old 07-28-2003, 03:47 PM   #8
slackerJoe
LQ Newbie
 
Registered: Jul 2003
Location: Asheville, NC
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
sweet! I tried "/dev/hda1 /mnt/winxp ntfs auto,ro,umask=002 0 0" first and that works. Thanks for the help.

-Joe
 
Old 07-28-2003, 04:09 PM   #9
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Nice
 
Old 07-28-2003, 06:16 PM   #10
slinshot
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
Ok i tried this /dev/hda1 /mnt/winxp ntfs auto,ro,umask=002 0 0 and it said that permission was denied
i tried the other one same thing;.... how do i fix this help...
[B] also to log in as root do i just do this su root password: same as login pw?{/B] in other words how do i figure my password and username im a newb
 
Old 07-28-2003, 06:28 PM   #11
mowtown75
LQ Newbie
 
Registered: Jul 2003
Posts: 10

Rep: Reputation: 0
Slinshot

Boot up, at uder login, type:

Root


at password type


[your actual password for administrator/Super User]

Then you are logged on as root for the whole session and whtever you do will not be questioned for root permissions

Chrs

Mo
 
Old 07-29-2003, 06:44 AM   #12
koyi
Member
 
Registered: Jul 2003
Location: Osaka, Japan
Distribution: Arch, Ubuntu
Posts: 421

Rep: Reputation: 31
Quote:
/dev/hda5 /mnt/winxp2 ntfs auto,joe,uid=1000 0 0
You shouldn't put your user name "joe" there. Put "user" instead. I mean like this:

/dev/hda5 /mnt/winxp2 ntfs auto,user,uid=1000 0 0

wish this may help.
 
Old 07-29-2003, 05:14 PM   #13
the_anti_pat
LQ Newbie
 
Registered: Jul 2003
Distribution: RedHat 8.0 (Debian soon)
Posts: 21

Rep: Reputation: 15
HI...I'm using Redhat 8.0 and have the same problem trying to mount as anything other than the administrator! I've tried every configuration here and none seem to work! Also, I'm currently mounting it as my main user by opening a root terminal and typing "konqueror /mnt/windows" but I want to try to run /WINDOWS/explorer.exe...I tried "wine /mnt/windows/WINDOWS/explorer.exe" but it said it couldn't find the path! The path is definetly there, is this part of the read/write problem with NTFS systems?

Also, I cannot mount hda2 when i try i get...:-
"[root@localhost alistair]# mount -t ntfs /dev/hda2 /mnt/ntfs_file_dump
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)"
Is it not posible to mount a non-sytem partition?? This is where I keep all my avi files (40GB worth of them!) I can't afford to lose them!
On hda1 I have 30GB of data, I probably need to backup about 10GB of that to format and recover the data on the 'file dump'. If I'd gone with Linux the whole way I wouldn't have this problem!! But anyway as I'm using my linux partition it doesn't have 10GB of space left to backup the data I need so I need to mount another drive (all other drives are ntfs) with 10GB to spare! If anyone can help me with what that error means i'd be much abliged!
 
Old 07-29-2003, 07:10 PM   #14
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi the_anti_pat

When you get the error :

mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems

Have you already got a filesystem mounted into your mount point? - what filesystem type are you trying to mount there?
 
Old 07-29-2003, 11:37 PM   #15
slackerJoe
LQ Newbie
 
Registered: Jul 2003
Location: Asheville, NC
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Koyi, yea, I got confused and put my account name in there instead of user (my newbiness holds true!). The use of umask as suggested by Skyline and Mathieu got it working though. Thank you for clarifying, though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting ntfs partition Gentleman_finn Linux - Newbie 14 07-25-2005 03:45 PM
ntfs partition mounting as rw ktekosi Slackware 4 06-07-2005 08:43 PM
mounting my NTFS partition. Amsterdam Fedora 16 08-30-2004 11:48 AM
mounting an NTFS partition greythorne Slackware 1 06-02-2004 01:02 AM
Mounting NTFS partition dark_light Linux - General 4 09-20-2002 11:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration