LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-06-2005, 03:42 PM   #1
sugardaddy
LQ Newbie
 
Registered: Jan 2005
Posts: 4

Rep: Reputation: 0
NTFS mounting probs


Hi all,

great forum i found most of my linux probs here except for one, well almost.

I am trying to mount a NTFS partition that is connected as an usb mass storage device but i can't access those partitions. I think it has something to do with the permissions but i'm not sure.

i found a similar problem here at linuxquestions.org showthread.php?s=&threadid=273015

i tried the suggestions that were made theire and i changed my rules in /ect/fstab into this:

/dev/sda5 /mnt/mov ntfs auto,users,umask=000,ro 0 0
/dev/sda6 /mnt/appz ntfs auto,users,umask=000,ro 0 0
/dev/sda7 /mnt/mp3 ntfs auto,users,umask=000,ro 0 0

but i still dont have the permissions to view my files in X

What am i doing wrong???

i'm running Mandrake 10.1 btw
 
Old 01-06-2005, 03:54 PM   #2
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
Your fstab looks correct I think. Why don't you post the exact error you see when you try to access the partition. Then someone may be able to help more.
 
Old 01-06-2005, 04:04 PM   #3
vxc69
Member
 
Registered: Jul 2004
Distribution: Ubuntu
Posts: 387

Rep: Reputation: 33
Do the following:

Ctrl+Alt+F2
username: root
password: your root password

Then:
umount -a
remove the usb device.
reconnect the usb device.
It should output something like "Attached scsi disk sda at scsi blah blah blah....

Note what linux identified the usb device as. (sda, sdb, sdc etc...)

Next:
mkdir /mnt/ntfs
mount /dev/sda1 /mnt/ntfs -t ntfs #Note: replace sda1 accordingly.

This should mount your device to /mnt/ntfs

Only root will be able to access /mnt/ntfs. In order to let normal users access the device add the following line to /etc/fstab:

/dev/sda1 /mnt/ntfs ntfs noauto,users,exec 0 0 #Note: replace the sda1 bit accordingly.

Hope this helps,
vxc

EDIT: I hope you keep your USB device attached permanently. Otherwise linux may identify the device differently (i.e. sda might become sdc or sdd etc...) depending upon which particular device is fixed first.

Last edited by vxc69; 01-06-2005 at 04:08 PM.
 
Old 01-06-2005, 06:56 PM   #4
sugardaddy
LQ Newbie
 
Registered: Jan 2005
Posts: 4

Original Poster
Rep: Reputation: 0
vxc69, will try that tomorrow and will let you know if it helped

the exact error i got was: "Permission denied"

need to get some sleep it's 01h00 at night here
 
Old 01-07-2005, 03:03 AM   #5
sugardaddy
LQ Newbie
 
Registered: Jan 2005
Posts: 4

Original Poster
Rep: Reputation: 0
hmmmz i still get the Permission denied in commandline and i still can't view the files in X
X error message : Can't open Directory (or something like that)

are there other settings i can do?
 
Old 01-07-2005, 03:55 AM   #6
vxc69
Member
 
Registered: Jul 2004
Distribution: Ubuntu
Posts: 387

Rep: Reputation: 33
I've hit a brick wall here. Maybe it's the ntfs module. Try reinstalling the ntfs module.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Onmibook hotswap cdrom mounting probs! F0ul_Olli Linux - Laptop and Netbook 11 08-22-2005 10:17 AM
probs in mounting rewritable cd ankscorek Linux - Hardware 1 08-17-2005 02:23 PM
Wine/mounting probs ethics Linux - Newbie 2 04-30-2005 07:53 PM
mounting ntfs!! abhijit Programming 5 06-13-2003 08:51 PM
Mounting probs Stevy123 Linux - General 2 10-09-2002 01:52 PM


All times are GMT -5. The time now is 04:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration