LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-02-2006, 03:12 AM   #1
colonel
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Rep: Reputation: 0
NTFS mounted but inaccessible by non-root


Hi, i've installed the NTFS modules into my kernel etc, and have been trying to mount my NTFS windows drive. I managed to mount it, but only the root can access it. When I chown chris /media/windoze , (my username is chris)i get:

Code:
chown: changing ownership of `/media/windoze/': Read-only file system
When i use the root user i can successfully copy and view files on the drive. But that's hardly ideal for obvious reasons...
Thanks for any suggestions if you have any ideas,
Chris.
 
Old 07-02-2006, 03:19 AM   #2
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
there is no wright support for NTFS so you couldn't do that, also NTFS dosent support unix/linux file permissins so chown is useless here.
What you want to do is change the mount options
if you mount manually then:
Code:
mount /dev/hdX /media/windows -t ntfs -o uid=(your username),gid=(group name)
if you mount automatically then if /etc/fstab you need to add "user" to the options. eg:
Code:
/dev/hdX /media/windows ntfs user,noauto 0 0
 
Old 07-02-2006, 08:37 AM   #3
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 48
If you like that NTFS Drive to be mounted at start...then add the following line to /etc/fstab and then restart the computer for the changes to come into effect.


Code:
/dev/hdxx /media/windoze ntfs umask=0222 1 0
I hope you can replace the hdxx by the proper numbers.


Also, if you don't want it to be mounted at startup,

Code:
mount /dev/hdxx /media/windoze/ -t ntfs -o umask=0222
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Set permissions for my mounted ntfs arpanetguru Linux - General 1 05-29-2006 09:49 PM
Rsync mounted NTFS drive phatboyz Linux - Networking 0 11-22-2004 03:31 PM
Can't access mounted NTFS drive Nychold Linux - Hardware 1 06-12-2004 03:45 AM
CDRom mounted ok and suddenly all files become Inaccessible. Josequi Linux - Hardware 0 03-28-2003 07:17 PM
ntfs mounted but I cant access the files Boom Linux - Newbie 1 01-10-2003 01:03 AM


All times are GMT -5. The time now is 03:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration