LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-09-2004, 04:03 PM   #16
axess_denied
Member
 
Registered: Jun 2004
Location: DC Metro Area
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15

# make modules
make: *** No rule to make target `modules'. Stop.
That is what I got... what the heck should I do????
 
Old 06-09-2004, 04:09 PM   #17
axess_denied
Member
 
Registered: Jun 2004
Location: DC Metro Area
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15
One more thing I just noticed, when viwing
/usr/src/linux*/configs/
I have two kernel configs, one for kernel.X.X.i586.config, and one for kernel.x.x.i686.config
I edited the .i686.config file, should I have?
 
Old 06-09-2004, 04:12 PM   #18
SROSeaner
LQ Newbie
 
Registered: Jun 2004
Location: Ontario, Canada
Distribution: Fedora Core 2, Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Depends on your processor.

http://voidmain.is-a-geek.net/redhat..._686_mean.html
 
Old 06-09-2004, 04:21 PM   #19
v00d00101
Member
 
Registered: Jun 2003
Location: UK
Distribution: Fedora 8, Centos 5.1
Posts: 480

Rep: Reputation: 30
once uv finished xconfig:

make
make modules_install
make install
 
Old 06-10-2004, 01:37 AM   #20
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Hello SROSeaner,

firts of all *Thank you very much* of remaining me on an "old" rule:

"If you want to recreate a problem, then do it under the conditions it occurs"

As alraedy told,: I am using kernel 2.6.7-rc2 and you are using *very likely* the default
kernel provided by Fedora. In my case the default FC2 kernel is 2.6.5-1.358
(uname -r) will give you the current active kernel.

So I booted FC2 with the default kernel, made the steps that worked well with the 2.6.7-rc2
kernel and could *not* mount the NTFS partition.

So what happened? Nothing special. If you are running kernel 2.6.5-1.358 then the modules
shall be in the directory /lib/module/2.6.5-1.358
and there wasn't a NTFS module. However there was a new directory called /lib/module/2.6.5-1.358custom.

BY the way: You may have a different default FC2 kernel then me. I will use my kernelversion below. You need
to modify it according to your kernel version.

IMPORTANT:
Do *NOT* modify anything in the configs directory !!!!

So Fedora uses an EXTRAVERSION in it's Makefile.
Take a look on /usr/src/linux-2.6.5-1.358/Makefile
at the top there you can find following
VERSION = 2
PATCHLEVEL = 6
SUBLEVEL = 5
EXTRAVERSION = -1.358custom

This means that the kernel and modules version will be 2.6.5-1.358custom which is useless for the running 2.6.5-1.358.
What we will *NOT* do is to change EXTRAVERSION from "-1.358custom" to "-1.358" (so simply removing "custom" in the Makefile)

We need to recompile the kernel.

There are two options we have.
Which your take is your choice. I *suggest* option 2.

1) We will compile a custom kernel
a) In this case go into /usr/src/linux-2.6.5-1.358
cd /usr/src/linux-2.6.5-1.358
b) now we need to clean up everything, left from the previous compiler run. This is done by
make mrproper
c) now copy the kernel sources to a directory detremined by the EXTRAVERSION
cp -r /usr/src/linux-2.6.5-1.358 /usr/src/linux-2.6.5-1.358custom
d) change into the custom directory
cd linux-2.6.5-1.358custom
e) Get the current kernel configuration
make oldconfig
f) edit the .config file so NTFS is enabled and compiled as loadable module
CONFIG_NTFS_FS is=m
Do NOT forget to save the modified .config file
g) let's build the kernel
make
(just simply invoke make. no makefile needs to be specifyed)
You will be asked if you want to enable NTFS. Answer this with m (so NTFS shall be compiled as module)
Answer the question about enabling NTFS write support with n. So *no* write support forn NTFS. At least that is my recommendation.
If there are other questions, you can answer with n.
You can answer the question regarding the NTFS debug support also with n but also y will not hurt.
Now take your time. It takes some time to compile the kernel.
h) now install the modules
make modules_install
i) Now copy the kernel image into the boot directory
cp /usr/src/linux-2.6.5-1.358custom/i386/boot/bzImage /boot/vmlinuz-2.6.5-1.358custom
here bzImage is the new kernel Image and we copy it into /boot reanaming it into vmlinuz-2.6.5-1.358
j) Copy the System.map into /boot with a new name according to the kernel version
cp /usr/src/linux-2.6.5-1.358custom/System.map /boot/System.map-2.6.5-1.358custom
g) cd into /boot directory
cd /boot
h) Now we need to create the initial ram disk image
mkinitrd /boot/initrd-2.6.5-1.358custom.img 2.6.5-1.358custom
i) If you are using GRUB as boot manager (that's what I am using and this is FC2 default)
make a backup of your grub.conf file
cp /boot/grub/grub.conf /boot/grub/grub.conf.bak
j) Now add follwoing to your /boot/grub/grub.conf file

# Text to add BEGINN, BUT without this line
title Fedora Core with custom kernel (2.6.5-1.358)
root (hdX,Y)
kernel /vmlinuz-2.6.5-1.358custom ro root=LABEL=/ vga=0x31a splash=0 quiet
initrd /initrd-2.6.5-1.358custom.img
# Text to add END but without this line

IMPORTANT Remarks: root(X,Y) is the drive containing your boot image - where X is the drive and Y the partition number (starting from 0)
This are the same values like given in the existing Fedora Core section in grub.conf. In my case it's root(1,5) so
2-nd IDE drive on the first IDE controller 6-th partition (I start to count from 1 therefore is 6-th partition. GRUB starts to count from 0
therefore it's 5 for GRUB)
I have vga=normal splash=0 quiet and no rhgb parameter since I would like to see all teh messages during boot

k) Now reboot your computer and select the
Fedora Core with custom kernel (2.6.5-1.358)
in the boot menu. This will boot your new kernel.

L) Check if NTFS module is loaded
lsmod | grep ntfs
if not load it manually
modprobe ntfs

*OR*

2) This is what I would recommend.
Instead of coompiling the custom kernel download and compile the 2.6.7-rc2 kernel I use. It fixes a lot of bugs previous kernel versions had.
It's really a stable kernel,a nd since I have it, I do not have any DHCP problems, soundcard works and I can read CD/DVDs created under Windows.
Download this kernel from
http://www.kernel.org/pub/linux/kernel/v2.6/testing/
You need there to find and download the file linux-2.6.7-rc2.tar.gz
Download the linux-2.6.7-rc2.tar.gz file to /usr/src

Now untar this file:
cd /usr/src
tar -zxvf linux-2.6.7-rc2.tar.gz

This will create a new directory under /usr/src
/usr/src/linux-2.6.7-rc2

go to that directory
cd /usr/src/linux-2.6.7-rc2

From now on proceed like given in the steps e) 'til L) above (in option 1) ). Of course you need to replace 2.6.5.1-358custom with 2.6.7-rc2.
You need also here to enable NTFS support (as loadable module) by editing the .config file (step f) BUT
it's very likely that you will not be explictly asked about NTFS support when invoking make (step g). Do not worry about that.

Since 2.6.7-rc2 kernel has new options, you will be asked if you want to enable them when invoking make.
You can answer with N (except if you are asked to enable NTFS explicitly. there you need to answer with m, so module). I suggest that you answer with n (so No)
when you are asked about enabling features that are EXPERIMENTAL. They can cause a lot of trouble.

Last edited by Vlad-A; 06-10-2004 at 03:17 AM.
 
Old 06-15-2004, 04:32 PM   #21
axess_denied
Member
 
Registered: Jun 2004
Location: DC Metro Area
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15
Did
make modules
and modules were made, but now typing depmod returns.... NOTHING
what can I do to get this kernel to support NTFS?
 
Old 06-16-2004, 11:08 AM   #22
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Hello axess_denied,

1) what kernel version do you run ?

uname -r
will give you the kernel

2) Check in /lib/modules/kernel_version_you_obtained_by_uname_r
if there is the ntfs module

find /lib/modules/kernel_version_you_obtained_by_uname_r -name ntfs.*


If there isn't such module then what is the output of
ls /lib/modules
 
Old 06-19-2004, 04:33 AM   #23
artemis
Member
 
Registered: Feb 2002
Location: London
Distribution: Fedora 2, Red Hat 8.0
Posts: 46

Rep: Reputation: 15
I've just gone to the sourceforge site to get my NTFS support RPM and it appears to work fine. However, the documentation on the site seems to imply that I can't write toWindows partitions, its just Read Only. But when I check my dmesg, I find these messages:
NTFS driver 2.1.7 [Flags: R/W MODULE].
NTFS driver 2.1.7 [Flags: R/W MODULE].

Does this mean that I can write to my Win partition? I don't want to mess up the partition in any way... just checking to make sure I can do it and therefore, mount it r/w instead of r/o!

artemis
 
Old 06-19-2004, 05:45 PM   #24
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Check you kernel configuration.
Go to the source directory of teh kernel you are running.

You'll find your current kernel version with

uname -r

cd /usr/src

and there into the dircetory that contains the source files of your kernel.

Get the current configuration by

make oldconfig

now check in the .config file if NTFS write support is enabled or not.

However and anyway: You can mount your NTFS partitions as read only. So use the ro option in your
/etc/fstab.
 
Old 06-20-2004, 12:16 PM   #25
axess_denied
Member
 
Registered: Jun 2004
Location: DC Metro Area
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15
Vlad-A,
I have checked the kernel, now running 2.6.5-1.358custom,
I did the find /lib/modules/2.6.5-1.358custom ntfs*
and was told that no such file or directory exsists... What do I do?
 
Old 06-20-2004, 12:53 PM   #26
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
If you get the error message: No such file or directory
then it's very likely that you have a typo.

If find could not find ntfs then it will *not* print out any message.

What to do:

Become a root.

Change into the /lib/modules directory.
cd /lib/modules

List the content of that directory
ls

You will very likely find a directory called:
2.6.5-1.358custom

Change into it:
cd 2.6.5-1.358custom

now:
find . -name ntfs*
 
Old 06-21-2004, 02:44 PM   #27
axess_denied
Member
 
Registered: Jun 2004
Location: DC Metro Area
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15
Thanks Vlad, I did that and I got no response, just another # with a new root line???
I am very frustrated with this, and I don't even want my Windows drive I just want my media... Any other suggestions would be most welcome
 
Old 06-21-2004, 06:30 PM   #28
Rand
LQ Newbie
 
Registered: Dec 2002
Location: Ann Arbor, MI, USA
Distribution: Red Hat Linux 8.0
Posts: 9

Rep: Reputation: 0
Is there a reason that NTFS support is not in the kernel, at least read support? Now that the Microsoft's consumer OS user NTFS, it seems that NTFS support would be important functionality. The sourceforge project has been around for several years, I'm surprised that this feature hasn't made it into the kernel yet.
 
Old 06-22-2004, 01:12 AM   #29
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Hello axess_denied,

that you do not get any output from find means that the ntfs modules are not compiled and installed yet.
So let's try, make NTFS work :-)

Fierst one question/comment:

What do you mean by "......I just want my media... " ?
If you mean CD/DVD created by e.g. InCD (Nero) or DirectCD (Roxio) or any other packet writing Software
under Windows then this is *NOT* done via NTFS. Those programs use the UDF filesystem which *is* enabled
by default in Fedora. However: In the UDF driver prior kernel version 2.6.7-rc2 there was a bug, which
prevent you to access CD/DVD media created with Windows packet writing programs.
If you want to access such media, then you need to compile and install the 2.6.7-rc kernel.
You can find how to do this In one of my previous replays in this thread.

However, if you just want to enable NTFS support in your current kernel 2.6.5-1.358custom, then a short
decription is given below:

First Become root

1) We need to make sure that NTFS source files are installed. Change into the directory containing the filesystem source files
cd /usr/src/linux-2.6.5-1.358custom/fs

2) See if there is a subdirectory called ntfs
ls

3) If yes then change into that directory
cd ntfs

4) make sure that this directory is not empty
ls

If everything here is fine, and I *suppose* it will be, then we can proceed.

Fedora delivers the NTFS source files. It's only that the feature (unlike in SuSE or Mandrake) is not enabled by default.

5) Go into your kernel source directory
cd /usr/src/linux-2.6.5-1.358custom

6) Open your Makefile in your favorite editor (for example kwrite or vi or whatever you prefear)
kwrite Makefile

7) Make sure that following enties are there
VERSION = 2
PATCHLEVEL = 6
SUBLEVEL = 5
EXTRAVERSION = -1.358custom

This will make sure, that the steps below will be related to the kernel version you are running, so to 2.6.5-1.358custom

8) Close the editor where Makefile was opened and stay in the usr/src/linux-2.6.5-1.358custom directory.

Now some commands. Enter them just like described below. Wait 'til one command completes prior entering the other

9) make clean
10) make mrproper
11) make oldconfig

The last step will create a .config file.

12) open this file:
kwrite .config

13) look there for following entry:
CONFIG_NTFS_FS
You will see very likely following:
# CONFIG_NTFS_FS is not set
which means NTFS support is disabled

14) Enable the NTFS support:
CONFIG_NTFS_FS=m
This means we will have the NTFS driver as loadable module. Make sure that there is no leading # sign in front of the entry.

15) Do not forget to save the config file after you have edit it.

16) Now let's compile our modules
make modules

This needs some time.
It can be that you will be asked if you want to enable NTFS debugging and write support (or ntfs rw support). You can answer with n (so no).
I suggest that you do *not* enable NTFS write support.

17) Now we need to install the modules. This is usually done by make modules_install *BUT* there is a specific thing with Fedora.
Instead of having build in the lib/modules/kernel_version directory as symbolic link, Fedora provided kernels have it as
directory. So the make modules_install will fail, since it expects build as link (so more or less as file) and not as directory.
Therefore we need some extra work here. Steps 18,19,20 are not needed if you have an own compiled kernel (e.g. 2.6.7-rc2)
but 2.6.5-1.358custom looks like an "original" Fedora kernel.

Change into your /lib/mdules/2.6.5-1.358custom directory
cd /lib/modules/2.6.5-1.358custom

18) Renam there the build directory
mv build build.old.bak

19) Set now build as symbolic link
ln -s /usr/src/linux-2.6.5-1.358custom build

20) Change back into your kernel source directory
cd /usr/src/linux-2.6.5-1.358custom

21) Install the modules
make modules_install

22) reboot

23) Try to mount your NTFS partitions

If everything is OK then you may clean up to save disk space

24) cd /usr/src/linux-2.6.5-1.358custom
25) make mrproper
26) make clean

Last edited by Vlad-A; 06-22-2004 at 01:20 AM.
 
Old 06-23-2004, 11:46 AM   #30
axess_denied
Member
 
Registered: Jun 2004
Location: DC Metro Area
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15
So I tried everything you said Vlad, thank you. However, when I did this, I lost use of my ethernet card and my Logitech mouse. I really could use some more help... sorry I am a dumb newbie
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Video Card RAMDAC IBM 525 not supported Fedora Core 2 14awl Fedora 1 05-05-2005 01:35 AM
Supported PCI wireless adapters for Fedora Core 3? adabney Linux - Wireless Networking 8 02-16-2005 12:51 PM
Fedora Core 2 - Video Mode Not Supported cblucher67 Fedora 1 11-16-2004 09:47 PM
my computer specs: is this supported in Fedora Core 1? sweet*amber Fedora 5 05-04-2004 11:08 PM
Fedora Core 1, 2.6 and NTFS FrenchTouch Fedora 4 01-02-2004 03:18 AM


All times are GMT -5. The time now is 08:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration