LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-09-2004, 11:47 AM   #1
SROSeaner
LQ Newbie
 
Registered: Jun 2004
Location: Ontario, Canada
Distribution: Fedora Core 2, Mandrake 10.0
Posts: 12

Rep: Reputation: 0
Angry NTFS in Fedora Core 2 not supported


I have installed Fedora Core 2, and am fairly new to Linux.

I am attempting to mount my Windows XP partition (NTFS Volume) in Fedora Core 2, but after typing "cat /proc/filesystems", ntfs does not appear as a filesystem type. I have read that Fedora Core 2 kernel (2.6.5....) has built-in support for ntfs..... well I can't figure it out.

I mount using fstab and specify ntfs, but when I type "mount -a" I get ntfs not supported by kernel.

Oh, on an added note, I downloaded and attempted the install of the following rpm package:

kernel-ntfs-2.6.5-1.358.i586.rpm

And at first, it reported that the package is already installed??

Last edited by SROSeaner; 06-09-2004 at 12:04 PM.
 
Old 06-09-2004, 12:15 PM   #2
RHmicko
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0, ES3.0, Fedora Core 2, Mandrake 10
Posts: 22

Rep: Reputation: 15
Go to this website

I hope it works

Goodluck

http://home.gagme.com/greg/linux/fc2-tips.php

Cheers,

Michael.
 
Old 06-09-2004, 12:15 PM   #3
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
What appears when you
cat /etc/filesystems

(so filesystems located in /etc).

check if the ntfs module is loaded (if installed as loadable module)
lsmod

if not try to load it:
modprobe ntfs

How do you perfrom the mount ?

So what command do you use ?

You shall use something like

mount /dev/hdXY -t ntfs -o ro /mountpoint

where X=is the drive (hda, hdb,hdc....)
and Y the NTFS partition on that drive (1,2,3,....)

/mountpoint is th emountpoint. You shall use the one where you want to
mount the partition.

e.g.

mkdir /mnt/windows
mount /dev/hda1 -t ntfs -o ro /mnt/windows



What is the output of cat /etc/fstab ?

What do you mean ntfs not supported by the kernel ? mount -a means to mount all
entreis from /etc/fstab and not what filesystems are supported.

What is the output of /etc/mtab ?



Last edited by Vlad-A; 06-09-2004 at 12:18 PM.
 
Old 06-09-2004, 12:36 PM   #4
SROSeaner
LQ Newbie
 
Registered: Jun 2004
Location: Ontario, Canada
Distribution: Fedora Core 2, Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the replies. that site gagme is exactly what i have been trying, so that does not work.

here is a response to your questions Vlad-A

cat /etc/filesystems:
ext3
ext2
nodev proc
nodev devpts
iso9660
vfat
hfs

lsmod in terminal says (and I su to root):
bash: lsmod: command not found
modprobe ntfs in terminal says (again, as root):
bash: modprobe: command not found

i tried the mount by using the fstab file, then trying mount -a and i get the following error:
mount: fs type ntfs not supported by kernel

i tried a manual mount from the terminal (mount /dev/hda1 -t ntfs -o ro /mnt/WinXp) and get:
mount: fs type ntfs not supported by kernel

and output of cat /etc/fstab is:
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/sda1 /mnt/USBStorage vfat user,auto,umask=0 0 0
/dev/hda1 /mnt/WindowsXP ntfs defaults 0 0

output of cat /etc/mtab is:
/dev/hda3 / ext3 rw 0 0
none /proc proc rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/hda2 /boot ext3 rw 0 0
none /dev/shm tmpfs rw 0 0
/dev/sda1 /mnt/USBStorage vfat rw,noexec,nosuid,nodev,umask=0 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0

Thanks again for your help Vlad
 
Old 06-09-2004, 12:50 PM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Try /sbin/lsmod and /sbin/modprobe -- you need to switch to root with su - (note the dash0 to get root's environment (and thus root's correct PATH).
 
Old 06-09-2004, 01:13 PM   #6
SROSeaner
LQ Newbie
 
Registered: Jun 2004
Location: Ontario, Canada
Distribution: Fedora Core 2, Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
thanks bt!

Output for lsmod is now:
Module Size Used by
nls_utf8 1536 0
nls_cp437 5376 0
usb_storage 55392 0
snd_mixer_oss 13824 2
snd_intel8x0 26280 3
snd_ac97_codec 50436 1 snd_intel8x0
snd_pcm 68872 1 snd_intel8x0
snd_timer 17156 1 snd_pcm
snd_page_alloc 7940 2 snd_intel8x0,snd_pcm
gameport 3328 1 snd_intel8x0
snd_mpu401_uart 4864 1 snd_intel8x0
snd_rawmidi 17184 1 snd_mpu401_uart
snd_seq_device 6152 1 snd_rawmidi
snd 38372 10 snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_devi ce
soundcore 6112 3 snd
parport_pc 19392 1
lp 8236 0
parport 29640 2 parport_pc,lp
autofs4 10624 0
orinoco_cs 6152 1
orinoco 31500 1 orinoco_cs
hermes 6528 2 orinoco_cs,orinoco
ds 12292 5 orinoco_cs
yenta_socket 15104 1
pcmcia_core 46792 3 orinoco_cs,ds,yenta_socket
sunrpc 101064 1
8139too 17792 0
mii 3584 1 8139too
floppy 47440 0
sg 27552 0
microcode 4768 0
sd_mod 16384 0
scsi_mod 91344 3 usb_storage,sg,sd_mod
vfat 10496 0
fat 33472 1 vfat
joydev 6976 0
dm_mod 33184 0
ehci_hcd 21896 0
uhci_hcd 23708 0
button 4504 0
battery 6924 0
asus_acpi 8472 0
ac 3340 0
i830 55856 2
ipv6 184288 8
ext3 102376 2
jbd 40216 1 ext3

and modprobe ntfs is:
FATAL: Error inserting ntfs (/lib/modules/2.6.5-1.358/kernel/fs/ntfs/ntfs.ko): Invalid module format
 
Old 06-09-2004, 02:03 PM   #7
SROSeaner
LQ Newbie
 
Registered: Jun 2004
Location: Ontario, Canada
Distribution: Fedora Core 2, Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Bump

Bump
 
Old 06-09-2004, 02:15 PM   #8
brentos
Member
 
Registered: Nov 2003
Distribution: Fedora Core3, RHEL3,4
Posts: 92

Rep: Reputation: 15
Try this site
http://linux-ntfs.sourceforge.net/rpm/instructions.html

It is instructions and a download for the Fedora2 RPM to get NTFS to work, as far as I know, NTFS is not supported natively in any RedHat related distro
I have never tried this for Core2 as I am still on Core1 but it worked for RedHad 9 and Core1
Just look the link for Core2 is only on the left side and not in the text like the others.

Goodluck

Let me know if it works or you hit any snags.
 
Old 06-09-2004, 02:17 PM   #9
SROSeaner
LQ Newbie
 
Registered: Jun 2004
Location: Ontario, Canada
Distribution: Fedora Core 2, Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Thank you Brentos. Going to try it now.
 
Old 06-09-2004, 02:17 PM   #10
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Hi,

I have just booted my FC2 and indeed NTFS mount was not possible.
However fixing this, is not a problem at all.

Here what I have done

log in as root

1) make sure your kernel sources are installed
2) find out what kernel version you are running:
uname -a
3) cd /usr/src/linux-2.x.x
so in to the sources of teh kernel version you are running
4) make oldconfig

This produces a .config file.

if you
cat .config|grep NTFS
you will very likely see NTFS support out-commented
# CONFIG_NTFS_FS=n
CONFIG_NTFS_FS=n

open .config File and find the entry: # CONFIG_NTFS_FS=n
Remove the # sign and the leading space and replace the =n with =m (so NTFS will be a loadable module)
the row should look like:
CONFIG_NTFS_FS=m

Now:
make modules
This will take some time. You will be also prompted if you want to enable NTFS debugging and NTFS write.
You can press N (for No). I *strongly* recommend NOT to enable NTFS write support!!!!!!

Ather that and If *and only if* you are running 2.4.x kernel
make dep
make dep is *NOT* necessary if you are running 2.6.x kernel

after that (2.4,x and 2.6.x kernel)
make modules_install

Now you can load the NTFS module by
modprobe ntfs

after this step you shall be able to mount the NTFS partitions.
 
Old 06-09-2004, 02:35 PM   #11
SROSeaner
LQ Newbie
 
Registered: Jun 2004
Location: Ontario, Canada
Distribution: Fedora Core 2, Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Vlad,

Thanks again! This is awesome advice...

At this point, I made the .config file, and using cat, on the file:

cat .config|grep NTFS

I get:

# CONFIG_NTFS_FS is not set

???? I must have done something bad earlier on while attempting this myself... any ideas Vlad?

Oh, and Brentos.... thanks for that site. I actually hit it earlier, and installed the RPM, but appeared to do nothing. It told me it was already installed.

Last edited by SROSeaner; 06-09-2004 at 02:37 PM.
 
Old 06-09-2004, 02:53 PM   #12
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Hello SROSeaner,

I really *doubt* that this is your fault.

make oldconfig creates a .config file containing the configuration of the active kernel.

So if you did not recompile your kernel in the past *or* did recomplie your kernel but using
make oldconfig without changing the NTFS setting then there is one explanation left:

Fedeora delivers a kernel with disabled NTFS by default!!!

I indeed compiled a new kernel (2.6.7-rc2) but have used make oldconfig, without
changing anything related to NTFS. So I have used more or less the default Fedora settings!

Installing a RPM without recompiling the kernel wil not change the configuration of the kernel.
 
Old 06-09-2004, 03:50 PM   #13
axess_denied
Member
 
Registered: Jun 2004
Location: DC Metro Area
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15
I am having the same problems as SRO, I have followed all of your steps Vlad and need to make modules, however, I am unsure how to do this. PLease explain
 
Old 06-09-2004, 03:55 PM   #14
axess_denied
Member
 
Registered: Jun 2004
Location: DC Metro Area
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15
I did
vi linux*.config
changed all that was there
# CONFIG_NTFS_FS is not set
to
CONFIG_NTFS_FS=m
and saved this, now what do I need to do...
Sorry last msg was brief did not give all the info
 
Old 06-09-2004, 03:58 PM   #15
SROSeaner
LQ Newbie
 
Registered: Jun 2004
Location: Ontario, Canada
Distribution: Fedora Core 2, Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
What I did was type:

make modules

and away it went. looooong process.... but i still do not have ntfs fs support. my cat of .config|grep NTFS yielded a different result than Vlad's
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Video Card RAMDAC IBM 525 not supported Fedora Core 2 14awl Fedora 1 05-05-2005 01:35 AM
Supported PCI wireless adapters for Fedora Core 3? adabney Linux - Wireless Networking 8 02-16-2005 12:51 PM
Fedora Core 2 - Video Mode Not Supported cblucher67 Fedora 1 11-16-2004 09:47 PM
my computer specs: is this supported in Fedora Core 1? sweet*amber Fedora 5 05-04-2004 11:08 PM
Fedora Core 1, 2.6 and NTFS FrenchTouch Fedora 4 01-02-2004 03:18 AM


All times are GMT -5. The time now is 04:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration