LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2004, 02:19 PM   #1
JohnnyNapalm
LQ Newbie
 
Registered: Mar 2004
Posts: 22

Rep: Reputation: 15
NTFS-Captive drivers, and installing


I installed the standard .rpm off the website, but do I need to do anything extra (mounting the harddrive) to enable it?
 
Old 03-30-2004, 04:40 PM   #2
wiBo
Member
 
Registered: Aug 2003
Location: Saint-Georges de Beauce
Distribution: Gentoo soon..
Posts: 193

Rep: Reputation: 30
Read the instructions before installing..

You run captive-install acquire for identify your NTFS partitions..

After :

mkdir /mnt/NAME_OF_YOUR_MOUNT_POINT
mount -t captive-ntfs /dev/hdax /mnt/NAME_OF_YOUR_MOUNT_POINT


hdax = x is the number of your Windows NTFS partition...
like hda6 :-)

Try that


Last edited by wiBo; 03-30-2004 at 04:45 PM.
 
Old 03-30-2004, 05:00 PM   #3
JohnnyNapalm
LQ Newbie
 
Registered: Mar 2004
Posts: 22

Original Poster
Rep: Reputation: 15
i did read the instructions, and did not find them to be helpful at all.

after following your instructions, i can now no longer see ANYTHING in any of my NTFS drives. How do I reverse the effects?
 
Old 03-30-2004, 05:01 PM   #4
wiBo
Member
 
Registered: Aug 2003
Location: Saint-Georges de Beauce
Distribution: Gentoo soon..
Posts: 193

Rep: Reputation: 30
I have due that here and no problems :/

Try to unmount

umount /mnt/mount_point

What do you want to say, cauze my english is poor :/

Last edited by wiBo; 03-30-2004 at 05:03 PM.
 
Old 03-30-2004, 05:21 PM   #5
JohnnyNapalm
LQ Newbie
 
Registered: Mar 2004
Posts: 22

Original Poster
Rep: Reputation: 15
ok, restarted the comp, the drive is mounted as it had been.

now,

when i installed captive off of the rpm, it made two new mount points, one for each ntfs drive in my computer, so doing the "mkdir" command was unneccessary. then i tried to mount it as such:

mount -t captive-ntfs dev/hda7 /mnt/captive-extras

it returned no errors, but when i look into the folder, it's completely empty. explain?
 
Old 03-30-2004, 06:51 PM   #6
JohnnyNapalm
LQ Newbie
 
Registered: Mar 2004
Posts: 22

Original Poster
Rep: Reputation: 15
anybody have any ideas?
 
Old 03-30-2004, 07:12 PM   #7
wiBo
Member
 
Registered: Aug 2003
Location: Saint-Georges de Beauce
Distribution: Gentoo soon..
Posts: 193

Rep: Reputation: 30
try with mkdir
 
Old 03-30-2004, 07:26 PM   #8
sirpimpsalot
Member
 
Registered: Feb 2004
Posts: 141

Rep: Reputation: 15
permissions? try adding umount=000 to each ntfs entry in /etc/fstab file.
 
Old 03-30-2004, 09:19 PM   #9
Mr_C
Member
 
Registered: Jan 2004
Location: Trinidad & Tobago
Distribution: Slackware
Posts: 317

Rep: Reputation: 30
are you sure you read the documentation??

mkdir /var/lib/captive

must contain ntfs.sys and ntoskrnl.exe of your current ntfs drive (yes they change with service pack updates)

then you mount like normal ( by default, only root can write files on the ntfs)

WITH THE DRIVE UNMOUNTED

chmod u+rw /mnt/ntfs (or wherever you mounting your drive)
 
Old 03-31-2004, 07:45 PM   #10
JohnnyNapalm
LQ Newbie
 
Registered: Mar 2004
Posts: 22

Original Poster
Rep: Reputation: 15
ok, i got it mounted ok, but if i'm always logged into my normal account, how can i ever write to it, if that's a root only privalege
 
Old 03-31-2004, 08:55 PM   #11
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
su to root and then wirte and read from the dirve
 
Old 03-31-2004, 10:58 PM   #12
JohnnyNapalm
LQ Newbie
 
Registered: Mar 2004
Posts: 22

Original Poster
Rep: Reputation: 15
is there no way to drag and drop?
 
Old 04-02-2004, 11:32 AM   #13
Mr_C
Member
 
Registered: Jan 2004
Location: Trinidad & Tobago
Distribution: Slackware
Posts: 317

Rep: Reputation: 30
do the chmod on the directory (UNMOUNTED) and you can write to like a normal user...
 
Old 04-02-2004, 11:41 AM   #14
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
With regular ntfs/fat you can use the 'umask=0' option to give everybody access... not sure if it works with Captive.
mount -t captive-ntfs /dev/hda7 /mnt/captive-extras -o umask=0

You can add it to fstab to make it permanent.
 
Old 04-04-2004, 11:18 PM   #15
Mr_C
Member
 
Registered: Jan 2004
Location: Trinidad & Tobago
Distribution: Slackware
Posts: 317

Rep: Reputation: 30
it appears not with respect to the umask00 and captive....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone use captive-ntfs? bosewicht Linux - Newbie 1 06-03-2005 06:16 AM
Installing Captive drivers to reasd NTFS drives transparently crash_zero Mandriva 6 02-12-2005 07:57 PM
Writing to an NTFS volume using captive-ntfs (repairing boot.ini) macskeeball Linux - General 3 02-06-2005 10:28 PM
captive-ntfs drivers rule!! orange400 Linux - Software 2 11-13-2004 10:05 AM
Captive NTFS -- full r/w ntfs access for Linux spurious Linux - Software 6 01-09-2004 01:29 AM


All times are GMT -5. The time now is 06:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration