LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-26-2004, 12:29 AM   #1
NWS
LQ Newbie
 
Registered: Jun 2004
Posts: 10

Rep: Reputation: 0
ntfs automatic mount & root permissions


i've just configured an xp/redhat dual boot system on my home pc, and i'm having some newbie problems.

one of which is that i can only read my ntfs drive if i'm logged in as root user. if i login as myself (NWS), then i can't get to the folder because i don't have the "permissions". I've edited my fstab to look like:

------------------------------------------
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/usr /usr ext3 defaults 1 2
/dev/hda9 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hdb1 /mnt/xp ntfs ro, umask=000 0 0
--------------------------------------------

The ntfs drive that i want to see is hdb1 on the last line. I've also tried using the lines gid=NWS and uid=NWS, but neither of those options work. Other umask options like the ones described on the ntfs project page do not work either.

Can anyone help?
 
Old 06-26-2004, 03:01 AM   #2
lacerto
Member
 
Registered: Oct 2003
Location: South London
Distribution: Gentoo.
Posts: 297

Rep: Reputation: 30
Try
mount -t nfs yourmachine:/yourshare /mnt/yourshare type nfs (rw,addr=192.168.1.*)
or in fstab
yourmachine:/yourshare on /mnt/yourshare type nfs (rw,addr=192.168.1.*)

Remember that the user must have read/write permissions to the mount point
 
Old 06-26-2004, 03:05 AM   #3
lacerto
Member
 
Registered: Oct 2003
Location: South London
Distribution: Gentoo.
Posts: 297

Rep: Reputation: 30
Sorry...I totally misread your post - I thought were talking about NFS, not NTFS!

Just make sure the mount point is readable by the user.
 
Old 06-26-2004, 04:12 AM   #4
Xodiak
LQ Newbie
 
Registered: Jun 2004
Location: Athens, Greece
Distribution: Mandrake 10.1
Posts: 6

Rep: Reputation: 0
I think it must be the umask option which controls permissions.
http://linux-ntfs.sourceforge.net/info/ntfs.html#4.9
I usually set it to umask=0222
 
Old 06-26-2004, 07:41 AM   #5
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Quote:
Originally posted by NWS:

one of which is that i can only read my ntfs drive
actually this is quite fortunate, as chances are, your linux kernel doesn't support NTFS writing. You'll kill your hard-drive doing this.
 
Old 06-26-2004, 11:52 AM   #6
NWS
LQ Newbie
 
Registered: Jun 2004
Posts: 10

Original Poster
Rep: Reputation: 0
scuzz,

What I mean is that I can only access my ntfs drive if I'm logged in as the root user. None of my other users can get to it, and I want them to be able to. My kernel supports NTFS read cuz I used the NTFS project page to download and install read support for the ntfs drive.
 
Old 06-26-2004, 11:53 AM   #7
NWS
LQ Newbie
 
Registered: Jun 2004
Posts: 10

Original Poster
Rep: Reputation: 0
lacerto,

How do I make sure the mount point is readable by the user?
 
Old 06-26-2004, 11:54 AM   #8
NWS
LQ Newbie
 
Registered: Jun 2004
Posts: 10

Original Poster
Rep: Reputation: 0
i've tried the umask=0222 option and it still doesn't work
 
Old 07-21-2004, 02:44 AM   #9
amit101
LQ Newbie
 
Registered: Jul 2004
Location: Pune,India
Distribution: Mandrake 8.2
Posts: 1

Rep: Reputation: 0
Lightbulb

try the following option in fstab .. it works for me

ro,auto,user,exec,umask=0222
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NTFS mount permissions azoghbi Linux - Newbie 3 10-31-2005 05:40 PM
automatic driver load & device permissions xtravar Linux - Hardware 0 06-17-2005 12:30 PM
Can't change the read permissions on an NTFS partition as root? EOHooligan Linux - Newbie 4 01-09-2005 06:48 AM
Write to NTFS mount as non-root electronique Slackware 2 11-01-2004 02:24 AM
NTFS Permissions and Automatic Mount dbzw Linux - Newbie 2 02-26-2004 09:59 PM


All times are GMT -5. The time now is 06:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration