LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-25-2014, 05:09 AM   #1
moreroz
LQ Newbie
 
Registered: Jan 2013
Posts: 28

Rep: Reputation: 0
ns2 version-2.34 is too old-wpan-802.15.4


Hi, recently I downloaded wpan11.tar.gz from zheng's web site
https://sites.google.com/site/jzhengresearch/pub/file
I follow his readme file but when I run ./install I see below error also I usu NS2.34 But I see this error
By the I'm using ubuntu 12.04 if it usefull. OK what should I do.Can anybody help me to how fix this error?

Determine ns2 and nam pathes ...done
>> ns2 version: 2.34
>> ns2 directory: /home/reza/ns-allinone-2.34/ns-2.34
>> nam dirctory: /home/reza/ns-allinone-2.34/nam-1.14
Your ns2 (version 2.34) is too old
You need at least version 2.26 to install this packag

Last edited by moreroz; 03-27-2014 at 03:28 AM.
 
Old 03-25-2014, 09:50 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Welcome to LQ.

`wpan11.tar.gz' has a time stamp = Year 2004.
The files are meant for ns2 versions with no wpan : ns-2.26 .. ns-2.27,
.. and might also update the ns-2.28/wpan/**.

* About your question, at nabble.ns2 : "Can not open request log11" ..
http://network-simulator-ns-2.7690.n...l-td28476.html
.. Not easy to guess which changes you made to ns-2.34 :
The simulation $ ns wpan_demo1.tcl : No errors here with an original ns234.
Also : You can add almost any "extra protocol" / patch to ns-2.3x,
and "$ ns wpan_demo1.tcl" will still work with no errors :
→ I made 35 times different "$ ns-<added-protocol>" : 2 or 3 failed,
none with "can not open request log11" !
-
Attached Files
File Type: txt test__wpan_demo1.tcl.txt (975 Bytes, 28 views)

Last edited by knudfl; 03-25-2014 at 09:51 AM.
 
1 members found this post helpful.
Old 03-26-2014, 06:28 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
About "can not open request log11"
http://network-simulator-ns-2.7690.n...t-td28481.html

.. Won't help you much even if there was an error list,
or if you could debug your executable 'ns'.

It's much easier to guess how you got there :
Could be "a wrong OS", i.e. a 64bits (x86_64) Ubuntu,
combined with the use of the wrong compiler for ns-2.34.
( Should be gcc/g++ version 4.1.2 ).

All ns2 is for a 32bits (i686) OS.
Most ns-2.2x / 2.3x versions can be used with a 64bits OS.
But always with an inferior validate result.

So which Ubuntu 11.04 (EDIT to 12.04) are you using ?
Please show the output from the command : $ uname -m <Enter>

For the 32bits, i686 Ubuntu 11.04, please use gcc41/g++41, post #14 here
http://www.linuxquestions.org/questi...4-a-944856/#14
EDIT : Ubuntu 12.04 -i686, post #18 here ...
http://www.linuxquestions.org/questi...022/page2.html

Building : Start from scratch with a new unpacked ns-allinone-2.34.tar.gz :
$ cd ns-allinone-2.34/ && export CC=gcc41 CXX=g++41 && ./install

-

Last edited by knudfl; 04-02-2014 at 03:57 AM.
 
1 members found this post helpful.
Old 03-26-2014, 04:38 PM   #4
moreroz
LQ Newbie
 
Registered: Jan 2013
Posts: 28

Original Poster
Rep: Reputation: 0
Thanks , I use Ubuntu 12.04, 32 bit and now I want to try another part of your answer gcc4.5 and gcc4.5 thanks dear knudfl
 
Old 03-26-2014, 06:31 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 4 .
Quote:
gcc4.5 and gcc4.5
Do not use gcc-4.5 / g++-4.5 : gcc41/g++41 will do the job,
.. and no edits are to be done in ns-allinone-2.34 : Use as is, please.

The build command for ns-allinone-2.34 in 'Ubuntu 12.04 - i686' is :
$ cd ns-allinone-2.34/ && export CC=gcc41 CXX=g++41 && ./install

I.e. the gcc / g++ compilers, version 4.1.2 will build with no errors,
and create an executable 'ns' with no issues.

The compilers for Ubuntu 12.04 - i686, see post #18 here ..
http://www.linuxquestions.org/questi...022/page2.html

-
 
1 members found this post helpful.
Old 03-27-2014, 02:45 AM   #6
moreroz
LQ Newbie
 
Registered: Jan 2013
Posts: 28

Original Poster
Rep: Reputation: 0
@knfufl thanks, but in previous I did some changes in NS2 based on these change

+++++++++++++++++++++++++++++
+++++++++++++++++++++++++++++
By the way I previous In run my tcl files with no error But I saw "Can not open request log11" when I want to run wpan_demo1.tcl in ns-allinone-2.34/ns-2.34/tcl/ex/wpan by write
ns wpan_demo1.tcl



+++++++++++++++++++++++++++++
+++++++++++++++++++++++++++++
1. Do you tell me I should unistall my ns2 ? and again install ns2.34 and compile it with g++4.1 and g++4.1 packages?

Note: before tiring to unisatall I downloaded gcc4.1 and g++4.1 from your seggested link in(*)
http://www.linuxquestions.org/questi...4-a-944856/#14
and write this commands #3
Quote:
sudo dpkg -i gcc41-compat-4.1.2_i386.deb g++41-compat-4.1.2_i386.deb
.. Then reboot, and the new compilers can be used.
After that I wrote this #5
Quote:
$ cd ns-allinone-2.34/ && export CC=gcc41 CXX=g++41 && ./install
But I saw an error during installation
".
.
.
.
.
* Build tcl8.4.18
============================================================
configure: WARNING: unrecognized options: --enable-gcc
checking whether to use symlinks for manpages... no
checking whether to compress the manpages... no
checking whether to add a package name suffix for the manpages... no
checking for gcc... gcc41
checking whether the C compiler works... no
configure: error: in `/home/reza/ns-allinone-2.34/tcl8.4.18/unix':
configure: error: C compiler cannot create executables
See `config.log' for more details
tcl8.4.18 configuration failed! Exiting ...
Tcl is not part of the ns project. Please see www.Scriptics.com
to see if they have a fix for your platform"
"



+++++++++++++++++++++++++++++
+++++++++++++++++++++++++++++
2. Inorder to complete unistall NS2 on my 12.04 ubuntu is true to write this command :
sudo apt-get purge --auto-remove NS2 ?
[Sorry to ask ...I ask this because I had some problems to unistall non Ubuntu's repository packages in previous. ]
I saw that command termianl from belove link
http://www.installion.co.uk/ubuntu/r...uninstall.html
Attached Files
File Type: txt Ns_Install.txt (6.4 KB, 20 views)

Last edited by moreroz; 03-27-2014 at 03:23 AM.
 
Old 03-27-2014, 04:00 AM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 6 .
Quote:
1. Do you tell me I should unistall my ns2 ?
No. You can have as many ns-allinone-2.xx as you want, installed at the same time.
But : Do not add any *PATH text to .bashrc : Never required.

How do you think I made the 35 times post #2 test ?
I didn't uninstall/install 35 times. It's a simple thing :
Keep all the executable ns* in /usr/local/bin/: The default ns install location!
Read "test__wpan_demo1.tcl.txt" to understand that ns can have different names :
ns, ns-orig, ns234, etc. etc. ( I have eighty (80) times ns**). Read post #2.

2."--auto-remove NS2 ?" : Only binary packages.deb can be removed.
Your ns234 is not a package : You say you modified ns-allineone-2.34?


Quote:
checking for gcc... gcc41
checking whether the C compiler works... no
"gcc41 / g++41" wasn't installed :
Please check presence of a tool before you are trying to use it :
A) $ which gcc41
B) $ which g++41
C) $ which g++


Quote:
but in previous I did some changes in NS2 ...
... based on these change
Which changes ? Please tell :
It's interesting to know, in order to track the wpan behavior.

-

Last edited by knudfl; 03-27-2014 at 04:08 AM.
 
1 members found this post helpful.
Old 03-29-2014, 03:29 AM   #8
moreroz
LQ Newbie
 
Registered: Jan 2013
Posts: 28

Original Poster
Rep: Reputation: 0
@knudfl thanks a lot dear knudfl for your help. But still there is a point that I do not get it
suppose that I have had NS2.34 and also I added its PATH to my bashrc and Now I want to install NS2.35 based on #7
Quote:
But : Do not add any *PATH text to .bashrc : Never required.
but the problem for is here when I run "NS 1.tcl" this NS refer to 2.34 or 2.35
Please tell my if I am wrong.

Last edited by moreroz; 03-29-2014 at 04:36 AM.
 
Old 03-29-2014, 04:27 AM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 8 .

Repeat : Please answer the question from post #8 (and #2) :
Which changes were made to ns-2.34 ?
I.e. the changes causing the "can not open request log11" error.
It's an interesting error, and an explanation will help other ns users to avoid those issues.


""Do never add any *PATH text to .bashrc"" : If you did, delete it.
See post #2, the attached text : Make a copy of your different executable 'ns',
to new names, e.g. 'ns234', 'ns235' or whatever is relevant.
Then copy those new executable to /usr/local/bin/ : A system PATH.
And run simulations with $ ns234 file-name.tcl ,,, $ ns235 other-file.tcl
→ →
Do not run like $ ns 1.tcl
.. You can't be absolutely sure which of the 'ns's is going to be used.

-

Last edited by knudfl; 03-29-2014 at 11:09 AM.
 
1 members found this post helpful.
Old 03-30-2014, 11:41 AM   #10
moreroz
LQ Newbie
 
Registered: Jan 2013
Posts: 28

Original Poster
Rep: Reputation: 0
I want to say at first how I installed ns2.34 on ubuntu12.04, after that some changes that I made, at the end I have two questions

  1. How did I install ns2.34 on ubuntu 12.04 ?
    I exactly did this instructions from this link Installation of ns-2.34 in Ubuntu (preferably 12.04) except two parts
    1. I copied ns-allinone-2.34 to home directory not Desktop
    2. and also I did not put
      Quote:
      sudo apt-get install xorg-dev g++ xgraph
      from part three of the instructions
    3. I add PATHes to ~/.bashrc not ~/.bash_aliases

  2. what changes I have done ?
    I just did these changes from this link integration-of-rred
    Quote:
    The Robust Random Early Detection (RRED) algorithm can be integrated into the NS2 distributions in these steps:
    1. Copy the following files into the directory "ns-allinone-2.33\ns-2.33\queue".
    red-robust.h
    red-robust.cc

    2. Add the following lines to the end of ns-default.tcl ("ns-allinone-2.33\ns-2.33\tcl\lib\ns-default.tcl").
    # Added by leoking RobustRed config 0
    Queue/RED/Robust set hash_bins_ 23
    Queue/RED/Robust set hash_levels_ 2
    Queue/RED/Robust set score_max_ 10
    Queue/RED/Robust set score_min_ -1
    Queue/RED/Robust set score_pass_ 0
    Queue/RED/Robust set last_drop_time_ 0ms
    Queue/RED/Robust set drop_related_period_ 10ms
    # Added by leoking RobustRed config 1

    3. Insert the following line of code before "$(OBJ_STL)" in the Makefile ("ns-allinone-2.33\ns-2.33\Makefile"):
    queue/red-robust.o \

    4. Recompile the ns-allinone-2.33 system by using the following commands (you should execute these commands in the ns-2.33 directory "ns-allinone-2.33\ns-2.33"):
    make clean
    make depend
    make
  3. my questions:
    1. From #9 :
      Quote:
      See post #2, the attached text : Make a copy of your different executable 'ns',to new names, e.g. 'ns234', 'ns235' or whatever is relevant.Then copy those new executable to /usr/local/bin/ : A system PATH.And run simulations with $ ns234 file-name.tcl ,,, $ ns235 other-file.tcl
      would you please tell me to copy which file exactly from ns2.34 directory? there is a executable file with name 'ns'.I should rename this one -ns- to for example ns234 and copy this one to /usr/local/bin? please look at ns-234.jpg attached file.
    2. From #9:
      Quote:
      Do never add any *PATH text to .bashrc"" : If you did, delete it.
      I add these PATHs to my bashrc based on Installation of ns-2.34 in Ubuntu (preferably 12.04).You say I should remove which line of this all of them
      Quote:
      # LD_LIBRARY_PATH
      OTCL_LIB=/home/anurag/Desktop/ns-allinone-2.34/otcl-1.13
      NS2_LIB=/home/anurag/Desktop/ns-allinone-2.34/lib
      X11_LIB=/usr/X11R6/lib
      USR_LOCAL_LIB=/usr/local/lib
      export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$OTCL_LIB:$NS2_LIB:$X11_LIB:$USR_LOCAL_LIB

      # TCL_LIBRARY
      TCL_LIB=/home/anurag/Desktop/ns-allinone-2.34/tcl8.4.18/library
      USR_LIB=/usr/lib
      export TCL_LIBRARY=$TCL_LIB:$USR_LIB

      # PATH
      XGRAPH=/home/anurag/Desktop/ns-allinone-2.34/bin:/home/anurag/Desktop/ns-allinone-2.34/tcl8.4.18/unix:/home/anurag/Desktop/ns-allinone-2.34/tk8.4.18/unix
      NS=/home/anurag/Desktop/ns-allinone-2.34/ns-2.34/
      NAM=/home/anurag/Desktop/ns-allinone-2.34/nam-1.14/
      PATH=$PATH:$XGRAPH:$NS:$NAM
By the way do you seggeut a link to install ns2.34 in a correct way which you consider please

Last edited by moreroz; 04-02-2014 at 03:05 PM.
 
Old 03-30-2014, 02:41 PM   #11
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 10 . 1)
Quote:
I exactly did this instructions from this link
http://ns2-ubuntu.blogspot.fr/
That's is almost what I guessed : Erlend's Lookout Post
http://erl1.wordpress.com/2011/10/14...neiric-ocelot/
... or a copy of "Erlend's Lookout Post".
The problem is that it isn't always working.

2)
Quote:
what changes I have done ?
I just did these changes from this link integration-of-rred
https://docs.google.com/viewer?pid=s...on-of-rred.txt
OK, then do not expect default simulations like wpan to work.
** For default simulations, build an ns-2.34 with no changes.
And save `ns-allinone-2.34/ns-2.34/ns' as "ns234-orig" :
/usr/local/bin/ns234-orig .

3)
Quote:
I add these PATHs to my bashrc ....
... should I remove which line of this all of them ..
* Delete it all.
The executable ns* is hard coded to know the location of it's libraries :
Meaning that setting library path's for ns makes no sense at all.
* All the " *PATH* text" is just a 1997-1999 ( !15 years old! ) text.
Not required any more. 'nam' → copy nam to /usr/local/bin.
'xgraph' is already in /usr/bin/ . Etc. etc.

3) Read post #2 : All the ns-*** in "test__wpan_demo1.tcl.txt"
are examples of my eighty (80) times ns-<name> in /usr/local/bin/ .

-

Last edited by knudfl; 03-30-2014 at 03:01 PM.
 
1 members found this post helpful.
Old 04-01-2014, 09:18 AM   #12
moreroz
LQ Newbie
 
Registered: Jan 2013
Posts: 28

Original Poster
Rep: Reputation: 0
--> thanks

First I deleted all of contents(related to ns2) which I haved added to bashrc.
But still I have some questions
From #5
Quote:
.. and no edits are to be done in ns-allinone-2.34 : Use as is, please.
and From #11
Quote:
** For default simulations, build an ns-2.34 with no changes.
Would you please talk more about no changes: because there is still some
changes which I think I must do based on related links. I divide them to two parts
  1. Changes in Makefile.in based on http://www.linuxquestions.org/questi...10-a-782783/#2
    Quote:
    2) Edit the ' Makefile.in ' in each application from

    CC = @CC@
    CPP = @CXX@

    to

    CC = gcc-4.3
    CPP = g++-4.3
    1. Am I should do these changes too?
    2. If yes, My gcc and g++ version are gcc41 and g++41 based on http://www.linuxquestions.org/questi...4-a-944856/#14
      Quote:
      Must be : export CC=gcc41 CXX=g++41

      But first you must download and install gcc41, g++41 :
      gcc41-compat https://docs.google.com/open?id=0B7S...RjNjJhOTZjNjI2
      g++41-compat https://docs.google.com/open?id=0B7S...hjMjljN2M2MGU4

      sudo dpkg -i gcc41-compat-4.1.2_i386.deb g++41-compat-4.1.2_i386.deb
      .. Then reboot, and the new compilers can be used
      and From #5
      Quote:
      Do not use gcc-4.5 / g++-4.5 : gcc41/g++41 will do the job,
      What do I write instead of gcc-4.3 and g++-4.3 ?

      CC = @CC@
      CPP = @CXX@

      to

      CC = gcc41 or gcc41-compat-4.1.2_i386.deb or gcc41-compat or ...
      CPP =g++41 or g++41-compat-4.1.2_i386.deb or g++41-compat or ...

  2. Other changes(Non bashrc) adopted from http://erl1.wordpress.com/2011/10/14...neiric-ocelot/
    What about these? Am I add them or not?

    Quote:
    Fix the error in the linking of otcl by editing line 6304 of otcl-1.13/configure so that it reads
    SHLIB_LD="gcc -shared"
    instead of
    SHLIB_LD="ld -shared"

    Then, edit the file ns-2.34/tools/ranvar.cc and change the line 219 from
    return GammaRandomVariable::GammaRandomVariable(1.0 + alpha_, beta_).value() * pow (u, 1.0 / alpha_);
    to
    return GammaRandomVariable(1.0 + alpha_, beta_).value() * pow (u, 1.0 / alpha_);

    Next, change the lines 183 and 185 in file ns-2.34/mobile/nakagami.cc to read
    resultPower = ErlangRandomVariable(Pr/m, int_m).value();
    and
    resultPower = GammaRandomVariable(m, Pr/m).value();

    Add a line after line 64 in ns-2.34/mac/mac-802_11Ext.h to read:
    #include <stddef.h>

Last edited by moreroz; 04-01-2014 at 11:31 AM.
 
Old 04-01-2014, 11:26 AM   #13
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 12 .

! If you want a "clean" executable 'ns-orig' to use for default simulations,
! do no changes.


Quote:
1. Changes in Makefile.in based on http://www.linuxquestions.org/questi...10-a-782783/#2
! Please do not use old advices specifically meant for Ubuntu 9.10, 10.04 .
The post is dated `17 January 2010' :
{ gcc-4.3 g++-4.3 } worked with 9.10,,, and for a short time with 10.04 :
Until 10.04 got updated.

1. ""What do I write instead of .."" : No changes means no changes at all !


Quote:
2. Other changes(Non bashrc) adopted from http://erl1.wordpress.com/2011/10/14...neiric-ocelot/
What about these? Am I add them or not?
Only for use with gcc-4.5, which isn't available for all later Ubuntu's.
And besides that, it's also "old advices" : Not necessarily valid any more.
So please do not make any changes at all :
{ gcc41, g++41 } will do the job : All ns226..ns234 / all Ubuntu 10.04 ..13.10 .

-

Last edited by knudfl; 04-01-2014 at 11:30 AM.
 
1 members found this post helpful.
Old 04-02-2014, 02:23 AM   #14
moreroz
LQ Newbie
 
Registered: Jan 2013
Posts: 28

Original Poster
Rep: Reputation: 0
thanks,

I did all prevois steps .what about gcc41 and g++41. would you give a bit more comments please:
From #3
Quote:
For the 32bits, i686 Ubuntu 11.04, please use gcc41/g++41, post #14 here
http://www.linuxquestions.org/questi...4-a-944856/#14

Building : Start from scratch with a new unpacked ns-allinone-2.34.tar.gz :
$ cd ns-allinone-2.34/ && export CC=gcc41 CXX=g++41 && ./install
  1. I downloaded gcc41 and g++41 from google docs that exist in upper link to my desktop.
  2. sudo dpkg -i g++41-compat-4.1.2_i386.deb gcc41-compat-4.1.2_i386.deb
  3. based on #7
    Quote:
    Please check presence of a tool before you are trying to use it :
    A) $ which gcc41
    B) $ which g++41
    C) $ which g++
    when I type
    Code:
    which gcc41
    /usr/gcc41/bin/gcc41
    
    which g++41
    /usr/gcc41/bin/g++41
    
    which gcc
    /usr/bin/gcc
    
    which g++ 
    /usr/bin/g++
    
    sudo dpkg -l | grep gcc
    ii  gcc                                    4:4.6.3-1ubuntu5                        GNU C compiler
    ii  gcc-4.5                                4.5.3-12ubuntu2                         The GNU C compiler
    ii  gcc-4.5-base                           4.5.3-12ubuntu2                         The GNU Compiler Collection (base package)
    ii  gcc-4.6                                4.6.3-1ubuntu5                          GNU C compiler
    ii  gcc-4.6-base                           4.6.3-1ubuntu5                          GCC, the GNU Compiler Collection (base package)
    ii  gcc41-compat                           4.1.2                                   No description
    ii  libgcc1                                1:4.6.3-1ubuntu5                        GCC support library
    
    sudo dpkg -l | grep g++
    ii  g++                                    4:4.6.3-1ubuntu5                        GNU C++ compiler
    ii  g++-4.5                                4.5.3-12ubuntu2                         GNU C++ compiler
    ii  g++-4.6                                4.6.3-1ubuntu5                          GNU C++ compiler
    ii  g++41-compat                           4.1.2                                   No description
    {I bold and highlight gcc41-compat and g++41-compat to emphasize }

But I can not install my (new downloded and without any changes) ns2.34 on my ubuntu 32 bit 12.04:
Code:
reza@reza-N43JM:~/ns-allinone-2.34$ export CC=gcc41 CXX=g++41 && ./install > 1.txt
And here is 1.txt :
...sorry for this long ouput I put to them in a attached file with name 1.txt
Quote:
============================================================
* Testing for Darwin (OS X) environment
============================================================
============================================================
* Testing for Cygwin environment
============================================================
Cygwin not detected, proceeding with regular install.
============================================================
* Testing for FreeBSD environment
============================================================
FreeBSD not detected
============================================================
* Build XGraph-12.1
============================================================
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking if malloc debugging is wanted... no
checking for gcc... gcc41
checking whether the C compiler (gcc41 ) works... no
Can not create xgraph; But xgraph is an optional package, continuing...
============================================================
* Build CWeb
============================================================
Making cweb
gcc -g -c -o ctangle.o ctangle.c
gcc -g -DCWEBINPUTS=\"/usr/local/lib/cweb\" -c common.c
gcc -g -o ctangle ctangle.o common.o
gcc -g -c -o cweave.o cweave.c
gcc -g -o cweave cweave.o common.o
============================================================
* Build Stanford GraphBase
============================================================
Making sgb
gcc41 -g -I/usr/local/sgb/include -DDATA_DIRECTORY=\"/usr/local/sgb/data/\" -c gb_io.c
Unable to create sgb library, but it's optional, so continuing...
============================================================
* Build GT-ITM
============================================================
sgb lib not found. gt-itm & sgb2ns could not be installed. Continuing..
============================================================
* Build zlib
============================================================
Building static library libz.a version 1.2.3 with gcc41.
Checking for unistd.h... No.
Checking whether to use vs[n]printf() or s[n]printf()... using s[n]printf()
Checking for snprintf() in stdio.h... No.
WARNING: snprintf() not found, falling back to sprintf(). zlib
can build but will be open to possible buffer-overflow security
vulnerabilities.
Checking for return value of sprintf()... No.
WARNING: apparently sprintf() does not return a value. zlib
can build but will be open to possible string-format security
vulnerabilities.
Checking for errno.h... No.
Checking for mmap support... No.
gcc41 -O3 -DNO_snprintf -DHAS_sprintf_void -DNO_ERRNO_H -c -o example.o example.c
Zlib make failed, but it's optional Continue ...
============================================================
* Build tcl8.4.18
============================================================
checking whether to use symlinks for manpages... no
checking whether to compress the manpages... no
checking whether to add a package name suffix for the manpages... no
checking for gcc... gcc41
checking whether the C compiler works... no
Attached Files
File Type: txt 1.txt (3.4 KB, 9 views)

Last edited by moreroz; 04-02-2014 at 02:50 AM.
 
Old 04-02-2014, 04:01 AM   #15
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 14 .
Quote:
For the 32bits, i686 Ubuntu 11.04, please use gcc41/g++41, post #14 here
http://www.linuxquestions.org/questi...4-a-944856/#14
I don't think you have "Ubuntu 11.04". Post #14 says "my ubuntu 32 bit 12.04".
* Ubuntu 12.04 : See post #5.
... (Sorry for the "11.04 text" in post #3.)

-
 
1 members found this post helpful.
  


Reply

Tags
ns2, ubuntu 12.04


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
buffer inside MAC 802.15.4 in ns2 syanadia Linux - Newbie 0 09-12-2012 09:26 PM
802.11s support in ns2 houaidia Linux - Newbie 0 06-04-2012 05:17 PM
which ns2 version is compatible for TKN 802.11e patch stud17 Linux - Newbie 8 03-18-2012 12:12 PM
NS2 installation problem: no rule to make target 'VERSION' , needed by gen/version.c bilabongster Linux - Newbie 23 12-07-2011 12:54 PM
need 802.11e patch for ns2 stud17 Linux - Software 1 03-09-2011 07:54 AM


All times are GMT -5. The time now is 02:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration