LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2012, 04:00 AM   #1
veno
LQ Newbie
 
Registered: Jul 2012
Posts: 2

Rep: Reputation: Disabled
Angry ns2.35 make failes


HI.. i have 2 doubts and need clarifications.please help me im trying this for about 6 months to do my final year project.

1.My OS is Windows XP and processor is Intel Pentium dual core.I want to install ns2.35 in any linux environment.
So i installed VMware Player version: 4.0.1 build-528992
while installing any OS inside it shows:"software virtualization is incompatible with long mode on this platform disabling long mode the virtual machine will not be able to run 64 bit code" is there any problem

2. After ignore that message and i installed linux(i tried with ubuntu11.04, ubuntu 9.04, fedora 14, redhat5) to install ns2.35(network simulator). but i cant install ns2.35 which i had tried a lot about 6 months, it shows the error tk8.5.10 make failed
 
Old 07-20-2012, 05:50 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,635

Rep: Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268
Welcome to LQ.

Ubuntu 11.04 : sudo apt-get install \
g++ g++-4.4 make patch autoconf automake libtool libxmu-dev xgraph

cd ns-allinone-2.35/ && export CC=gcc-4.4 CXX=g++-4.4 && ./install


Fedora (14) and RHEL 5, RHEL 6 : # yum install \
gcc-c++ compat-gcc-34-c++ automake autoconf libtool libX11-devel \
libXext-devel libXau-devel libXmu-devel xorg-x11-proto-devel

cd ns-allinone-2.35/ && ./install

.
 
Old 07-24-2012, 06:53 AM   #3
veno
LQ Newbie
 
Registered: Jul 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thumbs up working fine

Hi. ...thank you ..I installed ns2.35 in Ubuntu 11.04..its working good.. thank you frnd

Quote:
Originally Posted by knudfl View Post
Welcome to LQ.

Ubuntu 11.04 : sudo apt-get install \
g++ g++-4.4 make patch autoconf automake libtool libxmu-dev xgraph

cd ns-allinone-2.35/ && export CC=gcc-4.4 CXX=g++-4.4 && ./install


Fedora (14) and RHEL 5, RHEL 6 : # yum install \
gcc-c++ compat-gcc-34-c++ automake autoconf libtool libX11-devel \
libXext-devel libXau-devel libXmu-devel xorg-x11-proto-devel

cd ns-allinone-2.35/ && ./install

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
make file error ns2 raji27 Linux - Wireless Networking 6 02-24-2013 09:51 AM
ns2.34:problem in running make. chinu Linux - Software 3 05-02-2012 08:18 AM
Bash 3.2 make failes Bliepo Linux From Scratch 5 08-19-2009 04:56 PM
Failes with make modules when noting is changed linuxtesting2 Red Hat 1 02-15-2008 08:11 PM
problem with re-make in ns2.26 newbie06 Red Hat 1 12-18-2006 06:42 PM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration