LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-02-2008, 08:29 AM   #1
m.alnaas
LQ Newbie
 
Registered: Apr 2008
Posts: 2

Rep: Reputation: 0
ns-allinone-2.31 question


Hi everyone;
I'm new in this website, and i need your help.
Q which is the best version of Linux that can work properly with ns-allinone-2.31?

I have tried with Fedora 9beta and Fedora8, both of them didn't work with it.

So many errors I have got, there's something I don't know about which is gcc. One of my friend told me that your linux should include it or it won't work properly.

Plz, advice me, because this is my first time working on Linux and I need it as much as you can imagien.
Thanks
 
Old 04-02-2008, 10:59 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Please see this thread for things required to install on fc8:
http://www.linuxquestions.org/questi...ll-ns2-421797/
And you can use the LQ search using keyword 'ns2' for more information, and remember to
look at 'Similar Threads' at bottom of LQ-pages.
What I know is that ns-allinone-2.31 compiles without problems on slackware 12 and
PCLinuxOS2007.
 
Old 04-24-2008, 12:51 AM   #3
linderque
LQ Newbie
 
Registered: Apr 2008
Posts: 2

Rep: Reputation: 0
Hello...
I tried to install ns-2.31 in ubuntu 7.10
everything seems to fine. It says that "Ns-allinone package has been installed successfully"
And i also did as what in the installation step from the ns2 site (setting up the environment variables)
But when i tried to run an example from ns2,(the tcl script)eventhough i am in the correct directory....it gave me this error,

>>> maslinda@maslinda:~/ns-allinone-2.31/ns-2.31/tcl/ex$ ns wireless.tcl
>>> wireless.tcl does not exist, try again


Can someone help me to figure out this problem?

-linderque-
 
Old 04-25-2008, 05:43 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Try this:
http://isi.edu/nsnam/ns/tutorial/nsscript5.html
Quote: If you want to download a copy of simple-wireless.tcl click here

Google is your friend: I just googled: wireless.tcl

Last edited by knudfl; 04-25-2008 at 05:48 AM. Reason: 1 line added
 
Old 07-21-2008, 02:35 AM   #5
inamullah
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
Hi everyone,
I have installed NS2 (3.31 version). Everything was successful. But When I was told to modify env variables, all but LD_LIBRAY_PATH are properly shown when I type env command. (I provided provided the variables in /etc/profile). I don't know why particularly LD_LIBRAY_PATH is not shown.
I am using Linux enterprise edition on a Sun machine.
 
Old 07-22-2008, 03:17 PM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 5 inamullah :
A permanent library path is usually added by a
line in /etc/ld.so.conf

I would try that.

( For the "bin" path I would create 2 scripts in
/etc/profile.d/
(like the scripts for java in Slackware)
1) "ns2.csh" and 2) "ns2.sh" )

Regards

Last edited by knudfl; 07-22-2008 at 03:18 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions about tclcl when install ns-allinone-2.26 ckflynn Linux - Software 1 04-26-2007 09:35 PM
Questions about tclcl when install ns-allinone-2.26 ckflynn Programming 1 04-26-2007 04:19 AM
I am getting problem in nam-1.11 while installing ns-allinone-2.29 on fedora core 5 deodutta Linux - General 0 02-03-2007 11:38 PM
Problem with Vocal allinone configuration vishesh4383 Linux - Software 1 11-17-2006 06:00 AM
Environment variables for ns-allinone under FC2, please help. Oxy Linux - Software 0 08-16-2004 11:38 PM


All times are GMT -5. The time now is 10:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration