LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-14-2005, 11:07 AM   #1
chstani
Member
 
Registered: Aug 2005
Posts: 42

Rep: Reputation: 15
nr.2 setxkbmap ??


hi,
my second problem, I have to write in latvian, so there are some letters that have (-) and (,) under and above. how i can change my keyboard from default EN-keyboard to LV-keyboard or keyboard layout or something alse so I can be able to write in that larguage.
I was Windows user and there was small keyboard language changer just near clock. Just one click on it and all were fine. How about this in linux?

I read some information about this all and found that I can run "setxkbmap lv" and then I can write in that Latvian by using Alt+letter for some non-latin letters. but it is NOT working!

Any help on changing keyboard language (or layout) for European NON-english languages!!
Thank you!

PS: I found some file on the internet that I run once and thet run "setxkbmap lv" and then I CAN write in Latvian. but the problem is thet every time I turn on my laptop I have to run "setxkbmap lv" as root to be able to write in that Latvian language.
 
Old 09-15-2005, 11:55 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
since the keyboard is controlled by the X server
this might be as simple as
in you X config file
under
Section "InputDevice"

put
Option "XkbLayout" "lv"

then X should start with lv keyboard


Quote:
I found some file on the internet that I run once
we can't know what this is
unless you explain more

there shouldn't be any reason i know of that you should have to run setxkbmap as root
unless you are running the X server as root

if the above configuration change doesn't help just put the commands exactly as you use them in some x startup file like /etc/X11/xinit/xinitrc
or
cp /etc/X11/xinit/xinitrc ~/.xinitrc
and change it from there
then the command will be run when you start x
if the script you are using needs to be run as root try just changing it's permissions so it is executable by user
 
Old 09-16-2005, 03:20 PM   #3
chstani
Member
 
Registered: Aug 2005
Posts: 42

Original Poster
Rep: Reputation: 15
I`m sorry, I don`t really understand:
Quote:
if the above configuration change doesn't help just put the commands exactly as you use them in some x startup file like /etc/X11/xinit/xinitrc
or
cp /etc/X11/xinit/xinitrc ~/.xinitrc
and change it from there
then the command will be run when you start x
if the script you are using needs to be run as root try just changing it's permissions so it is executable by user
I`M NEWBIE IN LINUX!!

Quote:
in you X config file
under
Section "InputDevice"

put
Option "XkbLayout" "lv"

then X should start with lv keyboard
I already read about this, but it doesn`t help for me.


And about that file. It is just some small helper, so that when i`m writing in Latvian, insted of pressing Alt+letter for some non-latin latters, I can press ' and then the letter. It is just to be more comfortable, nothing special, probably in Finland, Poland, Danmark and somewhere alse people using something simular for non-latin latters.
A lot of people here in Latvia think that [' and then letter] is much comfortable than [Alt+letter] (for non-latin letters). but i don`t care!
So, that file is .tar, i uncompres it, so there are some files, i double click on file "start", then i run "setxkbmap lv" in terminal and all should work fine for all the time until i run file "finish"!!
Maybe it is HARD to understand what i tryed to explain here. I`m sorry, english is not my language!
But don`t care about that file, i just tryed it, so maybe it wille help me, but it didn`t help. That file has nothing to do with this MY BIG PROBLEM. I need to write in Latvian, i need to write in some other languages and to do it as USER, so non-root.

so how i can change my keyboard map (or keyboard layout or keyboard language)
And can it be done as easy as it is in Windows, just clicking on small keyboard language changer near clock.
thank you!
 
Old 09-16-2005, 09:40 PM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
ok i think i understand
try this command
it will allow you to switch back and forth between english (or other language if adjusted) and latvian by pushing both shifts at the same time
setxkbmap -option grp:switch,grp:shift_toggle,grp_led:scroll us,lv
 
Old 09-17-2005, 03:14 AM   #5
chstani
Member
 
Registered: Aug 2005
Posts: 42

Original Poster
Rep: Reputation: 15
i typed it as root and it worked. but after i logout and then login it doesn`t work any more!!
maybe i need somehow save thouse settings ?!
 
Old 09-17-2005, 11:54 PM   #6
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
that is what i was trying to say before
i can't know your setup enough to give exact details
but will try
if you start from a graphical login
edit the file in your home directory called .xsession
and at the bottom of that file insert the command
setxkbmap -option grp:switch,grp:shift_toggle,grp_led:scroll us,lv
see if it works then when you login next time
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dead keys, setxkbmap and upside down exclamation marks! Komakino Linux - Software 2 08-03-2010 12:16 PM
XFCE & setxkbmap spes_hominis Slackware 3 07-12-2005 04:55 PM
setxkbmap no accents bobbens Linux - Software 0 03-17-2005 01:17 PM


All times are GMT -5. The time now is 08:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration