LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2005, 05:41 PM   #1
rwillard
Member
 
Registered: Feb 2005
Location: Lethbridge, AB, Canada
Distribution: Fedora 3
Posts: 33

Rep: Reputation: 15
Notebook won't suspend


Hello all...

I'm running a Dell notebook, and if i try to suspend, I get the following:

Code:
[root@localhost ~]# /usr/bin/apm -s
No APM support in kernel
How do I rectify this? Please note I am a relative newb, so a little more information than "recompile your kernel" would be appreciated.

Thanks!
Rob
 
Old 05-18-2005, 09:11 PM   #2
corfe
Member
 
Registered: Dec 2004
Location: Washington State, USA
Distribution: Debian Sid
Posts: 128

Rep: Reputation: 16
Well, if you're using a stock default kernel with your distro, they've probably compiled most of the kernel features as loadable modules. I'd try modprobe acpi or modprobe apm (acpi is apm's more advanced twin, as far as I know, and the two are both probably supported, but can't be enabled simultaneously). You can use rmmod to remove a module from memory if you don't think it's for you.

If loading that module seems to fix your problem, you'll have to check your distribution for instructions on how to make it load by default on bootup. In debian, you add the module name to "/etc/modules".

I hope that works for you - good luck!
 
Old 05-19-2005, 11:32 AM   #3
rwillard
Member
 
Registered: Feb 2005
Location: Lethbridge, AB, Canada
Distribution: Fedora 3
Posts: 33

Original Poster
Rep: Reputation: 15
Thanks corfe for the reply.

I tried the rmmod to get rid of acpi, and it didn't work. I did however do some additional searching based on what you had posted. Basically I found that acpi is the culprit, and by removing it apm should work.

I added 'acpi=off' to my /etc/grub.conf file and rebooted. I could now suspend without problem, however a couple of issues have arrisen from this:

1) my notebook makes an odd sound with the acpi off . It's tough to explain, but almost has the sound of an overloaded capacitor for you electronics guys. When I put acpi back on, the sound goes away. (no, this isn't coming from my speakers)

2) when I resume from a suspend, my USB is gone. I'm not sure how to reset it. I found a similar thread at this link, however the explanation given isn't really that clear to a newb like me.

Thanks!
Rob
 
Old 05-19-2005, 01:10 PM   #4
corfe
Member
 
Registered: Dec 2004
Location: Washington State, USA
Distribution: Debian Sid
Posts: 128

Rep: Reputation: 16
That's really odd. As for #1, if I were you, I'd try searching on google or linuxquestions for your specific model of laptop (in quotes), and linux. Try adding ACPI too. See if anyone else talks about this problem, you might find someone who's already found a solution.

As a general solution, the first thing that comes to mind is make sure you're using the newest kernel you can. I believe ACPI is an area that is pretty heavily worked on right now, so if you're using a relatively old kernel version, that could explain it. Try to get 2.6.x, 2.6.11 is most preferable.

As for #2, what they're saying is that we need to tell linux to, when suspending your computer, unload the module for your USB (that will effectively shutdown USB support), and when resuming from suspend, load that module (that will effectively enable USB properly).

This is probably an area you should go to your specific distribution for, as I don't know of a standard way to do this. Basically you want to:

figure out the module names that covers all your USB support, and figure out how to uninitialize and reinitialize it using rmmod and modprobe. This might be something like :

rmmod usbmouse
rmmod uhci

modprobe uhci
modprobe usbmouse

Once you have this down, figure out where you can tell Fedora to run a script before suspending, and figure out where to tell Fedora to run a script when resuming from suspend, and put your commands to unload and load the modules in those appropriate scripts.

I hope this makes more sense - tell me if that worked, or if it at least makes sense to you!
 
Old 05-19-2005, 03:02 PM   #5
csfalcon
Member
 
Registered: Jun 2004
Location: MD
Distribution: Fedora Core
Posts: 269

Rep: Reputation: 31
which dell laptop do you have? I know mine only supports ACPI.

Try enable ACPI and try this command:

"echo -n mem > /sys/power/state"
 
Old 05-19-2005, 06:39 PM   #6
rwillard
Member
 
Registered: Feb 2005
Location: Lethbridge, AB, Canada
Distribution: Fedora 3
Posts: 33

Original Poster
Rep: Reputation: 15
Thanks for that csfalcon... the "echo -n mem > /sys/power/state" worked.

I am still having a problem with the USB and now eth0 not coming back up on resume. Seeing as you are running the same core (FC3) on the same(ish) notebook, how have you overcome this?

Rob
 
Old 05-20-2005, 08:30 PM   #7
csfalcon
Member
 
Registered: Jun 2004
Location: MD
Distribution: Fedora Core
Posts: 269

Rep: Reputation: 31
I didn't run into any problems with USB or network problems, but here are the steps I took to setup my laptop:

http://www.csfalcon.com/index.jsp?to...end%20to%20RAM
 
Old 05-24-2005, 12:04 PM   #8
rwillard
Member
 
Registered: Feb 2005
Location: Lethbridge, AB, Canada
Distribution: Fedora 3
Posts: 33

Original Poster
Rep: Reputation: 15
Talking RESOLVED

Finally have it figured out!

Thanks to all that have helped with this problem. Here is the synopsis of how I resolved this (part this thread, part Google...)

Firstly, following csfalcon's instructions from his site I got the suspend working from the function key:

Created sleep.conf in /etc/acpi/events/ with the following:

Code:
# This is a sleep configuration

event=button/sleep.*
action=/etc/acpi/actions/sleep.sh
Then created sleep.sh in /etc/acpi/actions/ with the following:

Code:
#!/bin/sh
echo -n mem > /sys/power/state
and made it executable by entering:

Code:
chmod +x sleep.sh
and restarted my acpi with the following:

Code:
/etc/init.d/acpid restart

Then to fix the USB mouse problem, I created a bash script that I found here and called it wakeupfix with the following in it:

Code:
#!/bin/sh

# restart usb
sudo /sbin/rmmod uhci_hcd
sudo /sbin/rmmod ehci_hcd
sudo /sbin/modprobe uhci_hcd
sudo /sbin/modprobe ehci_hcd

# reset clock
sudo rdate -s ntp0.cornell.edu
This fixed the USB Mouse problem, and also a potential error where the time is wrong when you come out of suspend.

Again... thanks to all that helped.

Rob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to suspend a process? Thinking Programming 9 09-19-2005 02:34 AM
Time changes when notebook goes into suspend brokenflea Slackware 3 05-28-2005 09:24 PM
S3 Suspend xconspirisist Linux - Software 1 11-15-2004 04:47 AM
PC notebook or Mac Notebook? thebover Linux - General 8 10-08-2004 04:02 AM
suspend that won't go away ronald_fancher Linux - General 3 07-14-2002 10:20 PM


All times are GMT -5. The time now is 08:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration