LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-11-2014, 01:48 AM   #1
pon
Member
 
Registered: Aug 2014
Posts: 77

Rep: Reputation: Disabled
Unhappy Not Showing any packet transmission in nam upon executing wireless tcl scripts


Hi all,"SAVE ME" or "TELL ME how to completely uninstall ns-allinone-2xx package" from my ubuntu 12.04"

i have admitted myself in a problem in ns2,
upon executing wireless tcl scripts nam is not showing any packet transmission.

at first

I have encounter problem when I try to install ns2.33 in ubuntu 12.04, when already i have installed ns-2.35 and ns-2.33 in it.
upon completing my installation procedure,when i type ns in terminal i got error like as follows in terminal

Code:
application-specific initialization failed: Can't find a usable init.tcl in the following directories:
/home/chase/ns-allinone-2.34/tcl8.4.18/library:/usr/lib /home/chase/ns-allinone-2.34/lib/tcl8.4 /home/chase/ns-allinone-2.34/tcl8.4.18/library:/usr/lib /home/chase/ns-allinone-2.34/tcl8.4.18/library:/usr/tcl8.4 /usr/local/lib/tcl8.4 /usr/lib/tcl8.4 /usr/local/library /usr/library /usr/tcl8.4.18/library /tcl8.4.18/library /home/chase/ns-allinone-2.34/lib/tcl8.4
This probably means that Tcl wasn't installed properly.
% .
i was not able to execute any of .tcl script. so i ran following commands.(referred from http://www.linuxquestions.org/questi...ly-4175434577/ , see post #2, #4)

1) cd ns-allinone-2.34/tcl8.4.18/ && ln -s lib/ library
2). Go to location root-usr-local-bin by giving following command in terminal
cd /usr/local/bin
3). There you would find the ns file. We just need to remove it by giving following command
rm ns
4) Reinstall ns-allinone-2.34

now when i type ns
i am getting %,my previous error was fixed.

but upon executing any of my wireless tcl script it it not showing any packet transmission in nam ,

in terminal on executing any of my wireless tcl script i am getting following similar message in terminal, but wired network tcl script is working and showing packet transmission.

Code:
chase@chase-desktop:~/mylab$ ns aodv.tcl
num_nodes is set 12
warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl
mac/chanel.cc: INITIALIZE THE LIST xListHead
mac/channel.cc: sendUp - Calc highestAntennaZ_ and distCST_
mac/channel.cc: highestAntennaZ_ = 1.5,  distCST_ = 89.8
SORTING LISTS ...DONE!

Last edited by pon; 09-12-2014 at 09:50 AM. Reason: looking for solution
 
  


Reply

Tags
installing, ns2, tcl-ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set the color to the packet transmission in wireless routing in ns2 pon Linux - Newbie 0 08-31-2014 07:45 PM
Urgent Please help me in . Nam is not showing the packet flow??? keerthygopala Linux - Newbie 3 06-17-2014 02:31 PM
ns-2.34 problem executing 'nam' on ubuntu 9.10 ElijahJ Linux - Software 12 06-02-2014 08:32 AM
Multiple interface queue types in wireless tcl scripts sandy123 Linux - Newbie 0 03-05-2014 12:44 PM
[SOLVED] error while executing nam in ns2.34 on ubuntu 10.04 Aska123 Linux - Software 2 04-12-2013 07:04 AM


All times are GMT -5. The time now is 11:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration