LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-09-2008, 04:59 AM   #1
ypy13
LQ Newbie
 
Registered: Jul 2008
Posts: 8

Rep: Reputation: 0
Unhappy not in executable format: File format not recognized


Hi,I've searched the similar threads,but my problems still exist.I need help,thank you.Following is my problem:

administrator@administrator-laptop:~$ gdb /home/administrator/codes/test.cGNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
"/home/administrator/codes/test.c": not in executable format: File format not recognized
(gdb)

how can i solve this?
 
Old 07-09-2008, 05:03 AM   #2
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You problem is exactly what the error says - test.c is not executable - it's the source code. You need to compile it first. Something like "gcc test.c"
 
Old 07-09-2008, 05:13 AM   #3
ypy13
LQ Newbie
 
Registered: Jul 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by billymayday View Post
You problem is exactly what the error says - test.c is not executable - it's the source code. You need to compile it first. Something like "gcc test.c"
thanks for your answer,but i did have compile it,and i still have the problem.As follows:

administrator@administrator-laptop:~/codes$ gcc -o histogram histogram.c
administrator@administrator-laptop:~/codes$ ./histogram
test hello^
||||
|||||
administrator@administrator-laptop:~/codes$ gdb histogram
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
(gdb) file histogram.c
"/home/administrator/codes/histogram.c": not in executable format: File format not recognized

the program have aleady run,but when i use gdb,it has problems...
 
Old 07-09-2008, 05:18 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You are adding .c to the program name which is the source and not the program file. Run "gdb histogram" instead.
 
Old 07-09-2008, 05:30 AM   #5
ypy13
LQ Newbie
 
Registered: Jul 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
You are adding .c to the program name which is the source and not the program file. Run "gdb histogram" instead.
i run "gdb histogram", when i want to add a breakpoint to my programm, it doesn't work. As follow:

(gdb) break histogram.c:6
No source file named histogram.c.
Make breakpoint pending on future shared library load? (y or [n])

"No source file named histogram.c" why? the file is exactly there.
 
Old 07-09-2008, 04:44 PM   #6
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Try adding a -d option with the source file's path (even if it's ./)
 
Old 07-09-2008, 11:19 PM   #7
ypy13
LQ Newbie
 
Registered: Jul 2008
Posts: 8

Original Poster
Rep: Reputation: 0
doesn't work...
 
Old 07-09-2008, 11:24 PM   #8
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Does histogram work if you run it on its own?

edit - sorry - just re-read earlier post where you ran it

Last edited by billymayday; 07-09-2008 at 11:26 PM.
 
Old 07-09-2008, 11:28 PM   #9
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
File is the wrong command:
Code:
(gbd) help file
Use FILE as program to be debugged.
You are not trying to debug histogram.c

Code:
gcc -g -o histogram histogram.c   # use -g to add symbols
gbd histogram
b main
r
list
 
Old 07-09-2008, 11:33 PM   #10
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Sorry - your problem is the "file histogram.c" entry. This is trying to load histogram.c as the executable. You don't need the file command since you loaded the executable at gdb histogram
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gdb "not in executable format: File format not recognized" tcma Programming 9 07-18-2007 06:02 AM
Exec format error. binary file not executable. kaz2100 Linux - General 2 08-19-2006 05:26 PM
File Format not recognized eachow Linux - Hardware 2 07-10-2006 03:52 PM
executable format... shifter Programming 9 05-15-2006 12:05 PM
executable file format arunka Programming 2 03-15-2006 05:24 AM


All times are GMT -5. The time now is 08:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration