LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-17-2011, 07:11 PM   #1
Barclay
Member
 
Registered: Aug 2011
Location: Texas
Distribution: Slackware
Posts: 33

Rep: Reputation: Disabled
Not Getting It


I've tried a couple different distros now, and taken many suggestions from folks here at LQ and other sites and I still can't get my system to run linux. The problems I'm having are with my video and sound cards or perhaps the drivers that run them. I'm running off the Xubuntu disc right now and I noticed there was a hardware driver icon in the corner. It detected my nVidia card and suggested a 3D accel. driver so I enabled it then Installed the OS to my hard drive and rebooted. Still getting the black screen. Did I do this wrong (obviously)? How do I do it right? If you've made it this far, I appreciate it.
 
Old 08-17-2011, 07:27 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
If you enable it in the live environment (when you run Xubuntu from the CD) that doesn't mean that you enable it automatically in the installed system. But to enable it in the installed system isn't that hard.
Start in the recover mode (you should be able to choose that in your boot-loader), then launch the command
Code:
sudo jockey-text -e xorg:nvidia-current
This is assuming that your NVidia card is from the 6xxx-series or newer. Then reboot and the driver should be enabled.
 
Old 08-17-2011, 07:57 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,830

Rep: Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409
if you posted your hardware specifications
and the distros you tried

that would help
right now ????? there is no way we could .


Is this a single boot ( only a linux distro )
If so WHAT distro?
Or a dual boot with windows
If so what one XP,Vista,7 ?

is this a laptop?
or a desktop?
and so on with the 20 questions..............

Last edited by John VV; 08-17-2011 at 07:59 PM.
 
Old 08-17-2011, 11:02 PM   #4
Barclay
Member
 
Registered: Aug 2011
Location: Texas
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: Disabled
After trying what Tobi suggested it shows nvidia_current enabled but Not In Use, and still no screen.

Right now I'm using Xubuntu 11 but I've also had trouble with Kubuntu, Slackware, and Gentoo/Funtoo.
AMD64 X2
80GB Sata Mextor brand
nVidia GeForce 8500GT
And this is a linux-only machine.
Thanks John

Also I should point out when I first tried booting off the liveCD I got a white screen and I was told to select nomodeset in the boot options before booting. This fixed the problem for booting off the CD but booting from the installation gives me a black screen. Can I manually change the boot settings for "nomodeset" from within the recovery kernel on the harddrive? Or maybe there's a way to fix it from the liveCD?

Last edited by Barclay; 08-17-2011 at 11:04 PM.
 
Old 08-17-2011, 11:28 PM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Quote:
Originally Posted by Barclay View Post
After trying what Tobi suggested it shows nvidia_current enabled but Not In Use, and still no screen.
How do you see this when you don't get the screen working? Have you launched the command in the live environment or when running the installed Xubuntu in recovery mode? Did you reboot after that?
What type is your monitor? If it is a LCD screen, which is its native resolution?
If the driver is enabled but not in use something is preventing it from running, so a look at the contents of /var/log/Xorg.0.log from the installed system would be very helpful, please post that here between code-tags (the #-symbol on top of the forums text-editor).
 
Old 08-17-2011, 11:29 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,830

Rep: Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409
a slightly older machine but not old

how much ram . For a 64 bit cpu 4+ gig is no issue

nVidia GeForce 8500GT is well supported ,most are using the "nouveau" driver as default ( nomodeset should not be needed )

if you have 2+ gig of ram 4 gig is better.Try OpenSUSE 11.4 KDE
or OpenSUSE 11.3 if you want Gnome 2 ( gnome 3 is not ready for "prime time" yet )
or
Ubuntu 11.04

Slackware, and Gentoo are not really "new to linux" distros

Ubuntu is normally better .

on that machine any 64 bit os should install just fine


so you are saying that no install has worked ??? odd

download and burn Gparted" live cd
wipe the 80 gig drive , leave it unformated

now most "live" cd's or live dvd's do NOT install well
so
lets go with Ubuntu 11.04
burn the full install dvd
http://www.ubuntu.com/download/ubuntu/download
for ubuntu use the 32 bit version
or
OpenSUSE
http://www.opensuse.org/en/
http://software.opensuse.org/114/en
use the 64 bit
and try the install
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 08:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration