LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-08-2002, 02:56 PM   #1
MaxC
LQ Newbie
 
Registered: Jul 2002
Posts: 7

Rep: Reputation: 0
Not enough RAM to install Red Hat


I'm trying to install Red Hat on a Compaq Proliant 2500 server with 512 MB of RAM. When Linux cranks up, I try to do a default install and instantly get the message:

"You do not have enough RAM to install Red Hat Linux on this machine"

I checked the HCL and this server was not listed, though many other Proliants were. I'm guessing that, more than likely, that is the problem.

Any ideas?

Thanks,
Max.

Last edited by MaxC; 07-08-2002 at 03:04 PM.
 
Old 07-08-2002, 03:07 PM   #2
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
What version of RH hat did you say?

Watch the boot messages, and see if it is seeing all your ram? Your looking for somthing like this:

Memory: 255152k/262144k available (1536k kernel code, 6604k reserved, 426k data, 228k init
, 0k highmem)


The fact that it's not on RH's approved list is becuase
they have payed a "kickback" to RH to get approved.

Last edited by pickledbeans; 07-08-2002 at 03:10 PM.
 
Old 07-08-2002, 03:34 PM   #3
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
put the install CD in and at the prompt
boot:
enter
mem=512M
see if it cures the problem
 
Old 07-08-2002, 03:46 PM   #4
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Quote:
Originally posted by neo77777
put the install CD in and at the prompt
boot:
enter
mem=512M
see if it cures the problem
I thought that only applied to the older kernels?
MY stock install see all 256mb of my ram?
 
Old 07-08-2002, 03:54 PM   #5
MaxC
LQ Newbie
 
Registered: Jul 2002
Posts: 7

Original Poster
Rep: Reputation: 0
Oops. It's version 7.2 I thought I had typed that, but I guess I didn't.

I tried to look for that "Memory" line during boot up, but it goes by so fast I can't see it.

I tried the line "linux mem=512M" It seemes to have gotten me past the initial problem. I'll keep you posted.

Thanks everyone.

Max.
 
Old 07-09-2002, 08:52 AM   #6
MaxC
LQ Newbie
 
Registered: Jul 2002
Posts: 7

Original Poster
Rep: Reputation: 0
OK... specifying the amount of memory did the trick. Red Hat Linux 7.2 is now installed. Thanks a lot for the help.

Now, I just need to figure out why the thing is running so slow. It said it needed 1.3 GB to install all of the options I selected, and I have a 4.3 GB hard drive... so I have plenty of room left... but if I double click on System Options, it takes a full minute before I actually see the System Option window. I'm running a Compaq Proliant 2500 server with dual 200 Mhz processors.

Maybe it's a swap file size? Is this server's processors too slow? Man I have a lot to learn!

Mark.
 
Old 07-09-2002, 09:20 AM   #7
Config
Member
 
Registered: Jan 2001
Location: Switzerland
Distribution: Gentoo
Posts: 376

Rep: Reputation: 30
Well, this heavily depends on what you have running - like KDE and X and so on. They use a lot of resources and with 2*200mhz, I wouldn't want to run KDE. I don't think it's swap - with 512mb Ram, there should be no swap. I have 256Ram and KDE3 and I don't hear all the swapping
And btw... I heard many times RH 7.2 has a buggy gcc so if you're on a server, think about updating
 
Old 07-09-2002, 10:29 AM   #8
MaxC
LQ Newbie
 
Registered: Jul 2002
Posts: 7

Original Poster
Rep: Reputation: 0
Well, the default install selected gnome. I started to select KDE, but I figured since this was my first experience with 7.2, I'd just go with the defaults.

You hit the nail on the head, though. I'm hearing tons of swapping (or at least I'm guessing that's what's happening) before anything happens on the screen. Maybe I'll look into the programs that are loading in the background and get rid of the ones I won't be using.

Thanks for the info.

Max.

-------------------------------------------------------------------------

Update... I think I found the problem... GRUB says that it only sees 16 MB of memory available. So, I guess I'm still in the same boat as when I was installing the OS in the first place. That would explain all of the disk swapping I'm hearing.

Is Red Hat just not going to run right on this machine?

Last edited by MaxC; 07-09-2002 at 10:58 AM.
 
Old 07-09-2002, 10:01 PM   #9
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
You'll need to edit either the /boot/grub/menu.lst or the /boot/grub/grub.conf file. Just edit whichever one you have. Edit the kernel line and add mem=512M to it. It will look something like this.

Example:

kernel (hd0,5)/boot/vmlinuz root=/dev/hda6 ro mem=512M

Then reboot.
 
Old 07-09-2002, 10:48 PM   #10
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Better yet don't use GRUB use lilo, or check the RH update site and see if they is an update for GRUB ...or Use Lilo.
 
Old 07-10-2002, 04:34 PM   #11
MaxC
LQ Newbie
 
Registered: Jul 2002
Posts: 7

Original Poster
Rep: Reputation: 0
Well, I tried LILO and got the same problem... actually, LILO was only seeing 4 MG of RAM... so the problem was MUCH worse.

On the plus side, I put in mem=512M at the end of the kernel line and all is now smooth. It's running surprisingly fast. I may even decide to try KDE and see what it's like. Are there any advantages to KDE over Gnome?

Thanks for the input everyone! I hope to being GIVING the advice on this board soon rather than just asking for it In the mean time, you guys ROCK!!!

-Max.
 
Old 07-10-2002, 04:45 PM   #12
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Quote:
Originally posted by MaxC
Well, I tried LILO and got the same problem... actually, LILO was only seeing 4 MG of RAM... so the problem was MUCH worse.

-Max.
This really is a stumper,
I would still suggest posting to a Redhat specfic
mailing list, this just shouldn't be happening?


Like a said I got 256mb of ram. here's my lilo.conf:

slacker:davej % cat /etc/lilo.conf
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
#compact # faster, but won't work on all systems.
delay = 300
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda1
label = slack
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
 
Old 07-10-2002, 04:58 PM   #13
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
try this trick with mem=512M again but now edit your /etc/lilo.conf as root
after
root=/dev/hdX
put the following
append="mem=512M"
save the file, and rerun lilo
/sbin/lilo
This is very strange problem, as it was stated by pickled the newer kernel should see well past the 4 M.
 
Old 07-10-2002, 08:02 PM   #14
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Quote:
Originally posted by MaxC
Well, I tried LILO and got the same problem... actually, LILO was only seeing 4 MG of RAM... so the problem was MUCH worse.
If you want to use lilo, just do as neo77777says. If there is an append line already there, then add mem=512M to the append line. Like this:

append="hdc=ide-scsi mem=512M"

Quote:
On the plus side, I put in mem=512M at the end of the kernel line and all is now smooth. It's running surprisingly fast. I may even decide to try KDE and see what it's like. Are there any advantages to KDE over Gnome?
That's good to hear!

Quote:
Thanks for the input everyone! I hope to being GIVING the advice on this board soon rather than just asking for it In the mean time, you guys ROCK!!!
You're welcome.
 
Old 07-10-2002, 08:07 PM   #15
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
One last guestion for (now) is their any thing specail arbout you ram?

Ok two more last things:

man free

And post the output from free so that we can check and make sure it really is seeing all you ram

Last edited by pickledbeans; 07-10-2002 at 08:10 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat 9 (not enough RAM) Kelso Linux - Newbie 1 12-08-2003 09:14 PM
Red Hat 9 Using Alot of RAM jsoukup Linux - General 6 12-06-2003 12:42 PM
Red Hat 9.0 and RAM wacinski Linux - Software 3 07-23-2003 11:24 PM
Red Hat 7.3 RAM Issue hitaz Linux - General 1 07-10-2003 08:24 AM
Not enough RAM to install Red Hat? ScreeminChikin Linux - General 3 12-17-2002 05:47 PM


All times are GMT -5. The time now is 02:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration