LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Not Enough Memory To Load Specified Image... (http://www.linuxquestions.org/questions/linux-newbie-8/not-enough-memory-to-load-specified-image-898197/)

tb75252 08-18-2011 11:54 PM

Not Enough Memory To Load Specified Image...
 
I downloaded Slackware 13.37 on a DVD (32-bit version). The MD5 check is fine.

I am trying to install on an 11-year-old computer. It has a Pentium III 1100 MHz, 1.5 GB of memory, the motherboard is a Tyan Trinity 400 (S1854).

Upon booting up with the install DVD, it reaches the point where it says "Loading initrd.img" and then I get the following error message: Not enough memory to load specified image.

I have tried using two kernels: hugesmp.s and huge.s. Same error message!

Am I out of luck? Is my computer too old for Slackware? (No problems running Ubuntu 11.04 or Windows 7...)

gammahermit 08-19-2011 12:44 AM

If I remember right the slackware install disk has a minimal kernel called bare.i I think. You could try that one. There also may be some other boot options that could make it work. If you can't get it to work and you really want slackware on it. You could try getting an old version. That's what I used to do when tinkering with old computers.

And were you really able to get win7 on there and it was actually usable? It doesn't seem like it would be able to handle windows 7.

tb75252 08-19-2011 12:52 AM

Quote:

Originally Posted by gammahermit (Post 4447371)
If I remember right the slackware install disk has a minimal kernel called bare.i I think. You could try that one. There also may be some other boot options that could make it work. If you can't get it to work and you really want slackware on it. You could try getting an old version. That's what I used to do when tinkering with old computers.

And were you really able to get win7 on there and it was actually usable? It doesn't seem like it would be able to handle windows 7.

Thanks for the reply.
bare.i is not a recognized kernel by the install routine.

Yes, I was actually able to install Windows 7 Home Premium on my old desktop! Of course Aero was turned off and things ran a little slow but it wasn't actually that bad.

gammahermit 08-20-2011 03:44 PM

When you boot up to the install cd I think if you press F2 it'll show you all the options and kernels it has. And you only need to try the .i kernels. Those are one that support IDE connected HD. The .s ones support scsi drives.

TobiSGD 08-20-2011 04:14 PM

Slackware 13.37 doesn't have a bare.i kernel. And it should install and run fine on such a machine. Have you checked the DVD, may be with trying to but from it on a different machine?

markush 08-20-2011 04:27 PM

Quote:

Originally Posted by tb75252 (Post 4447348)
I am trying to install on an 11-year-old computer. It has a Pentium III 1100 MHz, 1.5 GB of memory, the motherboard is a Tyan Trinity 400 (S1854).

Just a question, is it possible that your computer doesn't support as much RAM?

Some weeks ago I managed to install Slackware on an old Celeron-Machine, I inserted 3x256MB and after the installation the computer did not work (no network). I reduced the RAM to 2x256MB and the computer worked again. In my experience these old machines often are limited even to 3x128MB of RAM. Sometimes if they have to much of RAM they seem to work but after some time there are things going wrong. Long story short, maybe your mainboard cannot handle 1.5GB of RAM, try it with less RAM....

Well, referring to this: http://www.tyan.com/archive/products...rinity400.html it supports a maximum of 768MB.

Markus

tb75252 08-27-2011 12:53 AM

I finally figured out what the problem was...

My eleven-year old desktop uses Award Modular BIOS v. 4.51PG. Under Chipset Features Setup, there is an entry called Memory Hole. It was enabled with a value of "15M - 16M". I disabled that and now the setup DVD loads just fine.

I am not much of an expert and don't really understand the advantage of having Memory Hole enabled, but the desktop seems to be working just fine with this setting disabled!


All times are GMT -5. The time now is 10:58 AM.