LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2013, 12:15 PM   #1
sniper8752
Member
 
Registered: Oct 2012
Posts: 354

Rep: Reputation: Disabled
not authorized to access external hard drive


I am running Raspberry Pi, and when I plug in my Toshiba external hard drive, and I try to access the contents of it, it gives off an error message saying that i am "Not authorized". I can't mount it.
 
Old 02-08-2013, 12:33 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Is the drive password protected?
Is the user part of disk, plugdev & backup group? Check /etc/group
 
Old 02-08-2013, 01:10 PM   #3
sniper8752
Member
 
Registered: Oct 2012
Posts: 354

Original Poster
Rep: Reputation: Disabled
no, it's not.
not sure what you mean - i ran a cat, and for the specific user logged in: 1003 is the last value.
 
Old 02-08-2013, 01:43 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
when I plug in my Toshiba external hard drive
Do you have hdd password set in bios of Toshiba?

Quote:
cat /etc/group
The user name should be next to those entries

Last edited by EDDY1; 02-08-2013 at 01:46 PM.
 
Old 02-08-2013, 01:47 PM   #5
sniper8752
Member
 
Registered: Oct 2012
Posts: 354

Original Poster
Rep: Reputation: Disabled
no, i don't. and the usernames do show up.
 
Old 02-08-2013, 01:53 PM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Use your editor to add
Attached Thumbnails
Click image for larger version

Name:	Screenshot-3.png
Views:	45
Size:	161.4 KB
ID:	11799  
 
Old 02-08-2013, 02:04 PM   #7
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,630

Rep: Reputation: 495Reputation: 495Reputation: 495Reputation: 495Reputation: 495
Quote:
Originally Posted by sniper8752 View Post
I am running Raspberry Pi, and when I plug in my Toshiba external hard drive, and I try to access the contents of it, it gives off an error message saying that i am "Not authorized". I can't mount it.
and just exactly how did you mount the drive and what flavor of linux are you running on your Pi?
 
Old 02-08-2013, 03:38 PM   #8
sniper8752
Member
 
Registered: Oct 2012
Posts: 354

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by EDDY1 View Post
Use your editor to add
what am i adding? that line that is selected?
 
Old 02-08-2013, 04:57 PM   #9
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Originally Posted by sniper8752 View Post
what am i adding? that line that is selected?
You are adding username to the group.
See my example I have 2 users

Also as lleb requested what Distro are you using?

Last edited by EDDY1; 02-08-2013 at 05:00 PM.
 
Old 02-08-2013, 05:49 PM   #10
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Try this if you have the sudo command enabled if not then just become root and then try this
Note replace the sdxx with the device you are mounting it can be sdb or sdb1



Code:
sudo mkdir /home/shares
sudo mkdir /home/shares/public
then
Code:
sudo chown -R root:users /home/shares/public
sudo chmod -R ug=rwx,o=rx /home/shares/public
then
Code:
sudo mount /dev/sdxx /home/shares/public/
Once you have done running these commands open up your file browser and navigate to /home/shares/public and all your files should be there

To find what name your system is giving to you device drive and type in terminal, as root "mount" it will display all the devices pluged in your system
Also if you type fdisk -l also will show you the list of drives and partitions in your system.

Good luck to you!

Last edited by TroN-0074; 02-08-2013 at 08:05 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can`t access my infos in my external hard drive for a while csaba Debian 8 12-23-2009 05:15 AM
Access External Hard Drive Saptech Other *NIX 5 10-30-2008 10:52 AM
external hard drive - access problem bigjohn Linux - Hardware 1 12-24-2006 03:51 AM
External Hard Drive --No Access as USER only ROOT (10.1) 1kyle Mandriva 1 10-31-2004 09:09 AM
Can't access external hard drive. new@this Linux - Hardware 0 12-11-2003 05:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration