LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-13-2009, 01:07 AM   #1
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
Not able to user wget and yum


hi all.......

I am working with fedora 9 ..My system is connected to the internet through proxy server, so i am not able to use the commands like wget and yum is there any way to make these command work having proxy server connected to my system....

i have tried using following command

http_proxy=ip_of_proxy:8080 wget http://www.kernel.org/pub/linux/kern...ch-2.6.29.6.gz

output is

Proxy request sent, awaiting response... 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )

2009-07-14 10:44:27 ERROR 407: Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied.).

It will not ask for password or username...In which file should i specify username and password to proxy....

can anyone please suggest me regarding this issue.........
Thanks in advance ............

Last edited by vinaytp; 07-13-2009 at 02:14 AM.
 
Old 07-13-2009, 06:44 AM   #2
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 774
Blog Entries: 6

Rep: Reputation: 75
/can anyone please suggest me regarding this issue.........

yes..



Code:
http_proxy=http://username:password@ip_of_proxy:8080 wget http://www.kernel.org/pub/linux/kern...ch-2.6.29.6.gz
 
Old 07-13-2009, 06:51 AM   #3
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
I don't know if yum is able to read the http_proxy environment variable, as wget does. Eventually you can try to edit /etc/yum.conf and add the following in the [main] section:
Code:
proxy=http://proxy-address:proxy-port-number
proxy_username=username
proxy_password=password
 
Old 07-14-2009, 02:17 AM   #4
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Original Poster
Rep: Reputation: 55
Quote:
Originally Posted by routers View Post
/can anyone please suggest me regarding this issue.........

yes..



Code:
http_proxy=http://username:password@ip_of_proxy:8080 wget http://www.kernel.org/pub/linux/kern...ch-2.6.29.6.gz
The problem here is my password has an @ symbol and it is conflicting with @ip_of_proxy

How can we solve this issue??
 
Old 07-14-2009, 02:42 AM   #5
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 774
Blog Entries: 6

Rep: Reputation: 75
Code:
The problem here is my password has an @ symbol and it is conflicting with @ip_of_proxy
hehe, i have this problem also before god damn , i have to change the password and i will never use @ in password, because i dont know other way to settle it


btw you can use wget direct but you need to create .wgetrc in your $HOME
so wget can make direct to proxy but still there the problem with your p@ssword which you need to settle first or maybe some others from here know how to solve it , i also need to know
 
Old 07-14-2009, 02:54 AM   #6
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
What if you set the environment variable without user and password and use wget options to provide authentication?
Code:
$ export http_proxy=http://proxy-address:proxy-port-number
$ wget --proxy-user=username --proxy-password=password http://download-url
In any case, I agree with routers: ask the proxy administrators to change your password: you will avoid some problems in the future and a lot of headache.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Print yum download list for wget a_m0d Fedora 6 05-09-2008 09:47 AM
yum, rpm cmd , ftp , wget ..nothing is working :'( rajashree Other *NIX 1 02-02-2007 04:52 AM
Trouble with Yum and Wget DigiCrime Linux - Server 4 01-25-2007 07:41 PM
authenticate a web filter in the terminal? (for use of yum, wget, etc) unknown_mosquito Linux - Security 2 05-02-2006 09:51 PM
Cannot Download via. Wget, YUM, or any kind of downloading on Fedora 4 coold8 Linux - Newbie 4 01-24-2006 11:42 AM


All times are GMT -5. The time now is 04:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration