LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-19-2011, 03:33 AM   #31
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled

aazkan are u back?and Mr.deepak can u help further from this?
 
Old 10-19-2011, 03:38 AM   #32
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
@reply
Code:
# If the mirrorlist= does not work for you, as a fall back you can try the
# remarked out baseurl= line instead.

why don't you try the base url for yum?
 
Old 10-19-2011, 03:44 AM   #33
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
i didnt't get you properly...

if what you meant was to tryin accesing the base url then,that isnt opening either..
 
Old 10-19-2011, 03:46 AM   #34
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
Quote:
Originally Posted by SarahGurung View Post
i didnt't get you properly...

if what you meant was to tryin accesing the base url then,that isnt opening either..

I mean comment the mirror list in the repo file
and uncomment all the baseurls
 
Old 10-19-2011, 03:50 AM   #35
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
by commenting u meant to put # in the front right?or is it different?
 
Old 10-19-2011, 03:51 AM   #36
hen770
Member
 
Registered: Oct 2010
Distribution: Arch
Posts: 136

Rep: Reputation: 7
I have a problematic ISP, and with the same error what i have did is to comment the mirrorlist line and uncomment the baseurl line.
For me it has work.
 
Old 10-19-2011, 03:52 AM   #37
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
yes just put # infront of mirror list and remove # from baseurl

this will work if the baseurl exist..!!!
 
Old 10-19-2011, 03:59 AM   #38
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
but when i copied that base url and typed it in the browser it's giving 404 error so i dont think commenting and uncommenting would help..
 
Old 10-19-2011, 04:46 AM   #39
aazkan
Member
 
Registered: Jan 2008
Posts: 72

Rep: Reputation: 5
hi Sarah,

Am back, sorry, was fixing dinner and putting my daughter to bed.

If you're getting a 404 on the baseurl itself, perhaps you do need to use the http proxy setting.
Just to test this theory, can you try this on that machine


curl -s http://www.google.com/index.html


and let us know what's the output?
 
Old 10-19-2011, 04:54 AM   #40
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
well i tried,it isn't returning any output at all...

you know the same baseurl and mirrolist is their in the slave servers also but there the yum command is working,it is only in the primary nameserver where it is returning that kind of error when using yum..
 
Old 10-19-2011, 04:59 AM   #41
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
Quote:
Originally Posted by SarahGurung View Post
well i tried,it isn't returning any output at all...

you know the same baseurl and mirrolist is their in the slave servers also but there the yum command is working,it is only in the primary nameserver where it is returning that kind of error when using yum..
you said that earlier your boss was using proxy server

So give a check whether that server is stopped?
it might be the issue of proxy server
 
Old 10-19-2011, 05:03 AM   #42
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
oh ya it has been stooped....we don't use that anymore.....
even if it is because of that proxy,can u please tell me why the command isnt working only in the primary nameserver then?
i even tried the "yum --disableplugin=fastestmirror check-update -d6" as u said but it gave the following error:

Config time: 0.100
Yum Version: 3.2.22
Setting up Package Sacks


Could not retrieve mirrorlist http://mirrorlist.centos.org/?releas...86&repo=addons error was
[Errno 4] IOError: <urlopen error (110, 'Connection timed out')>
Error: Cannot retrieve repository metadata (repomd.xml) for repository: addons. Please verify its path and try again

Last edited by SarahGurung; 10-19-2011 at 05:04 AM.
 
Old 10-19-2011, 05:03 AM   #43
aazkan
Member
 
Registered: Jan 2008
Posts: 72

Rep: Reputation: 5
That curl command ought to have output either one

a. curl command not found (curl isn't installed)
b. an output similar to this

curl -s http://www.google.com/index.html
<HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">
<TITLE>302 Moved</TITLE></HEAD><BODY>
<H1>302 Moved</H1>
The document has moved
<A HREF="http://www.google.com.my/index.html">here</A>.
</BODY></HTML>

on the slave servers, can you try

set|grep -i http*proxy
grep -i http*proxy /etc/yum.conf

to check if there is any http proxy set or used.

This is kind a wild guess but can you also try

iptables -L -nv | grep -A 3 OUTPUT

on the master
 
Old 10-19-2011, 05:11 AM   #44
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
well when i tried those commands in slave servers,it didnt return any output..

and for iptables -L -nv | grep -A 3 OUTPUT inthe master it gave the following output:

Chain OUTPUT (policy ACCEPT 1717K packets, 165M bytes)
pkts bytes target prot opt in out source destination

Chain RH-Firewall-1-INPUT (2 references)
 
Old 10-19-2011, 05:12 AM   #45
aazkan
Member
 
Registered: Jan 2008
Posts: 72

Rep: Reputation: 5
From what you explained, something is blocking yum from fetching data from centOS mirror.
Without knowing how the server is connected in your LAN to WAN, i'm just making guesses what could have gone wrong (or right)

What kind bugs me is the curl did not give any output... almost tempted to suggest wget next
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nameserver help kshazad86 Linux - Server 4 04-15-2011 02:52 PM
How would one specify one's own nameserver? RandomTroll Linux - Networking 2 08-19-2010 09:08 PM
nameserver linux_2007_ Linux - Networking 4 03-18-2007 10:56 PM
which is my nameserver. bruse Linux - Networking 3 07-16-2005 01:45 AM
secondary nameserver dilberim82 Linux - Networking 2 10-24-2001 06:47 AM


All times are GMT -5. The time now is 11:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration