LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-25-2014, 06:18 AM   #1
New_in_linux
LQ Newbie
 
Registered: Jan 2014
Posts: 24

Rep: Reputation: Disabled
Not able to take backup of file size more than 1MB in tape


Hi All,

i am using HP LTO3 for data backup in tape but when i taking backup of more than 1MB files(using tar-1.23) its showing me the following error:

xyz@localhost# tar -cvf /dev/nst0 file1.tar
file1.tar
tar: /dev/nst0: Cannot write: Input/output error
tar: Error is not recoverable: exiting now

Please help me guys and thanks in advance..!!!!
 
Old 04-25-2014, 07:24 AM   #2
TenTenths
Senior Member
 
Registered: Aug 2011
Location: Dublin
Distribution: Centos 5 / 6 / 7
Posts: 2,166

Rep: Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751
What's the output of
Code:
mt -f /dev/st0 status
 
Old 04-25-2014, 08:22 AM   #3
New_in_linux
LQ Newbie
 
Registered: Jan 2014
Posts: 24

Original Poster
Rep: Reputation: Disabled
@TenTenths thanks for the quick reply...out of mt -f /dev/nst0 status

mt -f /dev/st0 status

SCSI 2 tape drive:
File number=0, block number=0, partition=0.
Tape block size 0 bytes. Density code 0x44 (LTO-3).
Soft error count since last status=0
General status bits on (41010000):
BOT ONLINE IM_REP_EN
 
Old 04-25-2014, 08:26 AM   #4
TenTenths
Senior Member
 
Registered: Aug 2011
Location: Dublin
Distribution: Centos 5 / 6 / 7
Posts: 2,166

Rep: Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751
Ok so you are using tar to create file1.tar and then attempting to send that to the tape?

Have you tried using /dev/st0 instead of /dev/nst0 ?
 
Old 04-25-2014, 08:33 AM   #5
New_in_linux
LQ Newbie
 
Registered: Jan 2014
Posts: 24

Original Poster
Rep: Reputation: Disabled
@TenTenths yes i tried that also it is showing the same error.

in dmesg i am getting this error

st0: Sense Key : Aborted Command [current]
st0: Add. Sense: Information unit iuCRC error detected


and

st0: <<vendor>> ASC=0xff ASCQ=0xffASC=0xff <<vendor>> ASCQ=0xff
Errata on LSI53C1030 occurredsc->req_bufflen=0x2800, xfer_cnt=0x00,difftransfer= 0x1400
st0: Sense Key : Medium Error [current]
Info fld=0x1400



output of cat /proc/scsi/scsi

Attached devices:
Host: scsi1 Channel: 00 Id: 00 Lun: 00
Vendor: NECVMWar Model: VMware IDE CDR10 Rev: 1.00
Type: CD-ROM ANSI SCSI revision: 05

Host: scsi2 Channel: 00 Id: 00 Lun: 00
Vendor: VMware Model: Virtual disk Rev: 1.0
Type: Direct-Access ANSI SCSI revision: 02

Host: scsi2 Channel: 00 Id: 01 Lun: 00
Vendor: HP Model: Ultrium 3-SCSI Rev: G54W
Type: Sequential-Access ANSI SCSI revision: 03

Host: scsi2 Channel: 00 Id: 02 Lun: 00
Vendor: HP Model: 1x8 autoloader Rev: 1.50
Type: Medium Changer ANSI SCSI revision: 03

Last edited by New_in_linux; 04-25-2014 at 08:35 AM.
 
Old 04-25-2014, 08:46 AM   #6
TenTenths
Senior Member
 
Registered: Aug 2011
Location: Dublin
Distribution: Centos 5 / 6 / 7
Posts: 2,166

Rep: Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751
Strange, that all looks normal to me.
 
Old 04-25-2014, 08:52 AM   #7
New_in_linux
LQ Newbie
 
Registered: Jan 2014
Posts: 24

Original Poster
Rep: Reputation: Disabled
@TenTenths did you get something(i mean what is error)from the output of dmesg..?????
 
Old 04-25-2014, 03:42 PM   #8
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Note that may or may have no help.
Some of those tapes need to be initialized and for lack of the correct word, homed.
 
Old 04-28-2014, 03:07 AM   #9
New_in_linux
LQ Newbie
 
Registered: Jan 2014
Posts: 24

Original Poster
Rep: Reputation: Disabled
@jefro thanks for your reply.

can you tell me how to initializad hp LTO-3 tape drive..????
 
  


Reply

Tags
centos6, linux, lto, scsitape, tape drive


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to backup more than one time on same tape using DLT tape? hocheetiong Linux - Newbie 3 01-30-2008 07:54 AM
Tape Backup file manager build atripathy86 Linux - Software 2 06-26-2006 08:08 AM
Using a DDS5 tape drive to restore from a DDS3 backup tape. AndrewCAtWayofthebit Linux - Hardware 1 05-14-2006 10:15 AM
Tape Backup File Warnings for OS X to RH9 MadTurki Linux - General 0 07-29-2004 10:26 AM


All times are GMT -5. The time now is 08:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration