LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-07-2009, 11:45 PM   #1
mathu
LQ Newbie
 
Registered: Aug 2009
Distribution: ubuntu linux(jaunty jackelope)
Posts: 4

Rep: Reputation: 0
not able to run 'compiz fusion' and 'avant window navigator'


i installed compiz fusion and avant window navigator but i am not able to run them.when i try to run awn this message is shown " Screen isn't composited. Please run compiz (-fusion) or another compositing manager".again iam not able to bring in various effects with compiz fusion.what should i do?please help me.
 
Old 08-07-2009, 11:56 PM   #2
sandbish
LQ Newbie
 
Registered: Apr 2008
Posts: 25

Rep: Reputation: 15
Hey mathu may I know which distro r u using??and whats your graphics card(if any) or your mobo??
 
Old 08-08-2009, 07:09 AM   #3
mathu
LQ Newbie
 
Registered: Aug 2009
Distribution: ubuntu linux(jaunty jackelope)
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by sandbish View Post
Hey mathu may I know which distro r u using??and whats your graphics card(if any) or your mobo??
Thank you for the response.I use ubuntu 9.04(jaunty jackelope).No graphics card.Adding extra info(I don't know whether this would be useful)n giving command 'lspci' I get the following message:

"00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:09.0 Communication controller: Conexant Systems, Inc. HSF 56k HSFi Modem (rev 01)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] (rev 01)"
 
Old 08-08-2009, 07:26 AM   #4
karamarisan
Member
 
Registered: Jul 2009
Location: Illinois, US
Distribution: Fedora 11
Posts: 374

Rep: Reputation: 55
The Ubuntu forums (I'm reading from here) suggest this should be possible. First off, which xorg driver are you using? You should be able to tell from your xorg.conf. Not sure where that's located in Ubuntu - somewhere under /etc, of course. If it's not that one, try installing and switching to that one.

(Back up that xorg.conf first - it's a bitch of a file to mess up.)
 
Old 08-08-2009, 09:47 AM   #5
sandbish
LQ Newbie
 
Registered: Apr 2008
Posts: 25

Rep: Reputation: 15
proprietary driver installation

first make sure that your video card is installed properly...jst right click on desktop->change desktop background->visual effet(tab)

select extra

then if any proprietary driver is needed to be installed...let it be.

and then try to set compiz configs.

hope this will work.
 
Old 08-08-2009, 02:33 PM   #6
mathu
LQ Newbie
 
Registered: Aug 2009
Distribution: ubuntu linux(jaunty jackelope)
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by karamarisan View Post
The Ubuntu forums (I'm reading from here) suggest this should be possible. First off, which xorg driver are you using? You should be able to tell from your xorg.conf. Not sure where that's located in Ubuntu - somewhere under /etc, of course. If it's not that one, try installing and switching to that one.

(Back up that xorg.conf first - it's a bitch of a file to mess up.)
giving the contents of the xorg.conf file
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
 
Old 08-08-2009, 02:36 PM   #7
mathu
LQ Newbie
 
Registered: Aug 2009
Distribution: ubuntu linux(jaunty jackelope)
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by sandbish View Post
first make sure that your video card is installed properly...jst right click on desktop->change desktop background->visual effet(tab)

select extra

then if any proprietary driver is needed to be installed...let it be.

and then try to set compiz configs.

hope this will work.
i do not think that i have a video card.iselected option 'extra'after right clicking on desktop and i received this"desktop effects could not be loaded".
 
Old 08-08-2009, 02:44 PM   #8
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
I am afraid that won't work if you only have that onboard via unichrome graphics chip. Unless things have changed dramatically (hard to imagine), it simply does not support compiz.

You may be able to get awn working if you enable metacity compositing:
Sytem > Preferences > Main Menu > under System Tools, check Configuration editor.
Then, from the menu, bring up Configuration Editor and under apps > metacity > general, check "compositing manager".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Avant Window Navigator Issue stoneysilence Linux - Desktop 1 03-19-2008 12:53 PM
tester 4 - avant-window navigator namida12 MEPIS 0 02-01-2008 10:32 PM
Avant Window Navigator installing troubles ZparK Linux - Software 1 01-11-2008 08:51 PM
I can't get avant-window-navigator to run properly jobbe Linux - Software 2 09-15-2007 02:43 PM
Avant-window-navigator on Ubuntu ogee Linux - Desktop 0 02-19-2007 11:11 PM


All times are GMT -5. The time now is 03:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration