LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2012, 05:04 AM   #1
dwivedi_apurva@yahoo.com
LQ Newbie
 
Registered: Aug 2012
Location: India
Posts: 2

Rep: Reputation: Disabled
Thumbs down Not able to rlogin to remote server?


please find below the details of my system.and outputs , these are the few things which i had done , but still , so please have look and waiting for some advice which can help me out from this problem.

rsh package installed
rsh-0.17-25.1
rsh-server-0.17-25.1

chkconfig --list rsh
rsh on

auth sufficient pam_rhosts_auth.so

append /etc/securetty with "rsh" in bottom of the file.
############
[root@veritas ~]# rlogin veritas2
veritas2: host unknown
Trying krb4 rlogin...
veritas2: host unknown
trying normal rlogin (/usr/bin/rlogin)
veritas2: Unknown host
##############
[root@veritas ~]# /usr/bin/rsh 192.168.20.129
192.168.20.129: No route to host
[root@veritas ~]# ping 192.168.20.129
PING 192.168.20.129 (192.168.20.129) 56(84) bytes of data.
64 bytes from 192.168.20.129: icmp_seq=0 ttl=64 time=0.630 ms
64 bytes from 192.168.20.129: icmp_seq=1 ttl=64 time=1.02 ms

--- 192.168.20.129 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.630/0.825/1.020/0.195 ms, pipe 2
[root@veritas ~]# ssh root@192.168.20.129
root@192.168.20.129's password:
##########
$PATH
-bash: /usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin:
 
Old 08-04-2012, 07:31 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530
Apart from usage of any r.* services being frowned upon this isn't a security issue so I've moved your thread to the Newbie forum.

Quote:
Originally Posted by dwivedi_apurva@yahoo.com View Post
Code:
[root@veritas ~]# rlogin veritas2
veritas2: host unknown
... the "veritas2" host name does not resolve to an IP address, locally (/etc/hosts, host-based name server) or remotely (host-based forwarding name server, any remote name servers).


Quote:
Originally Posted by dwivedi_apurva@yahoo.com View Post
Code:
[root@veritas ~]# ping 192.168.20.129
# (..)
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.630/0.825/1.020/0.195 ms, pipe 2
... but you can throw ICMP messages at it to show it's alive.


Quote:
Originally Posted by dwivedi_apurva@yahoo.com View Post
Code:
[root@veritas ~]# ssh root@192.168.20.129
root@192.168.20.129's password:
... and you can SSH to it.


Quote:
Originally Posted by dwivedi_apurva@yahoo.com View Post
Code:
[root@veritas ~]# /usr/bin/rsh 192.168.20.129
192.168.20.129: No route to host
... 'tcptraceroute 192.168.20.129 514' would have been more convenient because it shows the route that actual traffic takes between hosts, if the remote port is open and if you have ensured it is open if it's denied in /etc/hosts.deny and or the firewall.
 
Old 08-04-2012, 07:41 AM   #3
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,027

Rep: Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845
maybe devs cut out support for rlogin because it is ancient and insecure. have you considered ssh with keys ?

also, at least with ssh, root login is disabled by default.

Last edited by schneidz; 08-04-2012 at 07:45 AM.
 
Old 08-04-2012, 09:57 AM   #4
dwivedi_apurva@yahoo.com
LQ Newbie
 
Registered: Aug 2012
Location: India
Posts: 2

Original Poster
Rep: Reputation: Disabled
cat /etc/hosts output
192.168.20.128 veritas.test.com
192.168.20.129 veritas2.test.com

no entry is there in /etc/hosts.deny

For Veritas Cluster Is is mandatory to have rlogin enabled or it can also work with passwordless ssh ????
 
Old 08-04-2012, 10:20 AM   #5
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530Reputation: 3530
Great. You managed to check 2 out of 4 things.
 
Old 08-04-2012, 12:46 PM   #6
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
To follow up on unSpawn's post: run iptables -L on the machine and see if rsh/rlogin is being blocked by the firewall.

I'd be shocked if Veritas did not work over passwordless SSH, but I've never used it so I don't really know.
 
Old 08-04-2012, 12:50 PM   #7
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,027

Rep: Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845
Quote:
Originally Posted by dwivedi_apurva@yahoo.com View Post
cat /etc/hosts output
For Veritas Cluster Is is[sic] mandatory to have rlogin enabled or it can also work with passwordless ssh ????
not sure what a veritas cluster is (is it like beowolf ?) but if it is linux it probably has sshd turned on by default (which has nothing to do with rlogin).

what i know of rlogin was that it was a protocol used for logging in remotely to systems. then it was replaced by telnet which added the security of needing a password to login to remote systems. and then ssh replaced that by encrypting the channel and optionally replacing passwords with keys.
 
Old 08-05-2012, 08:58 PM   #8
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
There's a good article here about why not to use rsh+friends, and how to replace them with the ssh equivalents http://www.informit.com/articles/art...p=169465&rll=1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] cannot connect to x server in sun solris from linux through rlogin kingston Linux - Newbie 12 04-29-2009 11:21 AM
RHEL Server 5.1 rlogin dnalex12 Linux - Newbie 0 09-22-2008 03:53 AM
set up the rlogin daemon & redhat's super-server adilturbo Linux - Networking 4 10-18-2006 07:08 PM
Remote connection using rlogin santhoshkv78 Linux - Security 1 04-18-2005 06:26 AM
remote login, rlogin is the solution? sirpelidor Linux - Newbie 7 02-19-2004 06:35 AM


All times are GMT -5. The time now is 11:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration