LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-02-2011, 11:33 PM   #1
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Rep: Reputation: 36
Not able to log into single user mode.


Hi as per the article given.
http://www.cyberciti.biz/faq/grub-bo...gle-user-mode/

I m modifying the boot entry

Code:
grub edit> kernel /vmlinuz-2.6.18-92.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet Single
and then booting from it by pressing b.
However the machine is getting booted into runlevel 5.

if the above entry is modified as
Code:
grub edit> kernel /vmlinuz-2.6.18-92.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet 1
then it goes into runlevel 1.

I just want to know why Single word is not working?
and
Is booting the system into runlevel 1 is same as single user mode?

Last edited by pinga123; 03-02-2011 at 11:35 PM.
 
Old 03-02-2011, 11:40 PM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Have you tried using "single" and not "Single?" (Notice I didn't capitalize the S in single....)
 
Old 03-02-2011, 11:46 PM   #3
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by corp769 View Post
Have you tried using "single" and not "Single?" (Notice I didn't capitalize the S in single....)
Yes i tried that but machine get booted to an environment which looks similar to single user mode but when i type runlevel is says unknown.
Code:
#runlevel
unknown
 
Old 03-02-2011, 11:50 PM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Try it by adding the following and see if it helps:
Code:
rw init=/bin/bash
 
Old 03-02-2011, 11:55 PM   #5
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by corp769 View Post
Try it by adding the following and see if it helps:
Code:
rw init=/bin/bash
modified the entry as below
Code:
grub edit> kernel /vmlinuz-2.6.18-92.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet rw init=/bin/bash single
Now i m getting an error as
Code:
/bin/bash :single : no such file or directory
Kernel panic - Not syncing attempting to kill init!

Last edited by pinga123; 03-02-2011 at 11:59 PM.
 
Old 03-03-2011, 12:03 AM   #6
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
I didn't tell you to add "rw init=/bin/bash single"... I told you to add the following:
Code:
rw init=/bin/bash
 
Old 03-03-2011, 12:09 AM   #7
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by corp769 View Post
I didn't tell you to add "rw init=/bin/bash single"... I told you to add the following:
Code:
rw init=/bin/bash
i apologize it was my mistake.
I have tried with following parameter
Code:
grub edit> kernel /vmlinuz-2.6.18-92.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet rw init=/bin/bash
Now i m at bash prompt.
Code:
bash-3.2#runlevel
bash :runlevel: command not found
Can you please explain the use of rw init=/bin/bash.
 
Old 03-03-2011, 12:15 AM   #8
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
It just gives you a simple bash shell; single user mode for minimal system maintenance. And most likely /usr is not mounted; Type "mount /usr" and you should be set.
 
1 members found this post helpful.
Old 03-03-2011, 12:45 AM   #9
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by corp769 View Post
It just gives you a simple bash shell; single user mode for minimal system maintenance. And most likely /usr is not mounted; Type "mount /usr" and you should be set.
Ok thanks for the explaination.
But my question is still unanswered .
Why m i not able to login into single user mode using Single or single keyword(Is this method not universal)?
Is runlevel 1 is similar to single user mode?
do i need to apply various parameters to log into single user mode?
Which method is universal?
 
Old 03-03-2011, 12:58 AM   #10
sumeet inani
Member
 
Registered: Oct 2008
Posts: 898
Blog Entries: 26

Rep: Reputation: 49
for grub2
Quote:
1. If you have Grub 2 set to boot without displaying the menu at all, hold the SHIFT key down until the menu displays. (In Grub it was the ESC key.)
2. Press any key once the menu is displayed to 'freeze' it. Then arrow to the kernel you want to boot.
3. Press "e"
4. Scroll to the end of the "linux /boot/vmlinuz...." line. If displayed, remove "quiet" and/or "splash". Add the word "single" to the end of the line.
5. Press CTRL-X to boot to the Recovery menu.
from http://ubuntuforums.org/showthread.php?t=1195275
 
Old 03-03-2011, 01:28 AM   #11
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by sumeet inani View Post
Finding it very difficult no newbie like me.
are there diff versions of grub available as i m not able to boot using ctrl +x after editing the lines?

Last edited by pinga123; 03-03-2011 at 01:30 AM.
 
Old 03-03-2011, 01:54 AM   #12
sumeet inani
Member
 
Registered: Oct 2008
Posts: 898
Blog Entries: 26

Rep: Reputation: 49
Quote:
"Single-user mode was traditionally init level 1. It brought down all
multiuser and remote login processes and made sure the system was
running a minimal complement of software. Since single-user mode
provides root access to the system, however, administrators wanted
the system to prompt for the root password whenever it was booted
into single-user mode. The S run level was created to address this
need: it spawns a process that prompts for the root password. On
Linux, the S level serves only this purpose and is not a destination
in itself."
from http://marc.info/?l=redhat-list&m=102242207300936&w=2

Last edited by sumeet inani; 03-03-2011 at 01:59 AM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Emergency mode can mount the HDD with FS error but not in rescue or single user-mode kayod_jj Linux - Newbie 3 12-01-2010 07:03 PM
single user mode under vxfs mode enabled. UltraSoul Solaris / OpenSolaris 1 06-27-2009 09:48 PM
single user mode aashishdhabarde Linux - Kernel 1 01-31-2008 05:11 AM
Single User mode isolvesystems Linux - Newbie 5 10-03-2007 08:05 PM
What is single-user mode?? rbanonuevo Linux - Newbie 4 01-28-2002 12:17 PM


All times are GMT -5. The time now is 08:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration