LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-08-2010, 07:37 AM   #1
darsh019
LQ Newbie
 
Registered: Dec 2010
Posts: 4

Rep: Reputation: 0
Not able to launch GUI based Installer on Linux machine.


Hello friends,

Please try to provide a solution for this question below. I've tried a set of things with no improvement.

When i tried to launch 2012 installer using GUI based command , it gives the following error message :-

PATH :- /u01/app...../../StartGUI.sh

Error:-

Script TMPDIR="."
Script dir="./inst"
Current operating system:"Linux"
Release="RedHatEnterpriseServer"
DSY_OS="linux_a64"
DSY_LIBPATH_VARNAME="LD_LIBRARY_PATH"
DSY_LIBPATH_VARNAME_value="${LD_LIBRARY_PATH}"
./inst/linux_a64/code/bin/DSYInsSetupUI: error while loading shared libraries: libXm.so.4: cannot open shared object file: No such file or directory



It is Observerd that ( but not sure ):-


[root@CEXXXXXI /]# find . | grep libXm.so*

./u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs/libXm.so
./u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs/libXm.so.3

it is looking for = > ./u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs/libXm.so.4.


I tried soft linking libXm.so.3 with libXm.so.4 but it doesn't help. Also tried downloading Openmotif and installing, its asking for many dependency packages. The following packages are also reported to be missing:-

libXp.so.6(64 bit)

libXmu.so.6

libXp.so.6

libXmu-devel


When i try to download and run rpm on these, it gives dependency problem. And these dependencies seem to be deadlocked. I don not understand how i can go about it..
 
Old 12-08-2010, 08:23 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,934

Rep: Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692
Quote:
Originally Posted by darsh019 View Post
Hello friends,
Please try to provide a solution for this question below. I've tried a set of things with no improvement. When i tried to launch 2012 installer using GUI based command , it gives the following error message :-

PATH :- /u01/app...../../StartGUI.sh
Error:-
Script TMPDIR="."
Script dir="./inst"
Current operating system:"Linux"
Release="RedHatEnterpriseServer"
DSY_OS="linux_a64"
DSY_LIBPATH_VARNAME="LD_LIBRARY_PATH"
DSY_LIBPATH_VARNAME_value="${LD_LIBRARY_PATH}"
./inst/linux_a64/code/bin/DSYInsSetupUI: error while loading shared libraries: libXm.so.4: cannot open shared object file: No such file or directory

It is Observerd that ( but not sure ):-
[root@CEXXXXXI /]# find . | grep libXm.so*
./u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs/libXm.so
./u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs/libXm.so.3

it is looking for = > ./u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs/libXm.so.4. I tried soft linking libXm.so.3 with libXm.so.4 but it doesn't help. Also tried downloading Openmotif and installing, its asking for many dependency packages. The following packages are also reported to be missing:-

libXp.so.6(64 bit)
libXmu.so.6
libXp.so.6
libXmu-devel


When i try to download and run rpm on these, it gives dependency problem. And these dependencies seem to be deadlocked. I don not understand how i can go about it..
You don't say what version/distro of Linux you're doing this on, so it's hard to be specific. Short answer is, it looks like you're missing part of your X windows installation, specifially the Openmotif libraries. Again, you don't mention version/distro of Linux, so can't tell you which package, or how to download/install it.

And since this is an Oracle issue....have you called Oracle support, since you're paying for it?
 
1 members found this post helpful.
Old 12-09-2010, 12:54 AM   #3
darsh019
LQ Newbie
 
Registered: Dec 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Hello friend,


Thank you for your reply. The machine is a redhat 5.3 version. I tried downloading and installing Openmotif but it fails. Below is the output of trying to install the rpm package.
Code:
[root@CESRHDEI motif]# rpm -i openmotif-2.3.2-5.1.svn.fc12.ccrma.x86_64.rpm
warning: openmotif-2.3.2-5.1.svn.fc12.ccrma.x86_64.rpm: Header V3 DSA signatu
 NOKEY, key ID 68d9802a
error: Failed dependencies:
        libXp.so.6()(64bit) is needed by openmotif-2.3.2-5.1.svn.fc12.ccrma.x
64
        libc.so.6(GLIBC_2.11)(64bit) is needed by openmotif-2.3.2-5.1.svn.fc1
crma.x86_64
        libc.so.6(GLIBC_2.7)(64bit) is needed by openmotif-2.3.2-5.1.svn.fc12
rma.x86_64
        rpmlib(FileDigests) <= 4.6.0-1 is needed by openmotif-2.3.2-5.1.svn.f
.ccrma.x86_64
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by openmotif-2.3.2-5.1.svn.fc1
crma.x86_64

Also i haven't contacted oracle because i assume this is a missing OS package case. Please correct me if i'm wrong.
Thanks..
 
Old 12-09-2010, 01:54 AM   #4
prodev05
Member
 
Registered: Jul 2009
Location: Planet Earth
Distribution: Unix & Linux Variants
Posts: 304

Rep: Reputation: 20
darsh019

Before applying the patch, You have to read the release notes for the patch?. The below mentioned shared objects are the mandatory libraries related to "libXP" for running oracle GUI installer. Install the LibXP libraries and again start the installation with the script.

libXp.so.6(64 bit)
libXmu.so.6
libXp.so.6
libXmu-devel


Thanks & Regards
 
1 members found this post helpful.
Old 12-09-2010, 08:23 AM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,934

Rep: Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692
Quote:
Originally Posted by darsh019 View Post
Hello friend,

Thank you for your reply. The machine is a redhat 5.3 version. I tried downloading and installing Openmotif but it fails. Below is the output of trying to install the rpm package.
Code:
[root@CESRHDEI motif]# rpm -i openmotif-2.3.2-5.1.svn.fc12.ccrma.x86_64.rpm
warning: openmotif-2.3.2-5.1.svn.fc12.ccrma.x86_64.rpm: Header V3 DSA signatu
 NOKEY, key ID 68d9802a
error: Failed dependencies:
        libXp.so.6()(64bit) is needed by openmotif-2.3.2-5.1.svn.fc12.ccrma.x
64
        libc.so.6(GLIBC_2.11)(64bit) is needed by openmotif-2.3.2-5.1.svn.fc1
crma.x86_64
        libc.so.6(GLIBC_2.7)(64bit) is needed by openmotif-2.3.2-5.1.svn.fc12
rma.x86_64
        rpmlib(FileDigests) <= 4.6.0-1 is needed by openmotif-2.3.2-5.1.svn.f
.ccrma.x86_64
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by openmotif-2.3.2-5.1.svn.fc1
crma.x86_64
Also i haven't contacted oracle because i assume this is a missing OS package case. Please correct me if i'm wrong.
Thanks..
It COULD be, but could also be resolved via Oracle's support, since they provide some things like this on their installation media. There may be a way to use what they ship you.

Since you're using RHEL, you should contact RedHat support then, for system packages. And don't install them with "rpm -i", use "yum install <package>", which will resolve the dependencies for you, and install them. Since you're paying for RHEL support, they can walk you through all this.
 
Old 12-09-2010, 08:21 PM   #6
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
This may also help http://kbase.redhat.com/faq/docs/DOC-2531
 
Old 12-10-2010, 12:44 AM   #7
darsh019
LQ Newbie
 
Registered: Dec 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Unhappy

Quote:
Originally Posted by prodev05 View Post
darsh019

Before applying the patch, You have to read the release notes for the patch?. The below mentioned shared objects are the mandatory libraries related to "libXP" for running oracle GUI installer. Install the LibXP libraries and again start the installation with the script.

libXp.so.6(64 bit)
libXmu.so.6
libXp.so.6
libXmu-devel


Thanks & Regards
Dear prodev05,

could you please let me know where i can find these packages? Because i tried to install all available rpms on the OS DVD which start with openmotif and Lib* but all of them either already installed or have dependancy issues. This may sound silly.. please also tell me how can i get the missing LibXm packages. I do not want to contact RHEL or Oracle support since it may be frowned upon


Thanks,
Darshan
 
Old 12-10-2010, 01:05 AM   #8
prodev05
Member
 
Registered: Jul 2009
Location: Planet Earth
Distribution: Unix & Linux Variants
Posts: 304

Rep: Reputation: 20
You have to go to rpm.pbone.net or rpm.org and download rpm's by comparing the shared objects.

If you are just practicing for your learning then no problem. Because it would take more time to solve the library dependencies.(take hell lot of time :P but a good learning)

Else I would advice you to buy a RHEL License.( you can fix the issue within time frame)


Best Regards,

Last edited by prodev05; 12-10-2010 at 01:21 AM. Reason: small correction
 
Old 12-10-2010, 08:23 AM   #9
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,934

Rep: Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692
Quote:
Originally Posted by darsh019 View Post
Dear prodev05,

could you please let me know where i can find these packages? Because i tried to install all available rpms on the OS DVD which start with openmotif and Lib* but all of them either already installed or have dependancy issues. This may sound silly.. please also tell me how can i get the missing LibXm packages. I do not want to contact RHEL or Oracle support since it may be frowned upon
Why, exactly, would it be 'frowned upon' to contact tech support, when you're PAYING FOR IT???

Seriously, if you've got RHEL and Oracle, you've got support for both. You could have had this fixed within half an hour with one phone call....I'd frown more upon someone taking two days to fix a problem that could have been resolved in, at most, an hour.
 
Old 12-13-2010, 02:16 AM   #10
darsh019
LQ Newbie
 
Registered: Dec 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Yes you're right.. I've called RHEL support to come and fix it. Thanks TB0ne
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GUI based package-manager installation on console based linux kevinchkin Linux - Software 2 07-14-2009 01:25 AM
open GUI on Linux machine from other machine (Windows or Linux) vietdoclap Linux - Newbie 3 04-25-2008 02:14 AM
Not able to launch my linux FC4 GUI while I installed it on my new HP Pavillion salil.mehta Linux - Laptop and Netbook 1 08-07-2006 04:03 AM
LXer: Google to launch Linux-based PC LXer Syndicated Linux News 1 01-05-2006 02:40 PM
What Does The UT2004 Installer Do Behind The Fancy GUI Installer? Tsuroerusu Linux - Games 2 09-09-2004 03:37 PM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration