LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2011, 01:06 AM   #1
varunb
Member
 
Registered: Mar 2011
Location: Bangalore, INDIA
Distribution: opensuse, fedora
Posts: 135
Blog Entries: 1

Rep: Reputation: 1
Question Not able to boot/login from Desktop, only login is happening through failsafe


Hi,

I am using opensuse 11.3 in my DELL LAPTOP latitude e5510,
Actually my LCD screen got bad, i was not getting display at all, so i had to replace the screen.
After replacing i am facing the prob like when ever i boot/reboot i am not able to boot from desktop. By default it loads from Desktop and all of a sudden screen get disappears.
if i press ESC button it wont go to log screen, either it wont take me to CLI if i press (ctrl+alt F1 or F2). Laptop screen gets stuck with a dark blueish screen.


But if I boot from failsafe it boots up and i will be able to use.

so what i did is i tried formatting and reinstalling opensuse 11.3 itself, But still the same issuse. .

anyone can help???

Last edited by varunb; 12-07-2011 at 01:13 AM.
 
Old 12-07-2011, 01:50 AM   #2
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
Paste result of this command
Code:
$cat /boot/grub/menu.lst
 
Old 12-07-2011, 02:56 AM   #3
varunb
Member
 
Registered: Mar 2011
Location: Bangalore, INDIA
Distribution: opensuse, fedora
Posts: 135
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by raju.mopidevi View Post
Paste result of this command
Code:
$cat /boot/grub/menu.lst
Code:
linux-gs03:~ # cat /boot/grub/menu.lst
# Modified by YaST2. Last modification on Wed Dec  7 12:38:49 IST 2011
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.3 - 2.6.34-12
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-SAMSUNG_HM500JJ_S2APJ1MB102194-part2 resume=/dev/disk/by-id/ata-SAMSUNG_HM500JJ_S2APJ1MB102194-part3 splash=silent quiet showopts vga=0x317
    initrd /boot/initrd-2.6.34-12-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.3 - 2.6.34-12
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-SAMSUNG_HM500JJ_S2APJ1MB102194-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
    initrd /boot/initrd-2.6.34-12-desktop

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd0,0)
    chainloader +1
 
Old 12-07-2011, 03:33 AM   #4
ongte
Member
 
Registered: Jun 2009
Location: Penang, Malaysia
Distribution: Mageia, CentOS, Ubuntu
Posts: 468

Rep: Reputation: 72
The display change probably just messed up your X configuration.

Try reading this guide here.
 
Old 12-07-2011, 03:51 AM   #5
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
Edit your /boot/grub/menu.lst and change vga=0x317 to vga=788

These are the general codes for vga

Code:
 Colours   640x400 640x480 800x600 1024x768 1152x864 1280x1024 1600x1200
  -------+--------------------------------------------------------------
  4 bits |    ?       ?     0x302      ?        ?        ?         ?
  8 bits |  0x300   0x301   0x303    0x305    0x161    0x307     0x31C
 15 bits |    ?     0x310   0x313    0x316    0x162    0x319     0x31D
 16 bits |    ?     0x311   0x314    0x317    0x163    0x31A     0x31E
 decimal |           d785    d788     d791
 24 bits |    ?     0x312   0x315    0x318      ?      0x31B     0x31F
 decimal |           d786    d789     d792
 32 bits |    ?       ?       ?        ?      0x164      ?

Last edited by raju.mopidevi; 12-07-2011 at 04:00 AM.
 
Old 12-07-2011, 04:44 AM   #6
varunb
Member
 
Registered: Mar 2011
Location: Bangalore, INDIA
Distribution: opensuse, fedora
Posts: 135
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Unhappy

Quote:
Originally Posted by raju.mopidevi View Post
Edit your /boot/grub/menu.lst and change vga=0x317 to vga=788

These are the general codes for vga

Code:
 Colours   640x400 640x480 800x600 1024x768 1152x864 1280x1024 1600x1200
  -------+--------------------------------------------------------------
  4 bits |    ?       ?     0x302      ?        ?        ?         ?
  8 bits |  0x300   0x301   0x303    0x305    0x161    0x307     0x31C
 15 bits |    ?     0x310   0x313    0x316    0x162    0x319     0x31D
 16 bits |    ?     0x311   0x314    0x317    0x163    0x31A     0x31E
 decimal |           d785    d788     d791
 24 bits |    ?     0x312   0x315    0x318      ?      0x31B     0x31F
 decimal |           d786    d789     d792
 32 bits |    ?       ?       ?        ?      0x164      ?

yes i edited to vga=788, and i selected desktop login, it showed like
undefined video mode number :788

and remains the same issue.
 
Old 12-07-2011, 06:23 AM   #7
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
I found this "Holding down ctrl to access grub the following can be used to modify the KMS behaviour. These can also be added to /boot/grub/grub.conf

All drivers: nomodeset - this will disable the kernel modesetting feature and drop the user back to the old X.org infrastructure and behaviour." But I am not sure, because I didn't test on my system. check this link
 
Old 12-07-2011, 07:55 AM   #8
varunb
Member
 
Registered: Mar 2011
Location: Bangalore, INDIA
Distribution: opensuse, fedora
Posts: 135
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Unhappy

Quote:
Originally Posted by raju.mopidevi View Post
I found this "Holding down ctrl to access grub the following can be used to modify the KMS behaviour. These can also be added to /boot/grub/grub.conf

All drivers: nomodeset - this will disable the kernel modesetting feature and drop the user back to the old X.org infrastructure and behaviour." But I am not sure, because I didn't test on my system. check this link
Hi

i added

All drivers: nomodeset

line in /boot/grub/grub.conf , but no luck issue remains the same. .
 
Old 12-07-2011, 09:13 AM   #9
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
This is my /boot/grub/menu.lst
Code:
 # Modified by YaST2. Last modification on Wed Dec  7 20:25:26 IST 2011
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,8)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.2 - 2.6.31.5-0.1
    root (hd0,8)
    kernel /boot/vmlinuz-2.6.31.5-0.1-desktop root=/dev/disk/by-id/scsi-SATA_FUJITSU_MHV2060_NW9JT6B2BCR6-part9 splash=silent vga=0x317
    initrd /boot/initrd-2.6.31.5-0.1-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.2 - 2.6.31.5-0.1
    root (hd0,8)
    kernel /boot/vmlinuz-2.6.31.5-0.1-desktop root=/dev/disk/by-id/scsi-SATA_FUJITSU_MHV2060_NW9JT6B2BCR6-part9 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe
    initrd /boot/initrd-2.6.31.5-0.1-desktop

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd0,0)
    chainloader +1
I have modified above code vga=ask, then it requested me during the boot time. Try if it works

Last edited by raju.mopidevi; 12-07-2011 at 09:33 AM.
 
Old 12-07-2011, 11:34 AM   #10
asimba
Member
 
Registered: Mar 2005
Location: 127.0.0.0
Distribution: Red Hat / Fedora
Posts: 355

Rep: Reputation: 42
try renaming .kde/gnome settings folder to something else and reboot.

location of this folder is usually

/home/<username>/.kdesomething or .kde


If you havent messed with anything else and hardware is good - it should come up as expected.

I apologize for not being specific. It has been along time since I fixed similar problem
 
Old 12-11-2011, 11:17 PM   #11
varunb
Member
 
Registered: Mar 2011
Location: Bangalore, INDIA
Distribution: opensuse, fedora
Posts: 135
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Wink

Quote:
Originally Posted by asimba View Post
try renaming .kde/gnome settings folder to something else and reboot.

location of this folder is usually

/home/<username>/.kdesomething or .kde


If you havent messed with anything else and hardware is good - it should come up as expected.

I apologize for not being specific. It has been along time since I fixed similar problem

i tried removing .kde4 folder and .kdm folder, but it dint make any difference. .
anyways i have ordered to replace a new screen and mother board, i hope it should boot from desktop.
Will update you once it is done. .
 
Old 12-16-2011, 01:15 AM   #12
varunb
Member
 
Registered: Mar 2011
Location: Bangalore, INDIA
Distribution: opensuse, fedora
Posts: 135
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Hi,

problem solved. .

I asked to replace the LCD screen with same model number as the old LCD screen and it worked properly.
When they changed the LCD screen for the first time they had put the LCD screen of different model no., which was not supporting to opensuse11.3 on DELL LATITUDE e5510 series.

Anywayz thanks for all your help. .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Login fails on 'std' session, works on 'failsafe' - how to fix? bjorke Linux - Newbie 3 05-26-2009 10:17 AM
Save X desktop between login (boot) billmoss Ubuntu 4 02-19-2009 01:47 AM
XSM - Failsafe Login KDM ???? cannot log in Trauma Linux - General 0 01-08-2007 11:30 PM
Can't get to Desktop; Initial Boot of SuSe 8.2 won't let me past Login Page bramfoto Linux - General 2 10-09-2003 11:46 PM
Can't get to Desktop; stopped at Login Page after Initial boot after install of SuSe bramfoto Linux - Software 1 10-09-2003 08:05 PM


All times are GMT -5. The time now is 09:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration