LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-17-2003, 10:14 PM   #1
GT_Onizuka
Member
 
Registered: Aug 2003
Location: Atlanta
Distribution: Debian, OS X
Posts: 711

Rep: Reputation: 30
normal user cannot edit vfat filesystem


currently my fstab has this entry for my Windows Partition

Quote:
/dev/hda1 /mnt/windowsC vfat uid=500,gid=500,umask=0000,auto,owner,rw 0 0
the uid and gid are for my normal user, however, at boot-up i cannot add/remove files from the windows partition unless i am root. what am i doing wrong?
 
Old 10-17-2003, 10:27 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
" i cannot add/remove files from the windows partition unless i am root."

Try setting the permissions for /mnt/windowsC to 777:
login as root
chmod 777 /mnt/windowsC


___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 10-17-2003, 10:32 PM   #3
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
[Just guessing,I don't have vfat partiton] I think the (uid,gid) flags and the owner flags contradict eachother. Try dropping out the owner flag. Also check that you have not mounted the partition to two different places. You can also try to drop auto flag,add user flag and mount as a normal user.
 
Old 10-17-2003, 11:36 PM   #4
GT_Onizuka
Member
 
Registered: Aug 2003
Location: Atlanta
Distribution: Debian, OS X
Posts: 711

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by ToniT
[Just guessing,I don't have vfat partiton] I think the (uid,gid) flags and the owner flags contradict eachother. Try dropping out the owner flag. Also check that you have not mounted the partition to two different places. You can also try to drop auto flag,add user flag and mount as a normal user.
yep that did it! thanks a bunch man!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
write permissions in /etc/fstab for vfat filesystem btb Linux - Newbie 5 10-24-2005 02:37 PM
Can't boot XP, can only mount ntfs filesystem as vfat bsm80 Linux - Hardware 4 05-06-2005 06:56 PM
Filesystem other than vfat on pc card? JohnKFT Slackware 1 04-03-2005 01:54 PM
Can't mount Vfat or Msdos Filesystem!! RKris Linux - Software 6 06-19-2002 05:58 PM
Mounting a vfat filesystem in RH 7.2 M.I. Linux - General 8 11-28-2001 10:06 PM


All times are GMT -5. The time now is 04:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration